Emerging Member
djth
Posts: 67
Registered: ‎09-16-2010
Posts: 67
Kudos: 1
Registered: 09-16-2010

WDS and DHCP

I have setup a wds link between a routerstation pro with xr2 cards and a nanostation loco 2.

Everything is working ok but for some reason the bridge of the ns2loco does not get an ip from the dhcp server neither anything connected to the ns2L. Not even a computer connected to the lan of the ns2l.
If I configure the ns2l as station wds it gets the ip correctly.

Here is the corresponding routerstation code for wireless file

config wifi-device wifi2
option type atheros
option channel 6
option hwmode 11bg
option txpower 15
config wifi-iface
option device wifi2
option network lan
option mode ap
option wds 1
option ssid GT
option encryption none
config wifi-iface
option device wifi2
option network lan
option mode wds
option ssid GT-CENTER
option bssid 00:15:6D:7A:10:61




here is the dhcp file (I have a dhcp server connected trough the lan of routerstation pro)

option localise_queries 1
option local '/lan/'
option domain 'lan'
option expandhosts 1
option nonegcache 0
option authoritative 1
option readethers 1
option leasefile '/tmp/dhcp.leases'
option resolvfile '/tmp/resolv.conf.auto'
#list server '/mycompany.local/1.2.3.4'
#option nonwildcard 0
#option interfaces ''

config dhcp lan
option interface lan
option ignore 1
option start 100
option limit 150
option leasetime 12h

config dhcp wan
option interface wan
option ignore 1



and here is the firewall file


config defaults
option syn_flood 1
option input ACCEPT
option output ACCEPT
option forward ACCEPT

config zone
option name lan
option input ACCEPT
option output ACCEPT
option forward ACCEPT

config zone
option name wan
option input ACCEPT
option output ACCEPT
option forward ACCEPT
option masq 1

config forwarding
option src lan
option dest wan
option mtu_fix 1


# include a file with users custom iptables rules
config include
option path /etc/firewall.user


### EXAMPLE CONFIG SECTIONS
# do not allow a specific ip to access wan
#config rule
# option src lan
# option src_ip 192.168.45.2
# option dest wan
# option proto tcp
# option target REJECT

# block a specific mac on wan
#config rule
# option dest wan
# option src_mac 00:11:22:33:44:66
# option target REJECT

# block incoming ICMP traffic on a zone
#config rule
# option src lan
# option proto ICMP
# option target DROP

# port redirect port coming in on wan to lan
#config redirect
# option src wan
# option src_dport 80
# option dest lan
# option dest_ip 192.168.16.235
# option dest_port 80
# option proto tcp

### FULL CONFIG SECTIONS
#config rule
# option src lan
# option src_ip 192.168.45.2
# option src_mac 00:11:22:33:44:55
# option src_port 80
# option dest wan
# option dest_ip 194.25.2.129
# option dest_port 120
# option proto tcp
# option target REJECT

#config redirect
# option src lan
# option src_ip 192.168.45.2
# option src_mac 00:11:22:33:44:55
# option src_port 1024
# option src_dport 80
# option dest_ip 194.25.2.129
# option dest_port 120
# option proto tcp