Reply
Emerging Member
karlfife
Posts: 52
Registered: ‎09-06-2011
Posts: 52
Kudos: 317
Registered: 09-06-2011

Unifi 2.3.2 Installation Problems - JAVA

I wanted to bring this to everyone's attention--particularly the 2.3.5 beta-rapid team to correct these issues before others face them.

1.
We found we were unable to install Unifi 2.3.2 (Windows) over the previous 2.2.5 version. The installer fails reporing "already isntalled".

2.
After uninstalling 2.2.5, the 2.3.2 installer APPEARED to work but would not actually run--2.3.2 appeared to launch, but would self-close shortly thereafter, before fully loading.

3.
We restored the VM to an earlier state which had NEVER touched any version of any unifi software. The windows system was fully patched, and running Java 7 update 5. This install also failed. Probably Java related. See below

4.
A successful installation was ONLY possible by restoring the VM to an earlier 'virgin' state before windows had seen any UniFi software NOR any JAVA Runtime Environment, and runing the installation from the physical CD allowing the old installer's included 6.x version of Java to be installed.

This resulted in a lot of wasted time and a complete rebuild of our environment because we could not simply upgrade the installation.

Have these issues been fixed? Was the initial upgrade failure due to the system running Java 7 update 5? That version of Java worked fine with version 2.2.5. Is there an upgrade path for in-place systems?

Thanks!
Regular Member
SA182
Posts: 475
Registered: ‎08-02-2010
Posts: 475
Kudos: 98
Registered: 08-02-2010

Re: Unifi 2.3.2 Installation Problems - JAVA

This has been covered hundreds of times and has nothing to do with the controller software but more of a Java issue. Here are a few instances.......
http://forum.ubnt.com/showthread.php?p=339495#post339495
http://forum.ubnt.com/showthread.php?p=339044#post339044
Newbie
scott@scsd1.com
Posts: 9
Registered: ‎04-11-2012
Posts: 9
Registered: 04-11-2012

Re: Unifi 2.3.2 Installation Problems - JAVA

I'm having the same sort of problem.
I went to a new site and installed 2.3.x from the website, clicked lauch UniFi after install and set everything up. All went well, I uploaded my map, setup three APs, tested everything and went home.
I just went back yesterday to add another AP, the Windows server had been restarted so I double clicked the icon to start the UniFi services. Nothing happens! I just get a message stating the shortcut is invalid.
It appears to be java related as well, there is no Java 6, only Java 7 from what I can tell... I will be uninstalling everything tonight, installing Java 6, and getting everything setup again.
Regular Member
SA182
Posts: 475
Registered: ‎08-02-2010
Posts: 475
Kudos: 98
Registered: 08-02-2010

Re: Unifi 2.3.2 Installation Problems - JAVA

I've had similar issues with windows installs and switched to a Linux install (debian squeeze) from instructions found on the forum and haven't had a problem since.
Emerging Member
karlfife
Posts: 52
Registered: ‎09-06-2011
Posts: 52
Kudos: 317
Registered: 09-06-2011

Re: Unifi 2.3.2 Installation Problems - JAVA

I would still call it a defect in the 2.3.2 software. I would argue that it is the responsibility of an installer (hopefully 2.3.5) to check the compatibility of its dependencies, even if users can find solutions to it online or by iteration & elimination. To wit: I did search the forum before posting, but apparently not well enough.
Reply