Reply
Newbie
colin1256
Posts: 3
Registered: ‎07-28-2011
Posts: 3
Registered: 07-28-2011

UniFi Controller not starting

Hey everyone,

we have just gotten four UniFi APs that I am currently installing.

However, I seem to be having problems that the Controller is not starting.

I have now tried two different Servers (Win 2003 R2 and Win 2008 R2) of our Domain, but on both it eventually shows the message "Server taking too long to start".

I'm using Release 1.3.2 which I have downloaded just now.

Has anyone seen this before? What's wrong with the setup?

Best regards,


Colin

Here is an excerpt of the last bits of the logfile:

INFO SystemService - Platform:windows
INFO SystemService - Firmware Bundled:{ "BZ2" : { "display" : "UniFi AP" , "path" : "BZ2/1.3.2.424/firmware.bin" , "version" : "1.3.2.424"} , "BZ2LR" : { "display" : "UniFi AP-LR" , "path" : "BZ2/1.3.2.424/firmware.bin" , "version" : "1.3.2.424"} , "U2O" : { "display" : "UniFi AP-Ourdoor" , "path" : "BZ2/1.3.2.424/firmware.bin" , "version" : "1.3.2.424"} , "p2N" : { "display" : "PicoStation M2" , "path" : "BZ2/1.3.2.424/firmware.bin" , "version" : "1.3.2.424"}}
INFO SystemService - Current IP: 172.20.0.110
INFO SystemService - Interfaces:
WARN DigesterFactory - Could not get url for /javax/servlet/jsp/resources/jsp_2_1.xsd
WARN DigesterFactory - Could not get url for /javax/servlet/resources/j2ee_web_services_1_1.xsd
WARN DigesterFactory - Could not get url for /javax/servlet/jsp/resources/jsp_2_1.xsd
WARN DigesterFactory - Could not get url for /javax/servlet/resources/j2ee_web_services_1_1.xsd
INFO DbService - waiting for db connection...
INFO DbService - DB running. shutdown db server...
INFO DbService - DbServer starting, dbdir=C:\Users\admin\Ubiquiti UniFi\data\db, port=27117
INFO DbService - db connected
INFO UbntDiscoveryServer - DiscoveryServer started
INFO DeviceManager - started
INFO SystemService - Checking for updates (url=http://www.ubnt.com/downloads/unifi/updates/)
INFO SystemService - http response:{
"error": "not found"
}

ERROR LauncherUI - Server taking too long to start...
Ubiquiti Employee
UBNT-Matt
Posts: 5,260
Registered: ‎11-27-2007
Posts: 5260
Kudos: 2080
Solutions: 47
Contributions: 39
Registered: 11-27-2007

Re: UniFi Controller not starting

Do you have anything running on those ports (8080/8443) already?
You can run 'netstat -a' to verify.
-Matt
Member
LarryV
Posts: 173
Registered: ‎06-08-2011
Posts: 173
Kudos: 19
Registered: 06-08-2011

Re: UniFi Controller not starting

Hey Colin,

I've installed a bunch of controllers on servers and have run into this occasionally. It is always due to other apps using those ports. You can change the ports that the controller uses by editing the system.properties file found at C:\documents and settings\user who installed console\ubiquiti\data\. Why they put it under a user profile is beyond me but that's it. I think, as Matt eludes below, that ports 8080 and 8443 are the important ones but I just change them all to 9xxx rather than 8xxx and that has always worked.
Newbie
lan31
Posts: 4
Registered: ‎05-29-2011
Posts: 4
Registered: 05-29-2011

Re: UniFi Controller not starting

UniFi Controller not starting
Windows 7 SP1
UniFi 2.1.0 (build atag_2.1.0_1380 - release) is started
java.version = 1.6.0_27
WARN DigesterFactory - Could not get url for /javax/servlet/jsp/resources/jsp_2_1.xsd
WARN DigesterFactory - Could not get url for /javax/servlet/resources/j2ee_web_services_1_1.xsd
WARN DigesterFactory - Could not get url for /javax/servlet/jsp/resources/jsp_2_1.xsd
WARN DigesterFactory - Could not get url for /javax/servlet/resources/j2ee_web_services_1_1.xsd
ERROR LauncherUI - Server taking too long to start...
ERROR LauncherUI - Start-up failed.
Member
jborne
Posts: 116
Registered: ‎04-01-2009
Posts: 116
Solutions: 1
Registered: 04-01-2009

Re: UniFi Controller not starting

I got mine to start by completely uninstalling Java and letting the Unifi install do it.
New Member
endex
Posts: 10
Registered: ‎11-20-2011
Posts: 10
Kudos: 1
Registered: 11-20-2011

Re: UniFi Controller not starting

+ 1 Not starting Controller (2.2.0) on:
Win 7 prof
Win2008r2 standart x64

INFO system - BASE directory: C:\Users\Администратор\Ubiquiti UniFi
WARN system - *** Running for the first time, creating identity ***
WARN system - UUID: b017d057-907b-4741-811f-1b3778262596
WARN system - Generating Certificate... please wait...
WARN system - Certificate generated!
WARN system - ======================================================================
WARN system - UniFi 2.2.0 (build atag_2.2.0_1451 - release) is started
WARN system - ======================================================================
WARN system - BASE dir:C:\Users\Администратор\Ubiquiti UniFi
ERROR LauncherUI - Initializing UniFi Controller ...
ERROR LauncherUI - Starting UniFi Controller ...
INFO system - BASE directory: C:\Users\Администратор\Ubiquiti UniFi
WARN system - ======================================================================
WARN system - UniFi 2.2.0 (build atag_2.2.0_1451 - release) is started
WARN system - ======================================================================
WARN system - BASE dir:C:\Users\Администратор\Ubiquiti UniFi
WARN DigesterFactory - Could not get url for /javax/servlet/jsp/resources/jsp_2_1.xsd
WARN DigesterFactory - Could not get url for /javax/servlet/resources/j2ee_web_services_1_1.xsd
WARN DigesterFactory - Could not get url for /javax/servlet/jsp/resources/jsp_2_1.xsd
WARN DigesterFactory - Could not get url for /javax/servlet/resources/j2ee_web_services_1_1.xsd
ERROR system - Unable to seed the default map
com.mongodb.MongoException$Network: can't say something
New Member
endex
Posts: 10
Registered: ‎11-20-2011
Posts: 10
Kudos: 1
Registered: 11-20-2011

Re: UniFi Controller not starting

Started!
...C:\Users\Администратор...
that's the trouble.
nstall controller by anothe user (name in english)
Newbie
tp_ap
Posts: 7
Registered: ‎05-22-2012
Posts: 7
Registered: 05-22-2012

Mac OSX 10.6.8 UniFi 2.2.5

Has anyone seen issues on OSX 10.6.8 and UniFi 2.2.5 (build atag_2.2.5_1507 - release)?

I have checked my ports and changed them to avoid conflicts on the 8443. There could be more that I ahve not found but the netstat -a does not show any overlap that I can see.
I have also tried the same on a lion 10.7.x with the same results.

Not sure were else to look. I get a UI on the ports I have set (originally 8443 and shifted to 9443) but the Controller and discovery fails to start. The error does seem to link to a JAVA VM memory issue but its happening on two OSX platforms...


My server log shows the following:
 
INFO system - BASE directory: /Applications/UniFi.app/Contents/Resources
WARN system - ======================================================================
WARN system - UniFi 2.2.5 (build atag_2.2.5_1507 - release) is started
WARN system - ======================================================================
WARN system - BASE dir:/Applications/UniFi.app/Contents/Resources
ERROR LauncherUI - Initializing UniFi Controller ...
ERROR LauncherUI - Starting UniFi Controller ...
INFO system - BASE directory: /Applications/UniFi.app/Contents/Resources
WARN system - ======================================================================
WARN system - UniFi 2.2.5 (build atag_2.2.5_1507 - release) is started
WARN system - ======================================================================
WARN system - BASE dir:/Applications/UniFi.app/Contents/Resources
WARN DigesterFactory - Could not get url for /javax/servlet/resources/j2ee_web_services_1_1.xsd
WARN DigesterFactory - Could not get url for /javax/servlet/resources/j2ee_web_services_1_1.xsd
INFO discover - started
ERROR LauncherUI - UniFi Controller (2.2.5) started.
Reply