New Member
network newbie
Posts: 11
Registered: ‎02-26-2011
Posts: 11
Registered: 02-26-2011

PicoStation M2 with firmware 5.2, is EAP-PEAP supported?

I have a picostation running AirOS 5.2 and I am trying to use enterprise security with a radius server that is using EAP-PEAP protocol. I had assumed that this was supported but I have not been able to connect and in the user guide wiki I read:
"Note: AirOS v5.2 Web Management GUI supports only EAP-TTLS authentication method."
So I guess PEAP is not supported but in the release notes for v5.2 I saw PEAP support mentioned and on the forums there are some post by people who seem to be using PEAP.
Can anyone clarify this for me? If PEAP support is possible how do you configure it? Thanks.:icon_lol:
Ubiquiti Employee
UBNT-Edmundas
Posts: 3,897
Registered: ‎05-13-2009
Posts: 3897
Kudos: 571
Solutions: 49
Registered: 05-13-2009

Re: PicoStation M2 with firmware 5.2, is EAP-PEAP supported?

I have a picostation running AirOS 5.2 and I am trying to use enterprise security with a radius server that is using EAP-PEAP protocol. I had assumed that this was supported but I have not been able to connect and in the user guide wiki I read:

"Note: AirOS v5.2 Web Management GUI supports only EAP-TTLS authentication method."

So I guess PEAP is not supported but in the release notes for v5.2 I saw PEAP support mentioned and on the forums there are some post by people who seem to be using PEAP.

Can anyone clarify this for me? If PEAP support is possible how do you configure it? Thanks.:icon_lol:


Please upgrade your Station to the latest firmware, to get EAP-PEAP support. v5.2 doesn't have it.

-Edmundas
New Member
network newbie
Posts: 11
Registered: ‎02-26-2011
Posts: 11
Registered: 02-26-2011

Re: PicoStation M2 with firmware 5.2, is EAP-PEAP supported?

Thanks for your response Edmundas.
I did upgrade to v5.3 and I'm still having the same result. My laptop connects (to the AP) then says validating identity but this step never completes. I also saw in the v5.3 user guide wiki:
Note: AirOS v5.3 Web Management GUI supports only EAP-TTLS authentication method.
The radius server is using EAP Protocol: PEAP with EAP-MSCHAP v2
I will contact the guy who administers the radius server and find out if request are coming in to the server. Before I upgraded nothing was getting to his server. I have a dd-wrt router that I can connect so I'm pretty confident that my configuration is correct.
Besides updating to the latest firmware and entering the settings under the wireless tab is there anything else that I need to do?
Ubiquiti Employee
UBNT-Edmundas
Posts: 3,897
Registered: ‎05-13-2009
Posts: 3897
Kudos: 571
Solutions: 49
Registered: 05-13-2009

Re: PicoStation M2 with firmware 5.2, is EAP-PEAP supported?

Thanks for your response Edmundas.
I did upgrade to v5.3 and I'm still having the same result. My laptop connects (to the AP) then says validating identity but this step never completes. I also saw in the v5.3 user guide wiki:
Note: AirOS v5.3 Web Management GUI supports only EAP-TTLS authentication method.

Looks like WIKI page isn't correctly updated. I will inform responsible persons to fix it.

The radius server is using EAP Protocol: PEAP with EAP-MSCHAP v2
I will contact the guy who administers the radius server and find out if request are coming in to the server. Before I upgraded nothing was getting to his server. I have a dd-wrt router that I can connect so I'm pretty confident that my configuration is correct.
Besides updating to the latest firmware and entering the settings under the wireless tab is there anything else that I need to do?

Please note, that you are required to set correct date/time on Station device, to validate certificate. In other case RADIUS will drop your authentication.
-Edmundas
New Member
network newbie
Posts: 11
Registered: ‎02-26-2011
Posts: 11
Registered: 02-26-2011

Re: PicoStation M2 with firmware 5.2, is EAP-PEAP supported?

In order to set the date/time on the device it looks like I need to follow the instructions from this thread:
http://ubnt.com/forum/showthread.php?t=28636
Just to be clear I need to create the rc.poststart with one line of text that should be:
date -s 011523592010
do I use this exact string or do I need to use a date/time that will match the time on the radius server? If I have to match the time of the radius server does this mean that I need to update the rc.poststart each time I restart my picostation? does the timezone setting in the AirOS have any effect on the time or does it not matter?
Thanks for your help.