Reply
New Member
Posts: 1
Registered: ‎01-14-2018
Kudos: 3

Re: Comcast IPv6 issues when hwnat enabled on ER-X

The very latest firmware released this week still has this problem. With hwnat off, IPv6 works great. Turn it on and no more IPv6. 

 

Comcast in San Francisco, CA.

 

Thankfully I only have a 180 Mb connection so the CPU is able to keep up with things, but I suspect I’ll be on gigabit in the next couple years as fiber is landing quickly around here. I’ll likely move to a different product since it’s absurd to have to pick between IPv6 or gigabit speed.  

 

The lack of of response is disappointing. 

Regular Member
Posts: 472
Registered: ‎09-23-2015
Kudos: 147
Solutions: 2

Re: Comcast IPv6 issues when hwnat enabled on ER-X


wrote:

I've had no PD/IPv6 issues after about a week with hwnat off.

 

This thread will be a year old in 3 weeks. It doesn't seems like this is getting fixed if they haven't figured it out by now.


Time flies, eh? Man Happy

 

@UBNT-sandisn are you able to give us a status update on this issue? I certainly believe UBNT when you guys say you haven't been able to reproduce it in your lab -- because I also haven't been able to reproduce it. But the sheer number of different people impacted by this issue convince me it's legit.

 

You've got users offering you remote access to devices that CAN reliably reproduce the issue. Given the sheer number of Comcast customers out there who could potentially purchase an ER-X, I'm a little surprised that this hasn't been prioritized higher... and that you guys haven't been ALL OVER those offers of visibility into affected devices.

UBNT Gear: ERPoe-5, ERLite-3, ER-X, USG-3, UAP-AC-Pro, UAP-AC-Lite, UAP-Pro, NBE-M2-13
942.22 Mbps down / 926.27 Mbps up (http://result.googlefiber.net/share/316298352.png)
My Blog: http://www.stevejenkins.com/
New Member
Posts: 1
Registered: ‎09-11-2017

Re: Comcast IPv6 issues when hwnat enabled on ER-X

Just another Comcast user of Ubiquiti gear that has plenty of time to help troubleshoot during working hours Pacific time.

-Gene
New Member
Posts: 23
Registered: ‎08-18-2016
Kudos: 3
Solutions: 1

Re: Comcast IPv6 issues when hwnat enabled on ER-X

 

You've got users offering you remote access to devices that CAN reliably reproduce the issue. Given the sheer number of Comcast customers out there who could potentially purchase an ER-X, I'm a little surprised that this hasn't been prioritized higher... and that you guys haven't been ALL OVER those offers of visibility into affected devices.


 

What you are missing here is that UBNT isn't the developer or maintainer of the HWNAT module - the chip vendor is. This is a huge problem for all the manufacturers of embedded devices running linux, not just UBNT. Old kernels, buggy proprietary kernel modules, it's a flipping nightmare

Regular Member
Posts: 472
Registered: ‎09-23-2015
Kudos: 147
Solutions: 2

Re: Comcast IPv6 issues when hwnat enabled on ER-X


wrote:

 

 

 What you are missing here is that UBNT isn't the developer or maintainer of the HWNAT module - the chip vendor is. This is a huge problem for all the manufacturers of embedded devices running linux, not just UBNT. Old kernels, buggy proprietary kernel modules, it's a flipping nightmare


That's a very fair point.

 

Yet still, I'd imagine UBNT would want to track down exactly what's going on with the HWNAT module in their devices so they can either change the chipset in future HW revs, and/or pass the information upstream to the chip vendor, and/or devise a SW solution to help mitigate the issue.

UBNT Gear: ERPoe-5, ERLite-3, ER-X, USG-3, UAP-AC-Pro, UAP-AC-Lite, UAP-Pro, NBE-M2-13
942.22 Mbps down / 926.27 Mbps up (http://result.googlefiber.net/share/316298352.png)
My Blog: http://www.stevejenkins.com/
Ubiquiti Employee
Posts: 469
Registered: ‎01-06-2017
Kudos: 175
Solutions: 20

Re: Comcast IPv6 issues when hwnat enabled on ER-X

Thanks everyone for the input.

 

During each release cycle we revisit this thread and check the new information. Now that we have started working on 2.0 we'll revisit the issue once again.

Highlighted
New Member
Posts: 3
Registered: ‎01-15-2017

Re: Comcast IPv6 issues when hwnat enabled on ER-X

I have an ERX-SFP that has its managment console online.

I am on Comcast and have this problem.

If UBNT needs a router to play with, contact me and I can share credentials.

 

Jon

Reply