Upcoming Maintenance Alert:

The UBNT Community will be upgraded at 5pm MDT on April 25th. During this time the community forums will be set to read-only status.

Learn more

×
Reply
Established Member
Posts: 1,535
Registered: ‎02-24-2012
Kudos: 379
Solutions: 54

Re: ER-X Bricked ??

Many thanks - I will see what output I am getting when I connect the console cable, and hopefully will get this one back online.
New Member
Posts: 14
Registered: ‎03-10-2016

Re: ER-X Bricked ??

Did you ever get this fixed. Have the same problem with my Edgerouter X after a firmware update. Update seemed to work, but did not come back after reboot.

 

Here is the console log I got after hooking up a USB TTL adapter.

 

[<80287f88>] ubi_io_read_vid_hdr+0x68/0x260
[<8028d114>] ubi_attach+0x228/0x1534
[<80281740>] ubi_attach_mtd_dev+0x604/0xd1c
[<804946c0>] ubi_init+0x2ec/0x400
[<80001554>] do_one_initcall+0x13c/0x1a8
[<80481a7c>] kernel_init_freeable+0x15c/0x21c
[<8037681c>] kernel_init+0x10/0xf8
[<800043b0>] ret_from_kernel_thread+0x10/0x18

UBI error: ubi_attach_mtd_dev: failed to attach mtd7, error -5
UBI error: ubi_init: cannot attach mtd7
UBIFS error (pid 1): ubifs_mount: cannot open "ubi0_0", error -19
VFS: Cannot open root device "ubi0_0" or unknown-block(0,0): error -19
Please append a correct "root=" boot option; here are the available partitions:
1f00             512 mtdblock0  (driver?)
1f01          261632 mtdblock1  (driver?)
1f02             512 mtdblock2  (driver?)
1f03             384 mtdblock3  (driver?)
1f04             384 mtdblock4  (driver?)
1f05            3072 mtdblock5  (driver?)
1f06            3072 mtdblock6  (driver?)
1f07          253696 mtdblock7  (driver?)
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

===================================================================
                MT7621   stage1 code 10:33:11 (ASIC)
                CPU=50000000 HZ BUS=16666666 HZ
==================================================================
Change MPLL source from XTAL to CR...
do MEMPLL setting..
MEMPLL Config : 0x11100000
3PLL mode + External loopback
=== XTAL-40Mhz === DDR-1200Mhz ===
PLL4 FB_DL: 0x11, 1/0 = 553/471 45000000
PLL2 FB_DL: 0x14, 1/0 = 582/442 51000000
PLL3 FB_DL: 0x14, 1/0 = 623/401 51000000
do DDR setting..[00320381]
Apply DDR3 Setting...(use customer AC)
          0    8   16   24   32   40   48   56   64   72   80   88   96  104  112  120
      --------------------------------------------------------------------------------
0000:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
0001:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
0002:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
0003:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
0004:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
0005:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
0006:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
0007:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
0008:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
0009:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
000A:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
000B:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
000C:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
000D:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    1
000E:|    0    0    0    0    0    0    0    0    0    1    1    1    1    1    1    1
000F:|    0    0    0    0    0    1    1    1    1    1    1    1    1    0    0    0
0010:|    1    1    1    1    1    1    1    1    1    0    0    0    0    0    0    0
0011:|    1    1    1    1    0    0    0    0    0    0    0    0    0    0    0    0
0012:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
0013:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
0014:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
0015:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
0016:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
0017:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
0018:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
0019:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
001A:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
001B:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
001C:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
001D:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
001E:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
001F:|    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
rank 0 coarse = 16
rank 0 fine = 32
B:|    0    0    0    0    0    0    0    1    1    1    0    0    0    0    0    0
opt_dle value:8
DRAMC_R0DELDLY[018]=00001B1B
==================================================================
                RX      DQS perbit delay software calibration
==================================================================
1.0-15 bit dq delay value
==================================================================
bit|     0  1  2  3  4  5  6  7  8  9
--------------------------------------
0 |    12 9 12 9 12 7 12 8 7 9
10 |    7 10 6 10 6 9
--------------------------------------

==================================================================
2.dqs window
x=pass dqs delay value (min~max)center
y=0-7bit DQ of every group
input delay:DQS0 =27 DQS1 = 27
==================================================================
bit     DQS0     bit      DQS1
0  (1~54)27  8  (2~52)27
1  (1~50)25  9  (1~49)25
2  (1~51)26  10  (1~49)25
3  (1~52)26  11  (1~51)26
4  (1~52)26  12  (1~53)27
5  (1~53)27  13  (1~52)26
6  (0~51)25  14  (1~52)26
7  (1~53)27  15  (1~54)27
==================================================================
3.dq delay value last
==================================================================
bit|    0  1  2  3  4  5  6  7  8   9
--------------------------------------
0 |    12 11 13 10 13 7 14 8 7 11
10 |    9 11 6 11 7 9
==================================================================
==================================================================
     TX  perbyte calibration
==================================================================
DQS loop = 15, cmp_err_1 = ffff0000
dqs_perbyte_dly.last_dqsdly_pass[0]=15,  finish count=1
dqs_perbyte_dly.last_dqsdly_pass[1]=15,  finish count=2
DQ loop=15, cmp_err_1 = ffff00aa
dqs_perbyte_dly.last_dqdly_pass[1]=15,  finish count=1
DQ loop=14, cmp_err_1 = ffff00a0
DQ loop=13, cmp_err_1 = ffff0020
DQ loop=12, cmp_err_1 = ffff0000
dqs_perbyte_dly.last_dqdly_pass[0]=12,  finish count=2
byte:0, (DQS,DQ)=(9,8)
byte:1, (DQS,DQ)=(8,8)
20,data:89
[EMI] DRAMC calibration passed

===================================================================
                MT7621   stage1 code done
                CPU=50000000 HZ BUS=16666666 HZ
===================================================================


U-Boot 1.1.3 (Jan 27 2015 - 17:52:09)

Board: Ralink APSoC DRAM:  256 MB
relocate_code Pointer at: 8ffb0000

Config XHCI 40M PLL
Allocate 16 byte aligned buffer: 8ffe13a0
Enable NFI Clock
# MTK NAND # : Use HW ECC
NAND ID [01 DA 90 95 46]
Device found in MTK table, ID: 1da, EXT_ID: 909546
Support this Device in MTK table! 1da
select_chip
[NAND]select ecc bit:12, sparesize :112 spare_per_sector=28
Signature matched and data read!
load_fact_bbt success 2047
load fact bbt success
[mtk_nand] probe successfully!
mtd->writesize=2048 mtd->oobsize=112,   mtd->erasesize=131072  devinfo.iowidth=8
..
UBNT e50 13-02079-18 44D9E750DB0D
UBNT BD type=e50, mac=44D9E750DB0D, s/n=44D9E750DB0D, mrev=18, k_idx=1
============================================
Ralink UBoot Version: 4.3.S.0
--------------------------------------------
ASIC MT7621A DualCore (MAC to MT7530 Mode)
DRAM_CONF_FROM: Auto-Detection
DRAM_TYPE: DDR3
DRAM bus: 16 bit
Xtal Mode=3 OCP Ratio=1/3
Flash component: NAND Flash
Date:Jan 27 2015  Time:17:52:09
============================================
icache: sets:256, ways:4, linesz:32 ,total:32768
dcache: sets:256, ways:4, linesz:32 ,total:32768

 ##### The CPU freq = 880 MHZ ####
 estimate memory size =256 Mbytes
#Reset_MT7530

Please choose the operation:
   1: Load system code to SDRAM via TFTP.
   2: Load system code then write to Flash via TFTP.
   3: Boot system code via Flash (default).
   4: Entr boot command line interface.
   7: Load Boot Loader code then write to Flash via Serial.
   9: Load Boot Loader code then write to Flash via TFTP.
default: 3                                                                    0

3: System Boot system code via Flash.
## Booting image at c0040000 ...
   Image Name:   Linux Kernel Image
   Image Type:   MIPS Linux Kernel Image (lzma compressed)
   Data Size:    1708328 Bytes =  1.6 MB
   Load Address: 80001000
   Entry Point:  803799d0
...........................   Verifying Checksum ... OK
   Uncompressing Kernel Image ... OK
No initrd
## Transferring control to Linux (at address 803799d0) ...
## Giving linux memsize in MB, 256

Starting kernel ...


LINUX started...

 THIS IS ASIC
Linux version 3.10.14-UBNT (root@edgeos-builder2) (gcc version 4.6.3 (Buildroot 2012.11.1) ) #1 SMP Thu Jul 13 03:40:37 PDT 2017

 The CPU feqenuce set to 880 MHz
GCMP present
CPU0 revision is: 0001992f (MIPS 1004Kc)
Software DMA cache coherency
Determined physical RAM map:
 memory: 10000000 @ 00000000 (usable)
Zone ranges:
  Normal   [mem 0x00000000-0x0fffffff]
Movable zone start for each node
Early memory node ranges
  node   0: [mem 0x00000000-0x0fffffff]
Detected 3 available secondary CPU(s)
Primary instruction cache 32kB, 4-way, VIPT, linesize 32 bytes.
Primary data cache 32kB, 4-way, PIPT, no aliases, linesize 32 bytes
MIPS secondary cache 256kB, 8-way, linesize 32 bytes.
PERCPU: Embedded 7 pages/cpu @81203000 s6720 r8192 d13760 u32768
Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 65024
Kernel command line: console=ttyS1,57600n8 ubi.mtd=7 root=ubi0_0 rootfstype=ubifs rootsqimg=squashfs.img rootsqwdir=w rw
PID hash table entries: 1024 (order: 0, 4096 bytes)
Dentry cache hash table entries: 32768 (order: 5, 131072 bytes)
Inode-cache hash table entries: 16384 (order: 4, 65536 bytes)
Writing ErrCtl register=00027801
Readback ErrCtl register=00027801
Memory: 254732k/262144k available (3588k kernel code, 7412k reserved, 1026k data, 244k init, 0k highmem)
Hierarchical RCU implementation.
NR_IRQS:128
console [ttyS1] enabled
Calibrating delay loop... 577.53 BogoMIPS (lpj=1155072)
pid_max: default: 32768 minimum: 301
Security Framework initialized
Mount-cache hash table entries: 512
launch: starting cpu1
launch: cpu1 gone!
CPU1 revision is: 0001992f (MIPS 1004Kc)
Primary instruction cache 32kB, 4-way, VIPT, linesize 32 bytes.
Primary data cache 32kB, 4-way, PIPT, no aliases, linesize 32 bytes
MIPS secondary cache 256kB, 8-way, linesize 32 bytes.
Synchronize counters for CPU 1: done.
launch: starting cpu2
launch: cpu2 gone!
CPU2 revision is: 0001992f (MIPS 1004Kc)
Primary instruction cache 32kB, 4-way, VIPT, linesize 32 bytes.
Primary data cache 32kB, 4-way, PIPT, no aliases, linesize 32 bytes
MIPS secondary cache 256kB, 8-way, linesize 32 bytes.
Synchronize counters for CPU 2: done.
launch: starting cpu3
launch: cpu3 gone!
CPU3 revision is: 0001992f (MIPS 1004Kc)
Primary instruction cache 32kB, 4-way, VIPT, linesize 32 bytes.
Primary data cache 32kB, 4-way, PIPT, no aliases, linesize 32 bytes
MIPS secondary cache 256kB, 8-way, linesize 32 bytes.
Synchronize counters for CPU 3: done.
Brought up 4 CPUs
devtmpfs: initialized
NET: Registered protocol family 16
bio: create slab <bio-0> at 0
Switching to clocksource MIPS
NET: Registered protocol family 2
TCP established hash table entries: 2048 (order: 2, 16384 bytes)
TCP bind hash table entries: 2048 (order: 2, 16384 bytes)
TCP: Hash tables configured (established 2048 bind 2048)
TCP: reno registered
UDP hash table entries: 256 (order: 1, 8192 bytes)
UDP-Lite hash table entries: 256 (order: 1, 8192 bytes)
NET: Registered protocol family 1
4 CPUs re-calibrate udelay(lpj = 1167360)
squashfs: version 4.0 (2009/01/31) Phillip Lougher
Registering unionfs 2.5.13 (for 3.10.34)
aufs 3.10.x-20140915
msgmni has been set to 497
io scheduler noop registered
io scheduler cfq registered (default)
Serial: 8250/16550 driver, 2 ports, IRQ sharing disabled
serial8250: ttyS0 at MMIO 0x1e000d00 (irq = 27) is a 16550A
serial8250: ttyS1 at MMIO 0x1e000c00 (irq = 26) is a 16550A
Ralink gpio driver initialized
i2cdrv_major = 218
loop: module loaded
flash manufacture id: 1c, device id 70 15
EN25QH16(1c 70151c70) (2048 Kbytes)
mtd .name = raspi, .size = 0x00200000 (2M) .erasesize = 0x00010000 (64K) .numeraseregions = 0
Creating 1 MTD partitions on "raspi":
0x000000000000-0x000000080000 : "SPI_FLASH"
MediaTek Nand driver init, version v2.1 Fix AHB virt2phys error
Allocate 16 byte aligned buffer: 804d0430
Enable NFI Clock
# MTK NAND # : Use HW ECC
NAND ID [01 DA 90 95 46, 00909546]
Device found in MTK table, ID: 1da, EXT_ID: 909546
Support this Device in MTK table! 1da
NAND device: Manufacturer ID: 0x01, Chip ID: 0xda (AMD/Spansion NAND 256MiB 3,3V 8-bit), 256MiB, page size: 2048, OOB size: 112
[NAND]select ecc bit:12, sparesize :112 spare_per_sector=28
Scanning device for bad blocks
Bad eraseblock 1532 at 0x00000bf80000
Bad eraseblock 1608 at 0x00000c900000
Bad eraseblock 1664 at 0x00000d000000
Bad eraseblock 2004 at 0x00000fa80000
Bad eraseblock 2018 at 0x00000fc40000
Signature matched and data read!
load_fact_bbt success 2047
00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 03
00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 03 00 00 00 00 00 00 00 00 00 00 00 00 00
03 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 03 00 00 30 00 00 00 00 00 00 00
Creating 7 MTD partitions on "MT7621-NAND":
0x000000000000-0x00000ff80000 : "ALL"
0x000000000000-0x000000080000 : "Bootloader"
0x000000080000-0x0000000e0000 : "Config"
0x0000000e0000-0x000000140000 : "eeprom"
0x000000140000-0x000000440000 : "Kernel"
0x000000440000-0x000000740000 : "Kernel2"
0x000000740000-0x00000ff00000 : "RootFS"
[mtk_nand] probe successfully!
UBNT BD mac 44d9e750db0d kidx 1 mrev 18 serial 44D9E750DB0D type e50
rdm_major = 253
GMAC1_MAC_ADRH -- : 0x000044d9
GMAC1_MAC_ADRL -- : 0xe750db0d
Ralink APSoC Ethernet Driver Initilization. v3.1  512 rx/tx descriptors allocated, mtu = 1500!
GMAC1_MAC_ADRH -- : 0x000044d9
GMAC1_MAC_ADRL -- : 0xe750db0d
PROC INIT OK!
Ralink I2C Init
TCP: cubic registered
Initializing XFRM netlink socket
NET: Registered protocol family 17
NET: Registered protocol family 15
UBI: attaching mtd7 to ubi0
UBI warning: ubi_io_read: error -5 while reading 2048 bytes from PEB 1302:2048, read only 0 bytes, retry
UBI warning: ubi_io_read: error -5 while reading 2048 bytes from PEB 1302:2048, read only 0 bytes, retry
UBI warning: ubi_io_read: error -5 while reading 2048 bytes from PEB 1302:2048, read only 0 bytes, retry
UBI error: ubi_io_read: error -5 while reading 2048 bytes from PEB 1302:2048, read 0 bytes
CPU: 2 PID: 1 Comm: swapper/0 Not tainted 3.10.14-UBNT #1
Stack : 804c7c32 00000039 00000000 80460000 00000800 00000516 8040d3ac 804c3b9c
          8fc33c78 80465527 00000800 00000516 8fe79000 ffffffb3 803d5a00 8037aaf0
          00000000 8002821c 00000000 00000000 8040f0cc 8fc35c7c 8fc35c7c 8040d3ac
          00000800 00000000 00000000 00000000 00000000 00000000 00000000 00000000
          00000000 00000000 00000000 00000000 00000000 00000000 00000000 8fc35c10
          ...
Call Trace:
[<80009990>] show_stack+0x64/0x7c
[<80287a9c>] ubi_io_read+0x210/0x3d0
[<80288148>] ubi_io_read_vid_hdr+0x68/0x260
[<8028d2d4>] ubi_attach+0x228/0x1534
[<80281900>] ubi_attach_mtd_dev+0x604/0xd1c
[<804966c0>] ubi_init+0x2ec/0x400
[<80001554>] do_one_initcall+0x13c/0x1a8
[<80483a7c>] kernel_init_freeable+0x15c/0x21c
[<80379afc>] kernel_init+0x10/0xf8
[<800043b0>] ret_from_kernel_thread+0x10/0x18

UBI error: ubi_attach_mtd_dev: failed to attach mtd7, error -5
UBI error: ubi_init: cannot attach mtd7
UBIFS error (pid 1): ubifs_mount: cannot open "ubi0_0", error -19
VFS: Cannot open root device "ubi0_0" or unknown-block(0,0): error -19
Please append a correct "root=" boot option; here are the available partitions:
1f00             512 mtdblock0  (driver?)
1f01          261632 mtdblock1  (driver?)
1f02             512 mtdblock2  (driver?)
1f03             384 mtdblock3  (driver?)
1f04             384 mtdblock4  (driver?)
1f05            3072 mtdblock5  (driver?)
1f06            3072 mtdblock6  (driver?)
1f07          253696 mtdblock7  (driver?)
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)
SuperUser
Posts: 11,509
Registered: ‎12-08-2008
Kudos: 8340
Solutions: 525
Contributions: 1

Re: ER-X Bricked ??

Looks like a flash failure - any possibility the power was interrupded during the upgrade?   You could try re-flashing from the CLI...

Jim

" How can anyone trust Scientists? If new evidence comes along, they change their minds! " Politician's joke (sort of...)

"Humans are allergic to change..They love to say, ‘We’ve always done it this way.’ I try to fight that. "Admiral Grace Hopper, USN, Computer Scientist
New Member
Posts: 14
Registered: ‎03-10-2016

Re: ER-X Bricked ??

No, the power was not interupted.
I can't get in the CLI, only the u-boot. I found this post:
https://help.ubnt.com/hc/en-us/articles/204959514-EdgeRouter-Last-resort-recovery-of-failed-EdgeOS-d...

but that doesn't apply to the ER-X.

 

Only solution I found on the forum was to RMA, but my device is already out of warranty.

Senior Member
Posts: 4,160
Registered: ‎03-24-2016
Kudos: 1170
Solutions: 491

Re: ER-X Bricked ??

From memory (....which is failing on me):

Was there an openwrt image, so you can boot it, and get linux shell to flash edgeOS back afterwards?

New Member
Posts: 14
Registered: ‎03-10-2016

Re: ER-X Bricked ??

Found that yes:

http://www.sector5d.org/openwrt-on-the-ubiquiti-edgerouter-x.html

https://wiki.openwrt.org/toh/ubiquiti/ubiquiti_edgerouter_x_er-x_ka

Things not clear to me are :

- how to build a openwrt image.

- how to go back to edgeOS from that

 

Senior Member
Posts: 4,160
Registered: ‎03-24-2016
Kudos: 1170
Solutions: 491

Re: ER-X Bricked ??

Never been there myself, but as soon as linux is up and running, you might use dd to overwrite flash

Emerging Member
Posts: 80
Registered: ‎04-21-2015
Kudos: 23
Solutions: 4

Re: ER-X Bricked ??

[ Edited ]

@pvdn    I have created a backup of all partitions before go to other firmware, never try to use it (back to stock), but it may be usefull - link to dropbox

New Member
Posts: 14
Registered: ‎03-10-2016

Re: ER-X Bricked ??

Thats great.

Any guide on how to restore them?  Do I need openwrt first?

Emerging Member
Posts: 80
Registered: ‎04-21-2015
Kudos: 23
Solutions: 4

Re: ER-X Bricked ??

According to boot log - all errors in "rootfs".

You shoud try boot to command line and find what command may help.

If you can't restore it (after you try all possible) - before trash it, write me in pm.

Senior Member
Posts: 4,160
Registered: ‎03-24-2016
Kudos: 1170
Solutions: 491

Re: ER-X Bricked ??

Google skills found this:

http://www.thecodingcircus.com/recovering-from-a-bricked-edgerouter-x/

 

Down at the moment, it's alive in google cache:

http://webcache.googleusercontent.com/search?q=cacheMan Surprisedm_MPumSdT4J:www.thecodingcircus.com/recovering-f...

 

It features a working dropbox link pointing to required file.

 

Please report back if this works

New Member
Posts: 14
Registered: ‎03-10-2016

Re: ER-X Bricked ??

Thanks for this, will try tomorrow.
Highlighted
Established Member
Posts: 1,535
Registered: ‎02-24-2012
Kudos: 379
Solutions: 54

Re: ER-X Bricked ??

Mine is a paperweight - and from memory, we decided it was bad flash that died during upgrade. I put it back in the box, and it's been there ever since.
New Member
Posts: 14
Registered: ‎03-10-2016

Re: ER-X Bricked ??

[ Edited ]

I managed to boot via tftp, but in the resulting busybox console I can't use command "sudo": 

/bin/ash: sudo: not found

running the command without sudo:

UBIFS error (pid: 1042): cannot open "/dev/ubi0_0", error -22mount: mounting /dev/ubi0_0 on /mnt failed: Invalid argument

Also , I don't see how I could copy files onto the ER-X.   I cannot reach the ER-x via network , only the console.

 

Just found another post on this forum, where someone has the exact same issues:
https://community.ubnt.com/t5/EdgeMAX/What-are-the-recovery-options-on-a-EdgeRouter-X/m-p/1933656#M1...

 

doesn't end well ...

Senior Member
Posts: 4,160
Registered: ‎03-24-2016
Kudos: 1170
Solutions: 491

Re: ER-X Bricked ??

I guess you already have root privileges in busybox

 

Alternatively, this thread also has link to dropbox 7zip file containing mtd blocks,  you could try to dd those back into place.

Anyway, getting ethernet up and running is 1st concern

Regular Member
Posts: 371
Registered: ‎07-21-2010
Kudos: 59
Solutions: 5

Re: ER-X Bricked ??

Is the user responsible for bad firmware flashes if the system wont check the upgrade gone fine?

 

Ubiquiti brings new firmwares to market and if you will flash these files, your router is bricked?

 

If you use non standard tools to upgrade your firmware, okay, so the user is responsible for that but not if you use the functions that are provided from vendor?

New Member
Posts: 5
Registered: ‎08-24-2017

Re: ER-X Bricked ??

Did you manage to find a solution? I have the exact same problem.

 

This seems to be a systemic issue with ER-X series of routers.

Member
Posts: 194
Registered: ‎09-16-2011
Kudos: 34
Solutions: 2

Re: ER-X Bricked ??

@BranoB @16again

 

I am trying to connect to console. I managed to get output, it is garbage. I tested all speeds, specially 57600 8N1 no flow control. still garbage output.

 

Any idea?

 

Used Windows 10 with USB-Serial on two laptops (same USB dongle), used direct serial on a PC with Win 2012R2, putty and termite (on all), still garbage output

Established Member
Posts: 1,346
Registered: ‎08-06-2015
Kudos: 548
Solutions: 68

Re: ER-X Bricked ??

Have you tried other baud rates?  I haven't checked on an ER-X but on other ERs I use 115200/N81

 

 

 

Senior Member
Posts: 3,110
Registered: ‎05-15-2014
Kudos: 1080
Solutions: 217

Re: ER-X Bricked ??

@alawadhi Your baud settings are OK. But you know that Tx on one side connect to Rx on other side and vice versa? GND to GND.

TEKUX - IT Consulting and Services
Reply