Reply
Highlighted
New Member
Posts: 8
Registered: ‎11-11-2014

EdgeRouter PoE - Enable arp proxy on switch0 errror

[ Edited ]

I have an ER PoE. eth0 is WAN, eth1 is LAN, and eth2-4 are on hardware switch0 as WLAN. At the moment, I am trying to get my phone on WLAN to talk to my TiVO on the LAN. I've enabled mdns reflector, which allowed it to discover the TiVO, but it is not getting the mac adress and several activities are failing. I am sure I'll have similar devices in the future.

 

It seems like I should enable proxy arp on switch0, so that any time a WLAN device asks for the hardware address of a LAN device, the router responds with it's own. (And probably enable it on eth1 too for the reverse use case). But... when I go to enable it on switch0, i get:

 

The specified configuration node is not validinterfaces switch switch0 ip enable-proxy-arp true

 

Any thoughts?

 

Full config:

 

 ethernet eth0 {
     address dhcp
     description Internet
     duplex auto
     firewall {
         in {
             name WAN_IN
         }
         local {
             name WAN_LOCAL
         }
     }
     poe {
         output off
     }
     speed auto
 }
 ethernet eth1 {
     address 10.10.10.1/24
     description LAN
     duplex auto
     firewall {
         in {
             name LAN_IN
         }
         local {
             name LAN_LOCAL
         }
     }
     ip {
     }
     poe {
         output off
     }
     speed auto
 }
 ethernet eth2 {
     description "Local 2"
     duplex auto
     ip {
     }
     poe {
         output 24v
     }
     speed auto
 }
 ethernet eth3 {
     description "Local 2"
     duplex auto
     ip {
     }
     poe {
         output 24v
     }
     speed auto
 }
 ethernet eth4 {
     description "Local 2"
     duplex auto
     ip {
     }
     poe {
         output 24v
     }
     speed auto
 }
 loopback lo {
 }
 switch switch0 {
     address 10.10.20.1/24
     description WLAN
     firewall {
         in {
             name WLAN_IN
         }
         local {
             name WLAN_LOCAL
         }
     }
     mtu 1500
     switch-port {
         interface eth2
         interface eth3
         interface eth4
     }
 }

 

SuperUser
Posts: 19,082
Registered: ‎09-17-2013
Kudos: 4791
Solutions: 1344

Re: EdgeRouter PoE - Enable arp proxy on switch0 errror

Simplest solution is "put everything on the same netblock" -- preferably all feeding from eth1 or switch0.

 

If you absolutely have no other choice, bridging eth1 to switch0 could work too.

 

New Member
Posts: 8
Registered: ‎11-11-2014

Re: EdgeRouter PoE - Enable arp proxy on switch0 errror

Yes, quite aware that is a possible solution. However, I have exactly three APs I'd like to drive off of the poe switch and I would like to keep the WLAN and LAN on seperate netblocks in order to be able to leverage different DHCP pools and control traffic as desired.

New Member
Posts: 8
Registered: ‎11-11-2014

Re: EdgeRouter PoE - Enable arp proxy on switch0 errror

Bump. Any thoughts on why arp proxy cannot be enabled on switch0?

Previous Employee
Posts: 10,504
Registered: ‎06-09-2011
Kudos: 3069
Solutions: 945
Contributions: 16

Re: EdgeRouter PoE - Enable arp proxy on switch0 errror


smashr wrote:

Bump. Any thoughts on why arp proxy cannot be enabled on switch0?


I'll get it added to the next release, but until then you can probably copy the template from ethernet:

 

sudo bash
cd /opt/vyatta/share/vyatta-cfg/templates/interfaces/switch/node.tag/ip
cp -r ../../../ethernet/node.tag/ip/enable-proxy-arp .
exit

 

EdgeMAX Router Software Development
New Member
Posts: 8
Registered: ‎11-11-2014

Re: EdgeRouter PoE - Enable arp proxy on switch0 errror

Thanks; copied that file and directory so it looks like:

 

root@xxx:/opt/vyatta/share/vyatta-cfg/templates/interfaces/switch/node.tag/ip/enable-proxy-arp# ls
node.def
root@xxx:/opt/vyatta/share/vyatta-cfg/templates/interfaces/switch/node.tag/ip/enable-proxy-arp# cat node.def
help: Enable proxy-arp on this interface
create:expression: "sudo sh -c \"echo 1 > /proc/sys/net/ipv4/conf/$VAR(../../@)/proxy_arp\" "
delete:expression: "sudo sh -c \"echo 0 > /proc/sys/net/ipv4/conf/$VAR(../../@)/proxy_arp\" "

 

However, still get:

 

	The specified configuration node is not valid 	interfaces switch switch0 ip enable-proxy-arp true

 

From the GUI. Also tried it from the CLI:

 

[edit]
admin@xxx# edit interfaces switch switch0 ip enable-proxy-arp true
The specified configuration node is not valid

 

Any further thoughts?

Previous Employee
Posts: 10,504
Registered: ‎06-09-2011
Kudos: 3069
Solutions: 945
Contributions: 16

Re: EdgeRouter PoE - Enable arp proxy on switch0 errror

Leave off the "true".  Tab completion would show you that you're at the end.

EdgeMAX Router Software Development
Reply