Upcoming Maintenance Alert:

The UBNT Community will be upgraded at 5pm MDT on April 25th. During this time the community forums will be set to read-only status.

Learn more

×
Reply
Highlighted
New Member
Posts: 3
Registered: ‎06-07-2017

Edgerouter POE Port only 10/100

Hi,

 

I have an Edgerouter POE that was working great, as expected, until the other day when I noticed the activity light on my Eth2 port changed from green to amber. On the GUI, it also indicates the port speed is 100/Full, but speed is set to auto-negotiate. I attempted to change the cable as well as the devices attached, but no luck getting 1000 speed out of the port. 

 

Is there a software issue that I'm missing? Or is this a hardware issue?

 

Thanks in advance! I have FiOS gigabit service, so I would like the full gigabit speed out of the port Man Happy

 

 firewall {                                                                       
     all-ping enable                                                              
     broadcast-ping disable                                                       
     ipv6-receive-redirects disable                                               
     ipv6-src-route disable                                                       
     ip-src-route disable                                                         
     log-martians enable                                                          
     name WAN_IN {                                                                
         default-action drop                                                      
         description "WAN to internal"                                            
         rule 10 {                                                                
             action accept                                                        
             description "Allow established/related"                              
             state {                                                              
                 established enable                                               
                 related enable                                                   
             }                                                                    
         }                                                                        
         rule 20 {                                                                
             action drop                                                          
             description "Drop invalid state"                                     
             state {                                                              
                 invalid enable                                                   
             }
         }
     }
     name WAN_LOCAL {
         default-action drop
         description "WAN to router"
         rule 10 {
             action accept
             description "Allow established/related"
             state {
                 established enable
                 related enable
             }
         }
         rule 20 {
             action drop
             description "Drop invalid state"
             state {
                 invalid enable
             }
         }
     }
     receive-redirects disable
     send-redirects enable
     source-validation disable
     syn-cookies enable
 }
 interfaces {
     ethernet eth0 {
         address dhcp
         description Internet
         duplex auto
         firewall {
             in {
                 name WAN_IN
             }
             local {
                 name WAN_LOCAL
             }
         }
         poe {
             output off
         }
         speed auto
     }
     ethernet eth1 {
         address 192.168.1.1/24
         description Local
         duplex auto
         poe {
             output off
         }
         speed auto
     }
     ethernet eth2 {
         description "Local 2"
         duplex auto
         poe {
             output off
         }
         speed auto
     }
     ethernet eth3 {
         description "Local 2"
         duplex auto
         poe {
             output off
         }
         speed auto
     }
     ethernet eth4 {
         address dhcp
         description "Local 2"
         duplex auto
         poe {
             output 48v
         }
         speed auto
     }
     loopback lo {
     }
     switch switch0 {
         address 192.168.2.1/24
         description "Local 2"
         switch-port {
             interface eth2 {
             }
             interface eth3 {
             }
             interface eth4 {
             }
         }
     }
 }
 service {
     dhcp-server {
         disabled false
         hostfile-update disable
         shared-network-name LAN1 {
             authoritative enable
             subnet 192.168.1.0/24 {
                 default-router 192.168.1.1
                 dns-server 192.168.1.1
                 lease 86400
                 start 192.168.1.38 {
                     stop 192.168.1.243
                 }
             }
         }
         shared-network-name LAN2 {
             authoritative enable
             subnet 192.168.2.0/24 {
                 default-router 192.168.2.1
                 dns-server 192.168.2.1
                 lease 86400
                 start 192.168.2.38 {
                     stop 192.168.2.243
                 }
                 unifi-controller 192.168.2.44
             }
         }
     }
     dns {
         forwarding {
             cache-size 150
             listen-on eth1
             listen-on switch0
         }
     }
     gui {
         https-port 443
     }
     nat {
         rule 5010 {
             description "masquerade for WAN"
             outbound-interface eth0
             type masquerade
         }
     }
     ssh {
         port 22
         protocol-version v2
     }
 }
 system {
     host-name 
     login {
         user 
             authentication {
             }
             level admin
         }
     }
     ntp {
         server 0.ubnt.pool.ntp.org {
         }
         server 1.ubnt.pool.ntp.org {
         }
         server 2.ubnt.pool.ntp.org {
         }
         server 3.ubnt.pool.ntp.org {
         }
     }
     syslog {
         global {
             facility all {
                 level notice
             }
             facility protocols {
                 level debug
             }
         }
     }
     time-zone UTC
     traffic-analysis {
         dpi enable
         export enable
SuperUser
Posts: 18,401
Registered: ‎09-17-2013
Kudos: 4599
Solutions: 1289

Re: Edgerouter POE Port only 10/100

it's most likely a cable issue, or connected hardware.

 

What's the port in question plugged into?  What happens if you move that device to another port?

New Member
Posts: 3
Registered: ‎06-07-2017

Re: Edgerouter POE Port only 10/100

I thought so too, but even with different cables or devices I still get the same problem.

 

If I move the device (an unmanaged switch) and same cable to a different port I get gigabit speed.

SuperUser
Posts: 18,401
Registered: ‎09-17-2013
Kudos: 4599
Solutions: 1289

Re: Edgerouter POE Port only 10/100

same port on the other device too?

 

I mean, it's not unheard of for ports to go south, but it's pretty rare.

New Member
Posts: 3
Registered: ‎06-07-2017

Re: Edgerouter POE Port only 10/100

Yup - no matter what I plug into the eth2 port I only get 10/100. 

 

I appreciate your help -- I'm afraid its the port thats gone bad, so I was looking to see if there was anything that I was missing. 

Regular Member
Posts: 363
Registered: ‎03-01-2016
Kudos: 80
Solutions: 41

Re: Edgerouter POE Port only 10/100

Loot at the pins in the port on the ER.  It isn't very common, but one contact could be bent.

Reply