New Member
Posts: 11
Registered: ‎06-15-2014
Kudos: 7
Solutions: 1
Accepted Solution

50% WAN speed on ERL3

Greetings to all,


I have a strange problem that I can't get rid of.

Currently I have a Asus RT-N66U wireless router at home to take care of everything. With my laptop connected to the switchport of the Asus, I can download at full speed.

My ISP is Ziggo and my internet speed is 180Mbits/18Mbits. The modem that I have from Ziggo is in bridge mode. This means that the Asus RT-N66U received a public IPv4 address on it's WAN interface. So far so good.

When installing the ERL-3 and running the simple WAN+2LAN configuration, I only have half the download speed (70-90Mbits).

show ubnt offload status shows that offloading is activated for everykind of traffic (IPSec, VLAN, Forwarding).

What am I doing wrong? Do I have to change a hidden setting in the EdgeOS CLI?

The network connectivity between the modem and the ERL-3 is 1GB/s-Full Duplex.

The only difference that I can think of is that the Asus RT-N66U has "Turbo NAT" to cope with high speed internet access and that maybe the ERL-3 does not have this ''Turbo NAT" feature in it's OS or CPU?


Thank you very much for your help and thinking with me.


Accepted Solutions
New Member
Posts: 11
Registered: ‎06-15-2014
Kudos: 7
Solutions: 1

Re: 50% WAN speed on ERL3

I have tested the mac clone option, but my ISP did not give me the same ip address as before. They check for mac clone situations.


I did some file transfer tests using this website: https://kb.leaseweb.com/display/KB/Link+speeds

and my average speed using the ERL-3 is 19MbitsIcon Razz

Either way I'm happy that my ERL is not the bottleneck and that I just had to choose a proper link speed website that offers big binary files to download.

In 5 weeks I will be having FttH with 100Mbits/100Mbits as initial speed. In the autumn my new ISP will upgrade the FttH speed to 500Mbits/500Mbits and the ERL will be ready to route at this speed.

Thank you all for your suggestions and tips!

View solution in original post


All Replies
Member
Posts: 141
Registered: ‎05-24-2014
Kudos: 10
Solutions: 2

Re: 50% WAN speed on ERL3

With my Edgerouter i get without Problems the Speed of my 250Mbit/s connection. Can you post your Configuration?

New Member
Posts: 11
Registered: ‎06-15-2014
Kudos: 7
Solutions: 1

Re: 50% WAN speed on ERL3

Hi Berkutta, this is my configuration (plain of the box, created with the GUI wizard):

 

ubnt@ubnt:~$ show configuration
interfaces {
    ethernet eth0 {
        address 192.168.1.1/24
        duplex auto
        speed auto
    }
    ethernet eth1 {
        address dhcp
        duplex auto
        speed auto
    }
    ethernet eth2 {
        duplex auto
        speed auto
    }
    loopback lo {
    }
}
service {
    gui {
        https-port 443
    }
    nat {
:
interfaces {
    ethernet eth0 {
        address 192.168.1.1/24
        duplex auto
        speed auto
    }
    ethernet eth1 {
        address dhcp
        duplex auto
        speed auto
    }
    ethernet eth2 {
        duplex auto
        speed auto
    }
    loopback lo {
    }
}
service {
    gui {
        https-port 443
    }
    nat {
        rule 5000 {
            description "To the Internet"
            log disable
            outbound-interface eth1
            protocol all
            type masquerade
        }
    }
    ssh {
        port 22
        protocol-version v2
    }
}
system {
    host-name ubnt
    login {
        user ubnt {
            authentication {
                encrypted-password ****************
            }
            level admin
        }
    }
    ntp {
        server 0.ubnt.pool.ntp.org {
        }
        server 1.ubnt.pool.ntp.org {
        }
        server 2.ubnt.pool.ntp.org {
        }
        server 3.ubnt.pool.ntp.org {
        }
    }
    offload {
        ipsec enable
        ipv4 {
            forwarding enable
            vlan enable
        }
        ipv6 {
            forwarding enable
            vlan enable
        }
    }
    syslog {
        global {
            facility all {
                level notice
            }
            facility protocols {
                level debug
            }
        }
    }
    time-zone UTC
}

Member
Posts: 141
Registered: ‎05-24-2014
Kudos: 10
Solutions: 2

Re: 50% WAN speed on ERL3

Do you have the performance problem even if you're hanging the WAN port of the ERL to the Asus Rotuer and your computer to the LAN port of the ERL?

New Member
Posts: 11
Registered: ‎06-15-2014
Kudos: 7
Solutions: 1

Re: 50% WAN speed on ERL3

I do not have that problem when hanging the ERL behind the Asus Router and my computer to the LAN port of the ERL.


It only happens when I try to mimic the following configuration:

Internet -> Ubee modem (in transparent mode, it passes the public IPv4 address to the next device -> ERL eth1 -> Computer (connected to the eth0 interface on the ERL).

Member
Posts: 141
Registered: ‎05-24-2014
Kudos: 10
Solutions: 2

Re: 50% WAN speed on ERL3

Is it possible that your Cable Company throttle the Speed of the MAC Adress of the ERL, but not of the MAC of the Asus Router? 

You could try to clone temporarily the MAC Adress of the Asus to the MAC Adress of the ERL. But for this you must disconnect the Asus during connection of the ERL.

1. Find the MAC Adress of the Asus (Webinterface/Sticker on the housing), note it down

2. Note the MAC Adress of the WAN Interface on the ERL to revert later the originally MAC Adress (http://community.ubnt.com/t5/EdgeMAX/Interface-MAC-address/td-p/611703)

3. Change the MAC Adress of the WAN Interface (https://community.ubnt.com/t5/EdgeMAX/Clone-MAC-adress-from-old-firewall/td-p/388931)

 

New Member
Posts: 11
Registered: ‎06-15-2014
Kudos: 7
Solutions: 1

Re: 50% WAN speed on ERL3

I didn't think of that option! I will clone the mac adress of the asus router and I will post my findings.

SuperUser
Posts: 16,841
Registered: ‎02-03-2013
Kudos: 9213
Solutions: 601
Contributions: 2

Re: 50% WAN speed on ERL3

Any chance you are negotiating at 100baseT instead of gig with your test machine when connected to the ERL?  Would check that to rule this out.

ubiquiti certified trainer :: ubwa | uewa
New Member
Posts: 11
Registered: ‎06-15-2014
Kudos: 7
Solutions: 1

Re: 50% WAN speed on ERL3

I have tested the mac clone option, but my ISP did not give me the same ip address as before. They check for mac clone situations.


I did some file transfer tests using this website: https://kb.leaseweb.com/display/KB/Link+speeds

and my average speed using the ERL-3 is 19MbitsIcon Razz

Either way I'm happy that my ERL is not the bottleneck and that I just had to choose a proper link speed website that offers big binary files to download.

In 5 weeks I will be having FttH with 100Mbits/100Mbits as initial speed. In the autumn my new ISP will upgrade the FttH speed to 500Mbits/500Mbits and the ERL will be ready to route at this speed.

Thank you all for your suggestions and tips!