Emerging Member
Posts: 98
Registered: ‎01-21-2013
Kudos: 19
Accepted Solution

CLI through web gui

Is there a setting to always keep the cli connected when using it through web gui? It times out and asks you to reconnect. 


Accepted Solutions
Previous Employee
Posts: 13,551
Registered: ‎06-10-2011
Kudos: 5479
Solutions: 1656
Contributions: 2

Re: CLI through web gui

Yeah currently there is a default timeout of 5 minutes if there is no activity, and we have discussed making this a configurable setting. For now, one workaround is to run something like "top" to keep the connection alive Icon Lol  Another is to add a line like this:

websocket.timeout = 500

 in the Web server config file "/etc/lighttpd/lighttpd.conf" and then restart the Web server (simplest may be to reboot the router).

View solution in original post


All Replies
Ubiquiti Employee
Posts: 2,991
Registered: ‎02-04-2013
Kudos: 354
Solutions: 289

Re: CLI through web gui

How often does it time out? I assume it times out if you don't use it for some time, but it doesn't if you keep using it, right? 

Emerging Member
Posts: 98
Registered: ‎01-21-2013
Kudos: 19

Re: CLI through web gui

Correct, if I am using it doesn't time out. Sometimes I step a way for a while so I would like to keep it connected at all times. Is this possible or is it a security measure that can not be changed?

Member
Posts: 148
Registered: ‎02-20-2010
Kudos: 29

Re: CLI through web gui

I would have to agree that the web CLI times out far too quickly.  If someone looks away to reference documentation or watch a funny cat video someone just sent them it'll time out and they'll loose any non-committed changes.

 

I primarily just ssh into the router but when I played with the GUI that was one thing that really stood out.  There should be an option to adjust it.

Previous Employee
Posts: 13,551
Registered: ‎06-10-2011
Kudos: 5479
Solutions: 1656
Contributions: 2

Re: CLI through web gui

Yeah currently there is a default timeout of 5 minutes if there is no activity, and we have discussed making this a configurable setting. For now, one workaround is to run something like "top" to keep the connection alive Icon Lol  Another is to add a line like this:

websocket.timeout = 500

 in the Web server config file "/etc/lighttpd/lighttpd.conf" and then restart the Web server (simplest may be to reboot the router).

Highlighted
Emerging Member
Posts: 98
Registered: ‎01-21-2013
Kudos: 19

Re: CLI through web gui

Thank you. I will check this out.