Emerging Member
Posts: 56
Registered: ‎02-25-2014
Kudos: 31
Solutions: 1

Cannot log into web cli using same credentials as web login

I have set up 2 new admins in the ERL and deleted the default ubnt user.

I cannot access the cli via the config web page - both users give an incorrect login; before I added any new users I had the same result with ubnt/ubnt....

Any clues?

Previous Employee
Posts: 13,551
Registered: ‎06-10-2011
Kudos: 5474
Solutions: 1656
Contributions: 2

Re: Cannot log into web cli using same credentials as web login

Could you clarify if you mean for example you can access the Web UI using ubnt/ubnt but then if you open the "CLI window" in the Web UI then ubnt/ubnt fails to login in that windiw?

Emerging Member
Posts: 56
Registered: ‎02-25-2014
Kudos: 31
Solutions: 1

Re: Cannot log into web cli using same credentials as web login

exactly that

Previous Employee
Posts: 13,551
Registered: ‎06-10-2011
Kudos: 5474
Solutions: 1656
Contributions: 2

Re: Cannot log into web cli using same credentials as web login

I was not able to replicate the issue. If you're not running the latest release, can you try upgrading to the latest (v1.4.1) and do the test again? Also you can provide the configuration so that people can take a look.

Emerging Member
Posts: 56
Registered: ‎02-25-2014
Kudos: 31
Solutions: 1

Re: Cannot log into web cli using same credentials as web login

Apologoies if this is stupid, but yes am on 1.4.1, but given that I cannot get into the CLI, how do I post the config? Is it just the backup file you need? It has some IP addresses and pppoe settings that I would not want publicised....

Previous Employee
Posts: 13,551
Registered: ‎06-10-2011
Kudos: 5474
Solutions: 1656
Contributions: 2

Re: Cannot log into web cli using same credentials as web login

Have you tried using SSH to access the CLI (instead of the CLI window in the Web UI)? Also, the backup file is a ".tar.gz" file and you can extract the content to get the configuration file (config.boot) and remove any sensitive information.

Emerging Member
Posts: 56
Registered: ‎02-25-2014
Kudos: 31
Solutions: 1

Re: Cannot log into web cli using same credentials as web login

Yes I can ssh into the ERL. Config.boot attached

Attachment
Emerging Member
Posts: 56
Registered: ‎02-25-2014
Kudos: 31
Solutions: 1

Re: Cannot log into web cli using same credentials as web login

[ Edited ]

cannot access the cli from within the gui on 1.5 beta.latest either....

Emerging Member
Posts: 56
Registered: ‎02-25-2014
Kudos: 31
Solutions: 1

Re: Cannot log into web cli using same credentials as web login

a bit more detail:

I have 2 users set up; with the admin user, first in the user list, I CAN log into the cli, but with the second user I CANNOT, but this user logs into the GUI fine...... Odd!

Previous Employee
Posts: 13,551
Registered: ‎06-10-2011
Kudos: 5474
Solutions: 1656
Contributions: 2

Re: Cannot log into web cli using same credentials as web login

OK so just to clarify, sounds like you have two users (say "user1" and "user2"), and both users can login through both SSH and the GUI, but from the GUI, user1 can use the CLI window but user2 cannot? Is this summary correct?

 

Emerging Member
Posts: 56
Registered: ‎02-25-2014
Kudos: 31
Solutions: 1

Re: Cannot log into web cli using same credentials as web login

Correct; whilst logged in as user2, user2 CANNOT log into the cli, but user1 can.

Previous Employee
Posts: 13,551
Registered: ‎06-10-2011
Kudos: 5474
Solutions: 1656
Contributions: 2

Re: Cannot log into web cli using same credentials as web login

Can you try swapping the passwords of the two users and see if the result is the reverse? Just verifying if any special characters in the password might cause issue with the CLI window in Web UI.

Emerging Member
Posts: 56
Registered: ‎02-25-2014
Kudos: 31
Solutions: 1

Re: Cannot log into web cli using same credentials as web login

there are no special characters in the passes: just upper and lower case letters and numbers (i know to include symbols as well; these passesa are just for testing)

I added in a 3rd user, and access to cli again denied; logged in to gui NOT as that user....

Do you still want me to do the swap?

 

Previous Employee
Posts: 13,551
Registered: ‎06-10-2011
Kudos: 5474
Solutions: 1656
Contributions: 2

Re: Cannot log into web cli using same credentials as web login

Yeah sure, basically we need to find out is what is special about this user that causes the issue. Btw 1.5 has been released so you might want to upgrade as well. Also I assume all tests are done with the same PC and the same version of the same browser?