New Member
Posts: 18
Registered: ‎05-14-2013
Kudos: 1
Accepted Solution

DNS Config Question

Hi,

 

I have attempted to configure the EdgeMax to be the DNS for the attached endpoints and for the EdgeMax to forward any DNS lookups that it cannot resolve (i.e. not in its cache) to the ISP DNS.

 

eth0 is my WAN and eth1 is my Lan

 

In the DHCP config for eth1 I have set the DNS server address to be the address of eth1.

 

I have configured DNS forwarding to listen on eth1 and to use the DNS address received over DHCP from eth0.

 

Is my approach sensible and is the config below correct?

 

Thanks for your feedback!

 

Sam

 

 

service {
    dhcp-server {
        disabled false
        
        shared-network-name PKN-DHCP {
            authoritative disable
            subnet 192.168.1.0/24 {
                default-router 192.168.1.1
                dns-server 192.168.1.1
                lease 86400
                start 192.168.1.100 {
                    stop 192.168.1.254
                }
            }
        }
    }
    dns {
        forwarding {
            cache-size 150
            dhcp eth0
            listen-on eth1
        }

Accepted Solutions
Previous Employee
Posts: 13,551
Registered: ‎06-10-2011
Kudos: 5474
Solutions: 1656
Contributions: 2

Re: DNS Config Question

Yeah the config looks OK assuming the interface config is correct and the DNS servers are obtained from DHCP of course.

View solution in original post


All Replies
Previous Employee
Posts: 13,551
Registered: ‎06-10-2011
Kudos: 5474
Solutions: 1656
Contributions: 2

Re: DNS Config Question

Yeah the config looks OK assuming the interface config is correct and the DNS servers are obtained from DHCP of course.

Highlighted
New Member
Posts: 18
Registered: ‎05-14-2013
Kudos: 1

Re: DNS Config Question

Yup, they are and it all seems to work fine, just wanted to double check - thanks for the feedback