Reply
New Member
Posts: 6
Registered: ‎06-17-2014
Kudos: 2

ER-Lite | 6rd issue with /47 prefix (tun0: ioctl 89f9 failed: Invalid argument)

Hi

 

I'm having issues setting up a 6rd tunnel with Altibox (Scandinavian ISP) using the following information provided by them:

 

IPv4 BR address: 37.97.56.1
IPv4 Prefix: 17
IPv6 Prefix: 2A00:FD00:FFF0::
IPv6 Prefix Length: 47

Which translates to the following commands:

 

set interfaces tunnel tun0 6rd-prefix '2a00:fd00:fff0::/47'
set interfaces tunnel tun0 6rd-default-gw ::37.97.56.1
set interfaces tunnel tun0 address '2a00:fd00:fff0:4050::1/62'
set interfaces tunnel tun0 description 'Altibox IPv6 6rd tunnel'
set interfaces tunnel tun0 encapsulation sit
set interfaces tunnel tun0 local-ip 37.97.16.20
set interfaces tunnel tun0 mtu 1480
set interfaces tunnel tun0 multicast disable
set interfaces tunnel tun0 ttl 255

 

All commands are accepted, but when committing it does the following:

 

 

# commit
[ interfaces tunnel tun0 6rd-prefix 2a00:fd00:fff0::/47 ]
tun0: ioctl 89f9 failed: Invalid argument
Commit failed

Apparently it doesn't like the /47 prefix ?

 

Tested and using the same 6rd parameters in pfSense without issues..

 

Is it a bug, or am I doing something wrong?

 

/Kewin

New Member
Posts: 6
Registered: ‎06-17-2014
Kudos: 2

Re: ER-Lite | 6rd issue with /47 prefix (tun0: ioctl 89f9 failed: Invalid argument)

Tried the same on an ER-X at a different site with the same ISP (but different BR):

 

# set interfaces tunnel tun0 6rd-prefix '2a00:fd00:fff0::/47'
# set interfaces tunnel tun0 6rd-default-gw ::188.228.2.36
# set interfaces tunnel tun0 address '2a00:fd00:fff1:fea8::1/62'
# set interfaces tunnel tun0 description 'Altibox IPv6 6rd tunnel'
# set interfaces tunnel tun0 encapsulation sit
# set interfaces tunnel tun0 local-ip 188.228.127.170
# set interfaces tunnel tun0 mtu 1480
# set interfaces tunnel tun0 multicast disable
# set interfaces tunnel tun0 ttl 255
# commit

[ interfaces tunnel tun0 6rd-prefix 2a00:fd00:fff0::/47 ]
tun0: ioctl 89f9 failed: Invalid argument
Commit failed
[edit]

$ show version all
Version: v1.9.1
Build ID: 4939092
Build on: 12/14/16 07:02
HW model: EdgeRouter X 5-Port

Same result :/

New Member
Posts: 2
Registered: ‎03-12-2017

Re: ER-Lite | 6rd issue with /47 prefix (tun0: ioctl 89f9 failed: Invalid argument)

Same here. Were you able to figure this out?

Veteran Member
Posts: 5,781
Registered: ‎01-04-2017
Kudos: 830
Solutions: 294

Re: ER-Lite | 6rd issue with /47 prefix (tun0: ioctl 89f9 failed: Invalid argument)

Is it from the quotations around the prefix?
New Member
Posts: 2
Registered: ‎03-12-2017

Re: ER-Lite | 6rd issue with /47 prefix (tun0: ioctl 89f9 failed: Invalid argument)

No, i didnt use them

New Member
Posts: 10
Registered: ‎07-15-2014
Kudos: 2

Re: ER-Lite | 6rd issue with /47 prefix (tun0: ioctl 89f9 failed: Invalid argument)

I have the same issue with an EdgeRouter X SFP on Altibox. Did you find a solution for this?

 

-Lars

Emerging Member
Posts: 80
Registered: ‎04-15-2017
Kudos: 18

Re: ER-Lite | 6rd issue with /47 prefix (tun0: ioctl 89f9 failed: Invalid argument)

[ Edited ]

Deleted duplicate post.

Emerging Member
Posts: 80
Registered: ‎04-15-2017
Kudos: 18

Re: ER-Lite | 6rd issue with /47 prefix (tun0: ioctl 89f9 failed: Invalid argument)

[ Edited ]

Hopefully my post doesn't get automatically deleted this time.

 

I had similar issues setting up 6rd on an ERL on a different ISP.  I found alot of old out dated information that caused me some problems.

 

Here is what I used to setup the tunnel on firmware 1.91. Note the setup is different than what you are using.

 

I've left some of the address's I used for an example, replace with you own

 

Tunnel setup:

set interfaces tunnel tun0 prefix 2600:16f0::/28        /* this line maybe optional but I needed it to work */
set interfaces tunnel tun0 address '2600:XXXX:XXXX:XXXX::1/28'    /* replace Xs' with your calculated IPv6 Customer prefix from »silmor.de/ipaddrcalc.html#ip6 use IPv4 to IPv6 Transitional section */

set interfaces tunnel tun0 description 'IPv6 Tunnel'
set interfaces tunnel tun0 encapsulation sit
set interfaces tunnel tun0 local-ip xxx.xxx.xxx.xxx /* you IPv4 WAN IP goes here */
set interfaces tunnel tun0 multicast disable
set interfaces tunnel tun0 remote-ip xxx.xxx.xxx.xxx    /* IPv4 tunnel address */
set interfaces tunnel tun0 ttl 255
set protocols static interface-route6 '::/0' next-hop-interface tun0

type "commit" hit enter then type "save" and hit enter.

Note: at this point I would do a ping6 to www.google.com to make sure the tunnel is up, once that's confirmed continue with the rest of the setup.

 

Below is the LAN side of things.  You may have to change some of the numbers other than IPV6 address's to match what your ISP requires.  Ifyou you use something other than eth1 for your LAN please update it to your interface.

 

 

Ethernet setup:

set interfaces ethernet eth1 address '2600:XXXX:XXXX:XXXX::/64' /* same address as calculated IPv6 Customer prefix */
set interfaces ethernet eth1 ipv6 dup-addr-detect-transmits 1
set interfaces ethernet eth1 ipv6 router-advert cur-hop-limit 64
set interfaces ethernet eth1 ipv6 router-advert link-mtu 1480
set interfaces ethernet eth1 ipv6 router-advert managed-flag false
set interfaces ethernet eth1 ipv6 router-advert max-interval 300
set interfaces ethernet eth1 ipv6 router-advert other-config-flag false
set interfaces ethernet eth1 ipv6 router-advert prefix '2600:XXXX:XXXX:XXXX::/64' autonomous-flag true /* same address as calculatedIPv6 Customer prefix */
set interfaces ethernet eth1 ipv6 router-advert prefix '2600:XXXX:XXXX:XXXX::/64' on-link-flag true /* same address as calculatedIPv6 Customer prefix */
set interfaces ethernet eth1 ipv6 router-advert prefix '2600:XXXX:XXXX:XXXX::/64' valid-lifetime 2592000 /* same address as calculatedIPv6 Customer prefix */
set interfaces ethernet eth1 ipv6 router-advert radvd-options 'RDNSS (enter your ISP IPV6 DNS server adress's here seperated by a space) {};'
set interfaces ethernet eth1 ipv6 router-advert reachable-time 0
set interfaces ethernet eth1 ipv6 router-advert retrans-timer 0
set interfaces ethernet eth1 ipv6 router-advert send-advert true

commit

save

 

Hopefully this helps

New Member
Posts: 6
Registered: ‎06-17-2014
Kudos: 2

Re: ER-Lite | 6rd issue with /47 prefix (tun0: ioctl 89f9 failed: Invalid argument)

Nope, I never found a solution that enabled me to utilize the 6rd implementation of the EdgeMax.

 

Instead, as a workaround, I had to create static IPv6 tunnels to the 6rd relay server.. It's a workaround I dont really like, since a single IP change on the ISP's behalf, will cause everything to break :/

 

I don't believe 6rd is fully implemented on EdgeMax yet..

New Member
Posts: 10
Registered: ‎07-15-2014
Kudos: 2

Re: ER-Lite | 6rd issue with /47 prefix (tun0: ioctl 89f9 failed: Invalid argument)

So, I have Altibox fiber internet in my summerhouse with an EdgeRouter X-SFP and wanted to get IPv6 working here as a proof of concept. It proved to be a bit difficult, but in the end it worked. The EdgeRouter is connected to a fiber-to-ethernet connector, completely removes the need for the big router provided by Altibox.
Thus, this post is based on a LOT of people’s contributions.
 
To begin with, the info from Altibox: https://www.altibox.dk/sadan-kommer-du-i-gang-med-ipv6/
 
IPv4 BR adresse: 188.228.2.36
IPv4 Prefix: 17
IPv6 Prefix: 2A00:FD00:FFF0::
IPv6 Prefix Length: 47 
IPv6 DNS: 2a01:798:0:8012::4
 
To calculate the proper values for the configuration, use this piece of bash: 
 
 
#!/bin/bash
PREFIX=2A00:FD00:FFF0::
PREFIX_LENGTH=47
RELAY_PREFIX=188.228.2.36
RELAY_PREFIX_LENGTH=17
PUBLIC=$(curl http://canihazip.com/s)

ipv6calc --action 6rd_local_prefix --6rd_prefix $PREFIX/$PREFIX_LENGTH --6rd_relay_prefix $RELAY_PREFIX/$RELAY_PREFIX_LENGTH $PUBLIC
 
 
In my case, this gave a result looking like this:
2a00:fd00:fff0:XXXX::/62
 
 
In configure mode in EdgeRouter, enter the following lines:
 
 
set interfaces tunnel tun0 address '2a00:fd00:fff0:XXXX::/62'        
set interfaces tunnel tun0 description 'Altibox 6rd tunnel'
set interfaces tunnel tun0 encapsulation sit
set interfaces tunnel tun0 local-ip XXX.XXX.XXX.XXX (get this from http://canihazip.com/s)
set interfaces tunnel tun0 multicast disable
set interfaces tunnel tun0 remote-ip 188.228.2.36
set interfaces tunnel tun0 ttl 255
set protocols static interface-route6 '::/0' next-hop-interface tun0
set system name-server '2001:4860:4860::8888’

commit
Now is a good time to see if the router can access an IPv6 address, such as Google:
$ ping6 ipv6.google.com
 
 
Next up is preparing the firewall rules so we’re protected.
 
 
set firewall ipv6-name WANv6_IN default-action drop
set firewall ipv6-name WANv6_IN description 'WAN inbound traffic forwarded to LAN'
set firewall ipv6-name WANv6_IN enable-default-log
set firewall ipv6-name WANv6_IN rule 10 action accept
set firewall ipv6-name WANv6_IN rule 10 description 'Allow established/related sessions'
set firewall ipv6-name WANv6_IN rule 10 state established enable
set firewall ipv6-name WANv6_IN rule 10 state related enable
set firewall ipv6-name WANv6_IN rule 20 action drop
set firewall ipv6-name WANv6_IN rule 20 description 'Drop invalid state'
set firewall ipv6-name WANv6_IN rule 20 state invalid enable
set firewall ipv6-name WANv6_LOCAL default-action drop
set firewall ipv6-name WANv6_LOCAL description 'WAN inbound traffic to the router'
set firewall ipv6-name WANv6_LOCAL enable-default-log
set firewall ipv6-name WANv6_LOCAL rule 10 action accept
set firewall ipv6-name WANv6_LOCAL rule 10 description 'Allow established/related sessions'
set firewall ipv6-name WANv6_LOCAL rule 10 state established enable
set firewall ipv6-name WANv6_LOCAL rule 10 state related enable
set firewall ipv6-name WANv6_LOCAL rule 20 action drop
set firewall ipv6-name WANv6_LOCAL rule 20 description 'Drop invalid state'
set firewall ipv6-name WANv6_LOCAL rule 20 state invalid enable
set firewall ipv6-name WANv6_LOCAL rule 30 action accept
set firewall ipv6-name WANv6_LOCAL rule 30 description 'Allow IPv6 icmp'
set firewall ipv6-name WANv6_LOCAL rule 30 protocol ipv6-icmp
set firewall ipv6-name WANv6_LOCAL rule 40 action accept
set firewall ipv6-name WANv6_LOCAL rule 40 description 'allow dhcpv6'
set firewall ipv6-name WANv6_LOCAL rule 40 destination port 546
set firewall ipv6-name WANv6_LOCAL rule 40 protocol udp
set firewall ipv6-name WANv6_LOCAL rule 40 source port 547
set firewall ipv6-receive-redirects disable
set firewall ipv6-src-route disable
set firewall ip-src-route disable
set firewall log-martians enable
 
and attach them to your WAN interface:
 
 
set interfaces ethernet eth0 vif 102 firewall in ipv6-name WANv6_IN
set interfaces ethernet eth0 vif 102 firewall local ipv6-name WANv6_LOCAL
 
Altibox delivers internet on VLAN 102, so the rules are attached here.
 
Don’t forget to commit to see if there are any errors.
 
Now it is time to allow LAN devices to get an IPv6 address. Remember to replace the X’s with your own value before attempting this Man Happy
 
 
set interfaces switch switch0 address '2a00:fd00:fff0:XXXX::/64'
set interfaces switch switch0 ipv6 dup-addr-detect-transmits 1
set interfaces switch switch0 ipv6 router-advert reachable-time 0
set interfaces switch switch0 ipv6 router-advert retrans-timer 0
set interfaces switch switch0 ipv6 router-advert send-advert true
set interfaces switch switch0 ipv6 router-advert cur-hop-limit 64
set interfaces switch switch0 ipv6 router-advert link-mtu 1480
set interfaces switch switch0 ipv6 router-advert managed-flag false
set interfaces switch switch0 ipv6 router-advert max-interval 300
set interfaces switch switch0 ipv6 router-advert other-config-flag false
set interfaces switch switch0 ipv6 router-advert prefix '2a00:fd00:fff0:XXXX::/64' autonomous-flag true
set interfaces switch switch0 ipv6 router-advert prefix '2a00:fd00:fff0:XXXX::/64' on-link-flag true
set interfaces switch switch0 ipv6 router-advert prefix '2a00:fd00:fff0:XXXX::/64' valid-lifetime 2592000
set interfaces switch switch0 ipv6 router-advert radvd-options 'RDNSS 2a01:798:0:8012::4 {};'

commit
And you’re done!
 
New Member
Posts: 25
Registered: ‎02-18-2015
Kudos: 5
Solutions: 1

Re: ER-Lite | 6rd issue with /47 prefix (tun0: ioctl 89f9 failed: Invalid argument)

[ Edited ]

I have Altibox myself and followed your guide all the way until the last part about allowing LAN devices to get IPv6 addresses.

 

The first line setting the address for the switch0 to the IPv6 address I get an error stating that this address already have been assigned to tunnel tun0.

 

The tunnel is up and I have an ipv6 address and can do ping6 ipv6.google.com on the router.

New Member
Posts: 10
Registered: ‎07-15-2014
Kudos: 2

Re: ER-Lite | 6rd issue with /47 prefix (tun0: ioctl 89f9 failed: Invalid argument)

That's weird.

 

This following is my newest config of the switch0 and tun0 interfaces. I have "upgraded" my Edgerouter X-SFP with dhcpv6, so it differs a bit from the above config, but here it goes:

 

set interfaces switch switch0 address 10.13.13.1/24
set interfaces switch switch0 address '2a00:fd00:fff0:XXXX::/64'
set interfaces switch switch0 description Switch
set interfaces switch switch0 ipv6 dup-addr-detect-transmits 1
set interfaces switch switch0 ipv6 router-advert cur-hop-limit 64
set interfaces switch switch0 ipv6 router-advert link-mtu 1500
set interfaces switch switch0 ipv6 router-advert managed-flag true
set interfaces switch switch0 ipv6 router-advert max-interval 300
set interfaces switch switch0 ipv6 router-advert other-config-flag true
set interfaces switch switch0 ipv6 router-advert prefix '2a00:fd00:fff0:XXXX::/64' autonomous-flag false
set interfaces switch switch0 ipv6 router-advert prefix '2a00:fd00:fff0:XXXX::/64' on-link-flag true
set interfaces switch switch0 ipv6 router-advert prefix '2a00:fd00:fff0:XXXX::/64' valid-lifetime 2592000
set interfaces switch switch0 ipv6 router-advert reachable-time 0
set interfaces switch switch0 ipv6 router-advert retrans-timer 0
set interfaces switch switch0 ipv6 router-advert send-advert true
set interfaces switch switch0 mtu 1500
set interfaces switch switch0 switch-port interface eth1
set interfaces switch switch0 switch-port interface eth2
set interfaces switch switch0 switch-port interface eth3
set interfaces switch switch0 switch-port interface eth4
set interfaces switch switch0 switch-port vlan-aware disable
set interfaces tunnel tun0 address '2a00:fd00:fff0:XXXX::/62'
set interfaces tunnel tun0 description 'Altibox IPv6 tunnel'
set interfaces tunnel tun0 encapsulation sit
set interfaces tunnel tun0 firewall in ipv6-name WANv6_IN
set interfaces tunnel tun0 firewall local ipv6-name WANv6_LOCAL
set interfaces tunnel tun0 local-ip 188.XXX.XXX.XXX
set interfaces tunnel tun0 multicast disable
set interfaces tunnel tun0 remote-ip 188.228.2.36
set interfaces tunnel tun0 ttl 255 

Can you post your config maybe?

New Member
Posts: 25
Registered: ‎02-18-2015
Kudos: 5
Solutions: 1

Re: ER-Lite | 6rd issue with /47 prefix (tun0: ioctl 89f9 failed: Invalid argument)

Hi

 

I notice the two addresses in your case are not the same after all.

 

set interfaces switch switch0 address '2a00:fd00:fff0:XXXX::/64'
set interfaces tunnel tun0 address '2a00:fd00:fff0:XXXX::/62'

 

I did not see that difference the first time. Will retry now...

 

New Member
Posts: 25
Registered: ‎02-18-2015
Kudos: 5
Solutions: 1

Re: ER-Lite | 6rd issue with /47 prefix (tun0: ioctl 89f9 failed: Invalid argument)

No errors, but the client's don't route ipv6 traffic correct.

 

My (partilal) config:

 

 firewall {
     all-ping enable
     broadcast-ping disable
     ipv6-name WANv6_IN {
         default-action drop
         description "WAN inbound traffic forwarded to LAN"
         enable-default-log
         rule 10 {
             action accept
             description "Allow established/related sessions"
             state {
                 established enable
                 related enable
             }
         }
         rule 20 {
             action drop
             description "Drop invalid state"
             state {
                 invalid enable
             }
         }
     }
     ipv6-name WANv6_LOCAL {
         default-action drop
         description "WAN inbound traffic to the router"
         enable-default-log
         rule 10 {
             action accept
             description "Allow established/related sessions"
             state {
                 established enable
                 related enable
             }
         }
         rule 20 {
             action drop
             description "Drop invalid state"
             state {
                 invalid enable
             }
         }
         rule 30 {
             action accept
             description "Allow IPv6 icmp"
             protocol ipv6-icmp
         }
         rule 40 {
             action accept
             description "allow dhcpv6"
             destination {
                 port 546
             }
             protocol udp
             source {
                 port 547
             }
         }
     }
     ipv6-receive-redirects disable
     ipv6-src-route disable
     ip-src-route disable
     log-martians enable
     name WAN_IN {
         default-action drop
         description "WAN to internal"
         rule 10 {
             action accept
             description "Allow established/related"
             state {
                 established enable
                 related enable
             }
         }
         rule 20 {
             action drop
             description "Drop invalid state"
             state {
                 invalid enable
             }
         }
     }
     name WAN_LOCAL {
         default-action drop
         description "WAN to router"
         rule 10 {
             action accept
             description "Allow established/related"
             state {
                 established enable
                 related enable
             }
         }
         rule 20 {
             action drop
             description "Drop invalid state"
             state {
                 invalid enable
             }
         }
     }
     receive-redirects disable
     send-redirects enable
     source-validation disable
     syn-cookies enable
 }
 interfaces {
     ethernet eth0 {
         address dhcp
         address dhcpv6
         description Internet
         duplex auto
         firewall {
             in {
                 ipv6-name WANv6_IN
                 name WAN_IN
             }
             local {
                 ipv6-name WANv6_LOCAL
                 name WAN_LOCAL
             }
         }
         poe {
             output off
         }
         speed auto
     }
     
     ethernet eth2 {
         description LAN
         duplex auto
         poe {
             output off
         }
         speed auto
     }
     loopback lo {
     }
     switch switch0 {
         address 192.168.10.1/24
         address 2a01:79c:xxxx:xxxx::/64
         description "Local 2"
         ipv6 {
             dup-addr-detect-transmits 1
             router-advert {
                 cur-hop-limit 64
                 link-mtu 1480
                 managed-flag false
                 max-interval 300
                 other-config-flag false
                 prefix 2a01:79c:xxxx:xxxx::/64 {
                     autonomous-flag true
                     on-link-flag true
                     valid-lifetime 2592000
                 }
                 radvd-options "RDNSS 2a01:798:0:8012::4 {};"
                 reachable-time 0
                 retrans-timer 0
                 send-advert true
             }
         }
         mtu 1500
         switch-port {
             interface eth2 {
             }
             interface eth3 {
             }
             interface eth4 {
             }
             vlan-aware disable
         }
     }
     tunnel tun0 {
         6rd-prefix 2a01:79c::/30
         6rd-default-gw ::213.167.115.92
         address 2a01:79c:xxxx:xxxx::/62
         description "Altibox 6rd tunnel"
         encapsulation sit
         local-ip 51.174.xxx.xxx
         mtu 1480
         multicast disable
         ttl 255
     }
 }
 protocols {
     static {
         interface-route6 ::/0 {
             next-hop-interface tun0 {
             }
         }
     }
 }
 service {
     dhcp-server {
         disabled false
         hostfile-update disable
         shared-network-name LAN1 {
             authoritative enable
             subnet 192.168.1.0/24 {
                 default-router 192.168.1.1
                 dns-server 192.168.1.1
                 lease 86400
                 start 192.168.1.38 {
                     stop 192.168.1.243
                 }
             }
         }
         shared-network-name LAN2 {
             authoritative enable
             subnet 192.168.10.0/24 {
                 default-router 192.168.10.1
                 dns-server 192.168.10.1
                 dns-server 8.8.8.8
                 lease 86400
                 start 192.168.10.100 {
                     stop 192.168.10.253
                 }
                 unifi-controller 192.168.10.10
             }
         }
         use-dnsmasq disable
     }
     dns {
         forwarding {
             cache-size 150
             listen-on switch0
         }
     }
     gui {
         http-port 80
         https-port 443
         older-ciphers enable
     }
     nat {
         rule 5010 {
             description "masquerade for WAN"
             outbound-interface eth0
             type masquerade
         }
     }
     ssh {
         port 22
         protocol-version v2
     }
     unms {
         disable
     }
 }
 system {
     name-server 2a01:798:0:8012::4	
 }
New Member
Posts: 10
Registered: ‎07-15-2014
Kudos: 2

Re: ER-Lite | 6rd issue with /47 prefix (tun0: ioctl 89f9 failed: Invalid argument)

Do your clients get IPv6 addresses assigned? How do they look?
New Member
Posts: 25
Registered: ‎02-18-2015
Kudos: 5
Solutions: 1

Re: ER-Lite | 6rd issue with /47 prefix (tun0: ioctl 89f9 failed: Invalid argument)

[ Edited ]

I only get what Windows calls Link-local IPv6 Address : fe80::2098:8213:9888:9121%23

 

Do I have to enable IP6 DHCP somehow?

 

New Member
Posts: 10
Registered: ‎07-15-2014
Kudos: 2

Re: ER-Lite | 6rd issue with /47 prefix (tun0: ioctl 89f9 failed: Invalid argument)

Your configuration looks similar to mine before I enabled DHCPv6. Have you tried rebooting the router by any chance?
New Member
Posts: 25
Registered: ‎02-18-2015
Kudos: 5
Solutions: 1

Re: ER-Lite | 6rd issue with /47 prefix (tun0: ioctl 89f9 failed: Invalid argument)

I've not rebooted the router, will have to wait to "off hours" for that. How to I enable DHCPv6?

New Member
Posts: 10
Registered: ‎07-15-2014
Kudos: 2

Re: ER-Lite | 6rd issue with /47 prefix (tun0: ioctl 89f9 failed: Invalid argument)

Quick setup of a DHCPv6 server:

 

set service dhcpv6-server shared-network-name LANv6 subnet '2a00:7660:bad:0::/64' address-range start '2a00:xxxx:xxxx:0:1000::' stop '2a00:xxxx:xxxx:0:1999::'
set service dhcpv6-server shared-network-name LANv6 subnet '2a00:xxxx:xxxx:0::/64' domain-search lan.domain.dk
set service dhcpv6-server shared-network-name LANv6 subnet '2a00:xxxx:xxxx:0::/64' name-server 'fe80::xxxx:xxxx:f065'

Set switch0 to know that addresses are managed

set interfaces switch switch0 ipv6 router-advert managed-flag true
set interfaces switch switch0 ipv6 router-advert other-config-flag true

Turn off the autonomous ipv6 addresses

set interfaces switch switch0 ipv6 router-advert prefix '2a00:xxxx:xxxx:xxxx::/64' autonomous-flag false
Regular Member
Posts: 335
Registered: ‎04-25-2014
Kudos: 298
Solutions: 13

Re: ER-Lite | 6rd issue with /47 prefix (tun0: ioctl 89f9 failed: Invalid argument)

I'm encountering exactly the same behavior as described by @scrooge, while using a /43 prefix.

 

@UBNT-benpin - are you already aware of this issue? Seems to be straightforward to reproduce.

Reply