Reply
Highlighted
New Member
Posts: 6
Registered: ‎01-08-2019

ER-X OSPF won't advertise network assigned to switch0

[ Edited ]

I have some ER-X routers (all running 1.10.8) configured with OSPF/GRE/IPSEC as hub/spoke. One of the spokes (#2) is configured as WAN2LAN with  switch0 having address 192.168.1.1/24

So far the networks corresponding to active ethernet and lo interfaces are being routed via OSPF, but the network that only exists on switch0 isn't. After finding the posts here about the routing limitations for an address assigned directly to switch0 it was moved to the switch0.1 interface, but the 192.168.1.0/24 network still isn't included in the OSPF routes.

Have I overlooked something? Is it possible to get OSPF to include a network assigned to switch0(.1)?

 

 

Spoke#2 config:

 

002# show protocols ospf
 area 0 {
     network 10.101.1.0/30
 }
 area 2 {
     network 192.168.11.0/24
     network 192.168.1.0/24
 }
 passive-interface default
 passive-interface-exclude tun0
002:~$ show interfaces
Codes: S - State, L - Link, u - Up, D - Down, A - Admin Down
Interface    IP Address                        S/L  Description
---------    ----------                        ---  -----------
eth0         10.0.50.71/24                     u/u  Internet
eth1         -                                 u/u  Local
eth2         -                                 u/u  Local
eth3         -                                 u/u  Local
eth4         -                                 u/u  Local
lo           127.0.0.1/8                       u/u
             10.1.1.2/32
             192.168.11.1/24
             ::1/128
switch0      -                                 u/u  Local
switch0.1    192.168.1.1/24                    u/u
tun0         10.101.1.2/30                     u/u
002# show interfaces switch
 switch switch0 {
     description Local
     mtu 1500
     switch-port {
         interface eth1 {
             vlan {
                 pvid 1
             }
         }
         interface eth2 {
             vlan {
                 pvid 1
             }
         }
         interface eth3 {
             vlan {
                 pvid 1
             }
         }
         interface eth4 {
             vlan {
                 pvid 1
             }
         }
         vlan-aware enable
     }
     vif 1 {
         address 192.168.1.1/24
         mtu 1500
     }
 }

 

 

Spoke#3 config:

 

003# show protocols ospf 
 area 0 {
     network 10.101.1.4/30
 }
 area 3 {
     network 192.168.20.0/24
     network 192.168.30.0/24
 }
 passive-interface default
 passive-interface-exclude tun0

 

003:~$ show interfaces 
Codes: S - State, L - Link, u - Up, D - Down, A - Admin Down
Interface    IP Address                        S/L  Description                 
---------    ----------                        ---  -----------                 
eth0         -                                 u/u                              
eth1         -                                 u/u                              
eth2         172.17.17.157/24                  u/u                              
eth3         192.168.20.1/24                   u/u                              
eth4         -                                 u/D                              
lo           127.0.0.1/8                       u/u                              
             10.1.1.3/32                      
             192.168.30.1/24                  
             ::1/128                          
pppoe0       pub.lic.ip.89                     u/u                              
switch0      -                                 u/u                              
tun0         10.101.1.6/30                     u/u                              

 

 

Spoke#2 routes:

 

002:~$ show ip route
IP Route Table for VRF "default"
S *> 0.0.0.0/0 [210/0] via 10.0.50.1, eth0
C *> 10.0.50.0/24 is directly connected, eth0
O *> 10.1.1.1/32 [110/20] via 10.101.1.1, tun0, 03:23:44
C *> 10.1.1.2/32 is directly connected, lo
C *> 10.101.1.0/30 is directly connected, tun0
O *> 10.101.1.4/30 [110/20] via 10.101.1.1, tun0, 03:23:44
C *> 127.0.0.0/8 is directly connected, lo
C *> 192.168.1.0/24 is directly connected, switch0.1
C *> 192.168.11.0/24 is directly connected, lo
O IA *> 192.168.20.0/24 [110/30] via 10.101.1.1, tun0, 03:23:44
O IA *> 192.168.30.1/32 [110/30] via 10.101.1.1, tun0, 03:23:44

 

 

Spoke#3 ospf routes:

 

003:~$ show ip route ospf
IP Route Table for VRF "default"
O    *> 10.1.1.1/32 [110/20] via 10.101.1.5, tun0, 1d01h44m
O    *> 10.101.1.0/30 [110/20] via 10.101.1.5, tun0, 1d01h44m
O IA *> 192.168.11.1/32 [110/30] via 10.101.1.5, tun0, 03:53:26

 

 

Hub ospf routes:

 

001:~$ show ip route ospf
IP Route Table for VRF "default"
O IA *> 192.168.11.1/32 [110/20] via 10.101.1.2, tun0, 03:34:52
O IA *> 192.168.20.0/24 [110/20] via 10.101.1.6, tun1, 03:48:36
O IA *> 192.168.30.1/32 [110/20] via 10.101.1.6, tun1, 1d01h25m

 

 

 

 

Veteran Member
Posts: 7,600
Registered: ‎03-24-2016
Kudos: 1977
Solutions: 871

Re: ER-X OSPF won't advertise network assigned to switch0

Not what you want....but what happens after:

Spoiler
set protocols ospf passive-interface-exclude switch0.1
New Member
Posts: 6
Registered: ‎01-08-2019

Re: ER-X OSPF won't advertise network assigned to switch0

@16again No discernible change in advertised routes.

 

It is working as expected, now. I am unable to tell what exactly caused it to "misfire". For now I can only assume that the myriad of incremental configuration changes that it got subjected to put it into a state that was different to the displayed configuration.

 

The end-game left it disconnected from UNMS and uncontactable so a site visit made today to restart it and correct some minor configuration errors brought everything up.

 

I suspect the moral is to not assume that avoiding reboots is as time-saving as it first might seem!

 

Reply