Emerging Member
Posts: 61
Registered: ‎09-15-2016
Kudos: 6

ER-X Unresponsive

[ Edited ]

Has anyone experienced an issue where their ER-X becomes unresponsive and needs a power cycle to resume normal operations? I have been using this device in question for many months without a problem until now.

 

The lights on the device were flashing like there was activity taking place but no device attached to the ER-X was available and the ER-X device itself could not be reached using the SSH or HTTPS protocols.

Emerging Member
Posts: 71
Registered: ‎05-24-2014
Kudos: 35
Solutions: 2

Re: ER-X Unresponsive

No, all ER-X work still fine.

Which firmware version is installed on your er-x?
Emerging Member
Posts: 42
Registered: ‎09-10-2017
Kudos: 7

Re: ER-X Unresponsive

Yes I have this issue. In my case it is related to IPSec Offloading.

Emerging Member
Posts: 61
Registered: ‎09-15-2016
Kudos: 6

Re: ER-X Unresponsive

v1.10.1

 

The strange thing is that the ER-X has been running for some time without any problems and then all of a sudden it becomes unresponsive. I am unable to establish an SSH or HTTPS session or connect to any of the devices attached to the ER-X. Only a power cycle seems to resolve the problem.

Emerging Member
Posts: 61
Registered: ‎09-15-2016
Kudos: 6

Re: ER-X Unresponsive

Is there a specific log that you looked at to identify the source of the problem?

Emerging Member
Posts: 71
Registered: ‎05-24-2014
Kudos: 35
Solutions: 2

Re: ER-X Unresponsive

[ Edited ]

There is one report regarding system hangups but only with firmware 1.10.3 (if I rememeber correctly). I was unable to reproduce that behaviour, all er-x are configured to use IPSec offloading. But let's go that route…

Did you activate IPSec offloading on the er-x? System->offload->IPsec in config tree.
If yes, try to deactivate it and watch what happens.

I'm not aware of any way to dump a log when the router crashed. All logos are removed on reboot. The serial console would give some details, but there is none (accessible) on an er-x.

Besides the IPSec offloading… Did you change something? Did you add some scripts that might fill up log files? If the er-x runs out of storage memory it tends to hangup and reboot.

New Member
Posts: 5
Registered: ‎05-15-2018
Kudos: 1

Re: ER-X Unresponsive

I'm seeing something similar with hwnat enabled. Have not tried further troubleshooting or fw upgrade.

Emerging Member
Posts: 42
Registered: ‎09-10-2017
Kudos: 7

Re: ER-X Unresponsive

[ Edited ]

Yea well if I turn off IPSec offloading the router won't crash. (It ran about 6 weeks fine)

 

But after IPSec offloading turned out the router will crash after a few hours. If I add Smart Queue, I can expect it to crash within a few minutes after putting load on the tunnel.

 

I got my ER-4 yesterday and it runs fine so far. (offload enabled)

Emerging Member
Posts: 61
Registered: ‎09-15-2016
Kudos: 6

Re: ER-X Unresponsive

Thanks for your input. IPSec offloading is not enabled and no Smart Queue settings have been configured. The ER-X itself has been runing since 1.10.1 was released without any changes to the configuration so it seems strange that the device would become unresponsive for no reason. 

Emerging Member
Posts: 61
Registered: ‎09-15-2016
Kudos: 6

Re: ER-X Unresponsive

Thanks for your feedback. hwnat has been enabled for over a year and only now have I experienced a unresponsive device. The device configuration itself has been largely unchanged since the installation of fw1.10.1 so I am oncerned that the device would become unresponsive for no reason. As the device is in a remote location it need to "just work" without exception. My assumption was that the EdgeRouter were good for this type of work but maybe I am mistaken. 

Emerging Member
Posts: 61
Registered: ‎09-15-2016
Kudos: 6

Re: ER-X Unresponsive

Thansk for your help. I see no mention of any additional logs or reporting in the changelog for fw1.10.3. IPSec offloading has never been enabled (hwnat has been enabled for over 1 year without a previous problem).  Additionally, the existing configuration has been inplace for some time and the only thing that has really happened to the device over the past few months are firmware upgrades. 

Emerging Member
Posts: 71
Registered: ‎05-24-2014
Kudos: 35
Solutions: 2

Re: ER-X Unresponsive

I would give disabling hwnat offloading a try and see of that changes anything.
There are some rare reports of ER-X hardware fails, but as always with technical devices… Some may fail.
Can you rule out any environmental or technical change at the remote site? Power supply failing? Intermitting outages?
Highlighted
Emerging Member
Posts: 61
Registered: ‎09-15-2016
Kudos: 6

Re: ER-X Unresponsive

The remote site is climate controlled and solar powered and I am able to confirm that there was no loss of power at the site. I am reluctant to turn off hwnat as that has been enabled for over 1 year without a problem but will give it a try if I encounter the problem again. Thanks again.