Scheduled maintenance: Community will be offline Monday June 17th, 1:00 AM - 6:00 AM (PT)
Highlighted
New Member
Posts: 3
Registered: ‎04-12-2018
Solutions: 1
Accepted Solution

ERLite-3 Failover with VLAN (Watchdog settings)

[ Edited ]

Hi,

 

I searched for the forum and could find a couple of similar cases but the solution does not solve my problem.

Excuse my bad skills... Man Happy

 

Easy setup, EdgeRouter ERLite-3 with Firmware v2.0.1.

eth0 = main WAN eth1 = secondary WAN (failover only) eth2 = Uplink LAN (UniFi 8p PoE)

Factory reset -> Wizard -> Load Balancing -> eth0, dhcp, enable the default firewall. eth1, dhcp, enable the default firewall, failover only. eth2 192.168.0.1/255.255.255.0, enable dhcp server. Reboot -> adding vlan 30 on eth2 (eth2.30) 192.168.30.1/24 -> adding dhcp server on the 192.168.30.0/24 net. Reboot.

 

So far so good, my main 192.168.0.0/24 are working fine, all wan traffic goes ut on main eth0 but my 192.168.30.0/25 vlan30 clients traffic are jumping from eth0 and eth1, load-balance watchdog says weight=100% on eth0. After some forum searching this command solved my problem.

 

configure

set interfaces ethernet eth2 vif 30 firewall in modify balance

commit

save

 

Now both 192.168.0.0/24 and vlan30 192.168.30.0/24 are going out on eth0 and i can see ALL the data are going out on eth0. And all my clients gets my eth0 external IP if the go to whatsmyip.com. Fine! I have a old Synology NAS with DYNDNS activated so every time my external IP changes i get a mail.

 

This setup has been running for 4 days, and randomly 2-3 times per day the router do a failover from eth0 to eth1 for exactly 3 minutes then back... And i am sure that there is NO downtime on eth0, i have a old ER-X (v1.9.7+hotfix.4) with same failover config but without VLAN working fine, no mysteric failover (on same cables week before and one week after).

 

Anyone? Man Happy

 

/Andy

 

 

 

 

 


Accepted Solutions
Veteran Member
Posts: 6,446
Registered: ‎01-04-2017
Kudos: 948
Solutions: 330

Re: ERLite-3 Failover with VLAN problem.

change the host your pinging.

View solution in original post

New Member
Posts: 3
Registered: ‎04-12-2018
Solutions: 1

Re: ERLite-3 Failover with VLAN problem.

Change the ping adress to 8.8.8.8 and modify the counts failure to 6, it takes som longer for the watchdog to fail over but the the 1 second failover and back are gone Man Happy

 

 

eth0 (100/100 incoming WAN)

route-test / count : load-balance counts failure: 6

                                                      seccess: 3

 

route-test / type / ping : Ping options target: 8.8.8.8

 

eth1 (failover only incoming 3G  Backup WAN)

route-test / count : load-balance counts failure: 6

                                                      seccess: 3

 

route-test / type / ping : Ping options target: 8.8.8.8

 

Thanks!

 

/Andy

 

 

View solution in original post


All Replies
Veteran Member
Posts: 6,446
Registered: ‎01-04-2017
Kudos: 948
Solutions: 330

Re: ERLite-3 Failover with VLAN problem.

change the host your pinging.
New Member
Posts: 3
Registered: ‎04-12-2018
Solutions: 1

Re: ERLite-3 Failover with VLAN problem.

Well its the same om both routers..

New Member
Posts: 3
Registered: ‎04-12-2018
Solutions: 1

Re: ERLite-3 Failover with VLAN problem.

Change the ping adress to 8.8.8.8 and modify the counts failure to 6, it takes som longer for the watchdog to fail over but the the 1 second failover and back are gone Man Happy

 

 

eth0 (100/100 incoming WAN)

route-test / count : load-balance counts failure: 6

                                                      seccess: 3

 

route-test / type / ping : Ping options target: 8.8.8.8

 

eth1 (failover only incoming 3G  Backup WAN)

route-test / count : load-balance counts failure: 6

                                                      seccess: 3

 

route-test / type / ping : Ping options target: 8.8.8.8

 

Thanks!

 

/Andy