Reply
Highlighted
New Member
Posts: 13
Registered: ‎09-15-2017
Kudos: 1
Solutions: 1
Accepted Solution

Edge Router X SPF - No Internet

Hi guys, 

 

Having heard so many good things about the EdgeRouter, I decided to invest my money on the X SPF model. Unfortunately, I am having issues getting the thing to work (or maybe I am the problem) Here is the situation:

 

- Deployment: ISP modem (port1) -> EdgeRouter (eth0) -> client (eth1-4)

- ISP: modem is configured in bridgemode

- EdgeRouter: router is running latest firmware 1.9... 

- Client: running Windows 10 and getting ip via DHCP e.g. 192.168.1.38

 

I used the "Wizard" guide when setting up the router and can see that I am getting the correct WAN ip from ISP on eth0. I can also ping whatever on the Internet from router and/or clients, but I cannot reach any website e.g. no Internet... I am thinking DNS, but I have tried changing those from my ISP ones to google, OpenDNS + more without any luck. 

 

(obs: I have already talked to my ISP and they managed to "whitelist" my EdgeRouter MAC e.g. which seems to work as I am getting the correct WAN ip.

 

What in the hell am I doing wrong here?!

 

/RB


Accepted Solutions
Established Member
Posts: 1,757
Registered: ‎04-21-2015
Kudos: 255
Solutions: 84

Re: Edge Router X SPF - No Internet

[ Edited ]

Yeah.. Clearly no 3-way handshake. You send SYN packets but never receive SYN,ACK. You need to check your modem. Something is not right there 

Thanks,
Myky
--------------------------------------------------------------------------------------------------------------------------------------------------
Don`t blame the device as it`s always doing what you have asked it to do, this is not always the same as what you want.

View solution in original post


All Replies
Established Member
Posts: 1,757
Registered: ‎04-21-2015
Kudos: 255
Solutions: 84

Re: Edge Router X SPF - No Internet

from router:

1) ping 8.8.8.8 - results
2) ping cisco.com - results
2) check the NAT config on the EdgeMAX
Thanks,
Myky
--------------------------------------------------------------------------------------------------------------------------------------------------
Don`t blame the device as it`s always doing what you have asked it to do, this is not always the same as what you want.
Veteran Member
Posts: 6,602
Registered: ‎03-24-2016
Kudos: 1721
Solutions: 758

Re: Edge Router X SPF - No Internet

Ping by name to see if DNS lookup works.

If it does, next suspect might be mss-clamp settings

New Member
Posts: 13
Registered: ‎09-15-2017
Kudos: 1
Solutions: 1

Re: Edge Router X SPF - No Internet

[ Edited ]

Alright, from the EdgeRouter pinging 8.8.8.8 and cisco.com works. The NAT configuration shows a "masquerade" to eth0 (see attachment)

 

@16again  mss-clamp settings?

 

This is my config:

 

interfaces {
ethernet eth0 {
address dhcp
description Internet
duplex auto
speed auto
}
ethernet eth1 {
description Local
duplex auto
speed auto
}
ethernet eth2 {
description Local
duplex auto
speed auto
}
ethernet eth3 {
description Local
duplex auto
speed auto
}
ethernet eth4 {
description Local
duplex auto
speed auto
}
ethernet eth5 {
duplex auto
speed auto
}
loopback lo {
}
switch switch0 {
address 192.168.1.1/24
description Local
switch-port {
interface eth1 {
}
interface eth2 {
}
interface eth3 {
}
interface eth4 {
}
}
}
}
service {
dhcp-server {
disabled false
hostfile-update disable
shared-network-name LAN {
authoritative enable
subnet 192.168.1.0/24 {
default-router 192.168.1.1
dns-server 192.168.1.1
lease 86400
start 192.168.1.38 {
stop 192.168.1.243
}
}
}
}
dns {
forwarding {
cache-size 150
listen-on switch0
}
}
gui {
https-port 443
}
nat {
rule 5010 {
description "masquerade for WAN"
outbound-interface eth0
type masquerade
}
}
ssh {
port 22
protocol-version v2
}
}
system {
host-name ubnt
login {
user ubnt {
authentication {
encrypted-password ****************
}
level admin
}
}
ntp {
server 0.ubnt.pool.ntp.org {
}
server 1.ubnt.pool.ntp.org {
}
server 2.ubnt.pool.ntp.org {
}
server 3.ubnt.pool.ntp.org {
}
}
syslog {
global {
facility all {
level notice
}
facility protocols {
level debug
}
}
}
time-zone UTC
}

 

 

Capture.PNG
New Member
Posts: 13
Registered: ‎09-15-2017
Kudos: 1
Solutions: 1

Re: Edge Router X SPF - No Internet

Oh, and my DNS tab on the EdgeRouter shows:

Capture1.PNG
Member
Posts: 123
Registered: ‎05-11-2014
Kudos: 135
Solutions: 1

Re: Edge Router X SPF - No Internet

what's your Wan ip and netmask ?
Veteran Member
Posts: 6,602
Registered: ‎03-24-2016
Kudos: 1721
Solutions: 758

Re: Edge Router X SPF - No Internet

These commands set mss-clamp:

configure
set firewall options mss-clamp interface-type all
set firewall options mss-clamp mss 1452
commit
save
exit
New Member
Posts: 13
Registered: ‎09-15-2017
Kudos: 1
Solutions: 1

Re: Edge Router X SPF - No Internet

[ Edited ]

Changing the mss-clamp and a reboot did not do anything unfortunately Man Sad

 

 

Established Member
Posts: 1,757
Registered: ‎04-21-2015
Kudos: 255
Solutions: 84

Re: Edge Router X SPF - No Internet

[ Edited ]

sudo ping -I 192.168.1.1 8.8.8.8
sudo ping -I 192.168.1.1 cisco.com

Post the output of the above commands, please

Thanks,
Myky
--------------------------------------------------------------------------------------------------------------------------------------------------
Don`t blame the device as it`s always doing what you have asked it to do, this is not always the same as what you want.
New Member
Posts: 13
Registered: ‎09-15-2017
Kudos: 1
Solutions: 1

Re: Edge Router X SPF - No Internet

[ Edited ]

What is the default mss-clamp setting here? (just to revert back)

New Member
Posts: 13
Registered: ‎09-15-2017
Kudos: 1
Solutions: 1

Re: Edge Router X SPF - No Internet

Output from both commands:

 

 

Capture1.PNG
Capture2.PNG
Veteran Member
Posts: 6,602
Registered: ‎03-24-2016
Kudos: 1721
Solutions: 758

Re: Edge Router X SPF - No Internet

Try a http download on ER itself:

 

 cd /tmp
curl -O https://help.ubnt.com/hc/en-us/article_attachments/202758584/network_diagram.png

It should download an 100kB image

 

Could this be a ISP issue?   Some block connections partially when they detect malware being present on your machines.   (but they should redirect you to a page giving a clue what's going on. At least mine does)

Established Member
Posts: 1,757
Registered: ‎04-21-2015
Kudos: 255
Solutions: 84

Re: Edge Router X SPF - No Internet

This is a miracle  Smiley Happy

 

Ok can you please connect Win10, open CMD and post the following:

 

ipconfig

 

ping cisco.com 

 

Open the web browser, try to surf the Internet. What error do you get? Can you get  PCAP of the session, please

 

Thanks,
Myky
--------------------------------------------------------------------------------------------------------------------------------------------------
Don`t blame the device as it`s always doing what you have asked it to do, this is not always the same as what you want.
New Member
Posts: 13
Registered: ‎09-15-2017
Kudos: 1
Solutions: 1

Re: Edge Router X SPF - No Internet

Well, that did not work... 

Capture3.PNG
New Member
Posts: 13
Registered: ‎09-15-2017
Kudos: 1
Solutions: 1

Re: Edge Router X SPF - No Internet

Done - no issues Man Happy

 

 

Capture1.PNG
Capture2.PNG
Veteran Member
Posts: 6,602
Registered: ‎03-24-2016
Kudos: 1721
Solutions: 758

Re: Edge Router X SPF - No Internet

[ Edited ]

Then lets make a dump to see what's going on:

ssh session 1 to ER:

 

sudo tcpdump -I <WAN-INTERFACE> -s 0 -w /tmp/port80.pcap  tcp port 80

==>Edit:

Or even better, capture all WAN traffic:

sudo tcpdump -I <WAN-INTERFACE> -s 0 -w /tmp/dump.pcap

 

On 2nd session, do same curl command as in previous post, give it some seconds.

 

Get back to session1 hit CTRL-C , copy the file to your machine and post it

Member
Posts: 123
Registered: ‎05-11-2014
Kudos: 135
Solutions: 1

Re: Edge Router X SPF - No Internet

[ Edited ]

whats your WAN ip address and subnet mask ? just type the first digits of the ip anyway for privacy e.g. 81.45.66.XX and mask 255.255.255.252

New Member
Posts: 13
Registered: ‎09-15-2017
Kudos: 1
Solutions: 1

Re: Edge Router X SPF - No Internet

Here is the out in pcap... hope you can get something out of it.

New Member
Posts: 13
Registered: ‎09-15-2017
Kudos: 1
Solutions: 1

Re: Edge Router X SPF - No Internet

I guess you can see it in the pcap file Man Wink

 

 

Established Member
Posts: 1,757
Registered: ‎04-21-2015
Kudos: 255
Solutions: 84

Re: Edge Router X SPF - No Internet

[ Edited ]

Yeah.. Clearly no 3-way handshake. You send SYN packets but never receive SYN,ACK. You need to check your modem. Something is not right there 

Thanks,
Myky
--------------------------------------------------------------------------------------------------------------------------------------------------
Don`t blame the device as it`s always doing what you have asked it to do, this is not always the same as what you want.
Reply