Reply
Ubiquiti Employee
Posts: 1,067
Registered: ‎07-20-2015
Kudos: 1087
Solutions: 73

Re: EdgeMAX EdgeRouter software version v1.10.1 has been released!

@tbyehl
> The patch for load-balance isn't working for me. I can fail over but it doesn't want to fail back.
Please show output of following shell commnads when LB does not fail back:

  1. show load-balance status
  2. show load-balance watchdog
  3. ip route
  4. ip route show table 201
  5. ip route show table 202
  6. show interfaces
  7. show configuration commands |grep load-balance

 

Emerging Member
Posts: 70
Registered: ‎05-14-2016
Kudos: 105
Solutions: 2

Re: EdgeMAX EdgeRouter software version v1.10.1 has been released!

Well. I don't know what was messing up when I was trying this yesterday, but this morning I flipped back to v1.10.1, put the patch back in place, rebooted, and restarted my primary WAN modem a bunch of times and it failed back to primary properly every time.

 

I'll leave it on v1.10.1 and let it soak a while.

New Member
Posts: 8
Registered: ‎02-28-2016
Solutions: 1

Re: EdgeMAX EdgeRouter software version v1.10.1 has been released!

Same thing here. I'm not sure what the deal was with the first reboot after the patch.  But, I had powered it off and went back to my former setup for the week (ERPoE-5 with 1.9.7 hotfix 4), and when I put the ER-X back in place today to do some mroe testing it was working fine from the start.

 

Odd, but I'll go ahead and keep running for a bit and report back with any additional findings.

 

Thanks for the patch!

New Member
Posts: 22
Registered: ‎08-30-2016
Kudos: 2

Re: EdgeMAX EdgeRouter software version v1.10.1 has been released!

Does anyone has problems with dhcp , after upgrade ? I updated today and two of my devices aren't getting an ip address, because I was running out of time I had to switch back to 1.9.4 .

Ubiquiti Employee
Posts: 1,067
Registered: ‎07-20-2015
Kudos: 1087
Solutions: 73

Re: EdgeMAX EdgeRouter software version v1.10.1 has been released!

@sharky1337
> I updated today and two of my devices aren't getting an ip address

Could you please reproduce this issue again and provide following data:

  1. Show your interface+DHCPconfiguration:
    show configuration commands|grep interface
  2. Please check if dhclient is running:
    ps ax|grep [d]hclient
  3. Please show dhclient logs:
    cat /var/log/messages|grep dhclient"
Emerging Member
Posts: 55
Registered: ‎06-06-2016
Kudos: 8
Solutions: 2

Re: EdgeMAX EdgeRouter software version v1.10.1 has been released!

come on guys..we are wating for 1.10.2

Emerging Member
Posts: 92
Registered: ‎09-03-2016
Kudos: 2
Solutions: 1

Re: EdgeMAX EdgeRouter software version v1.10.1 has been released!

Why, what is 1.10.1 not doing for you?

New Member
Posts: 31
Registered: ‎05-25-2017
Kudos: 2

Re: EdgeMAX EdgeRouter software version v1.10.1 has been released!

For a lot of people it is simply not stable enough. I for one am not planning to update from 1.9.7+4 until most of the bugs have been fixed and more positive news around the stability on 1.10 surfaces. 

Established Member
Posts: 2,474
Registered: ‎08-06-2015
Kudos: 1016
Solutions: 150

Re: EdgeMAX EdgeRouter software version v1.10.1 has been released!


@dennisvo wrote:

For a lot of people it is simply not stable enough. I for one am not planning to update from 1.9.7+4 until most of the bugs have been fixed and more positive news around the stability on 1.10 surfaces. 


1.10.1 actually addresses stability issues present in 1.9.7.

 

It might be helpful to know specifically which outstanding issues with 1.10.x are keeping you from moving forward.  If the actual issues are not identified then any prioritization for remediation would be at the assumptions on the part of UBNT.  IOW:  Without specific feedback vendors would prioritize development based on what they feel is most important which may not be in alignment with your needs.

 

It is normal for posters to only note when there are issues so it is easy to read through a forum and assume that a given release/version is horribly buggy when it may not be.

 

Emerging Member
Posts: 68
Registered: ‎08-08-2014
Kudos: 14
Solutions: 3

Re: EdgeMAX EdgeRouter software version v1.10.1 has been released!

Just want to point out that I upgraded, saw the issues with WLB (which seem to be related to default routes not being added into the 201 and 202 route tables), applied the patch, and we seem to be in business.

 

I'll of course wait until 1.10.2 to start rolling out, but everything else seems to be working just fine!

Emerging Member
Posts: 91
Registered: ‎03-24-2014
Kudos: 14
Solutions: 3

Re: EdgeMAX EdgeRouter software version v1.10.1 has been released!

I'm also finding dhcpd is unrelaible in 1.10.1 on ER-4. I've had to restart the dhcpd service more times in a month than I have had to in 5 years of using Edgemax Routers. 

Emerging Member
Posts: 64
Registered: ‎06-25-2015
Kudos: 18
Solutions: 1

Re: EdgeMAX EdgeRouter software version v1.10.1 has been released!

DHCP servers are really unreliable on the ER-4. I have two DHCP servers set up, one for eth1 10.0.0.0/16 and the other eth2 10.1.0.0/16. Both the servers only give out 254 addresses, with a small number of ip reservations (which don't seem to reliably allocate their adddresses to the clients either).

 

Although the eth1 seems to work, the eth2 one doesn't. Aaaargh! I tried exactly the same config I had on my ER-Lite (before it went wrong this week)

 

Apart from the DHCP, the router is blindingly fast.

Emerging Member
Posts: 64
Registered: ‎06-25-2015
Kudos: 18
Solutions: 1

Re: EdgeMAX EdgeRouter software version v1.10.1 has been released!

Just following up, my log has the following interesting lines:

 

 
Apr 21 00:33:16 router dhcpd:                                                     
Apr 21 00:33:16 router dhcpd: No subnet declaration for eth0 (<My Public IP Address>).      
Apr 21 00:33:16 router dhcpd: ** Ignoring requests on eth0.  If this is not what  
Apr 21 00:33:16 router dhcpd:    you want, please write a subnet declaration      
Apr 21 00:33:16 router dhcpd:    in your dhcpd.conf file for the network segment  
Apr 21 00:33:16 router dhcpd:    to which interface eth0 is attached. **          
Apr 21 00:33:16 router dhcpd:                                                     
Apr 21 00:33:16 router dhcpd:                                                     
Apr 21 00:33:16 router dhcpd: No subnet declaration for eth2 (10.1.0.1).          
Apr 21 00:33:16 router dhcpd: ** Ignoring requests on eth2.  If this is not what  
Apr 21 00:33:16 router dhcpd:    you want, please write a subnet declaration      
Apr 21 00:33:16 router dhcpd:    in your dhcpd.conf file for the network segment  
Apr 21 00:33:16 router dhcpd:    to which interface eth2 is attached. **          
Apr 21 00:33:16 router dhcpd:                                                  
 

 So here's the interesting thing - I don't see a similar entry for the dhcp server on eth1, which appears to be working (better at least). To be clear, eth2 has a subnet of 10.1.0.0/16 and assigns ip addresses between 10.1.0.2-10.1.0.254. The subnet for eth2 is visible both through the web gui and the console.

 

The config for the eth2 dhcp server is similar to that for eth1 - the only differences are the subnet, the ranges, the router and the dns servers.

 

What's going wrong? It's like the eth2 dhcp-server isn't working at all.

Emerging Member
Posts: 64
Registered: ‎06-25-2015
Kudos: 18
Solutions: 1

Re: EdgeMAX EdgeRouter software version v1.10.1 has been released!

So narrowed it down further - the problem exists in both 1.9.8 and 1.10.1 - only DHCP doesn't work at all with 2 DHCP servers in 1.9.8! So went back to 1.10.1 - DHCP wasn't working at all. Disabled the DHCP server on eth2 and the eth1 DHCP server started to work properly.

So there's a problem that manifests itself with 2+ DHCP servers.
New Member
Posts: 14
Registered: ‎03-06-2017
Solutions: 1

Re: EdgeMAX EdgeRouter software version v1.10.1 has been released!

Experiencing the same issue here with my eth2 DHCP server. Doesn't want to work whatsoever. Have done literally 10+ factory resets, and to no avail. Please let me know what info you need to capture the error.

Emerging Member
Posts: 68
Registered: ‎08-08-2014
Kudos: 14
Solutions: 3

Re: EdgeMAX EdgeRouter software version v1.10.1 has been released!

[ Edited ]

@iposner paste the config of eth2

 

Edit: and the dhcp config

Emerging Member
Posts: 91
Registered: ‎03-24-2014
Kudos: 14
Solutions: 3

Re: EdgeMAX EdgeRouter software version v1.10.1 has been released!

You know you don't have to cat when using grep right?

grep string /path/to/log works just fine.
Emerging Member
Posts: 64
Registered: ‎06-25-2015
Kudos: 18
Solutions: 1

Re: EdgeMAX EdgeRouter software version v1.10.1 has been released!

ethernet eth1 {
     address 10.0.0.1/16
     description Local
     duplex auto
     speed auto
 }
 ethernet eth2 {
     address 10.1.0.1/16
     description DMZ
     duplex auto
     firewall {
         in {
             name DMZ
         }
     }
     speed auto
 }
 shared-network-name DMZ {
     authoritative disable
     disable
     subnet 10.1.0.0/16 {
         default-router 10.1.0.1
         dns-server 10.1.0.1
         dns-server 8.8.8.8
         domain-name <MyDomainName.com>
         lease 86400
         start 10.1.0.2 {
             stop 10.1.0.254
         }
<A bunch of static mappings, redacted (eth2)>
     }
 }
 shared-network-name LAN {
     authoritative disable
     subnet 10.0.0.0/16 {
         default-router 10.0.0.1
         dns-server 10.0.0.1
         dns-server 8.8.8.8
         domain-name <MyDomainName.com>
         lease 86400
         start 10.0.0.2 {
             stop 10.0.0.254
         }
<A bunch more static mappings on the LAN network (eth1)
}
Emerging Member
Posts: 92
Registered: ‎09-03-2016
Kudos: 2
Solutions: 1

Re: EdgeMAX EdgeRouter software version v1.10.1 has been released!

[ Edited ]

If those are actual cut and pastes, the issue seems to be the shared-network-name fields need to be within the dhcp-server clause., e.g.:

 

service {
    dhcp-server {
        disabled false
        hostfile-update disable
        shared-network-name DMZ {
            authoritative enable
            subnet 10.1.0.0/16 {
                default-router 10.1.0.1
                dns-server 10.1.0.1
                dns-server 8.8.8.8
                domain-name <MyDomainName.com>
                lease 86400
                start 10.1.0.2 {
                    stop 10.1.0.254
                }
            }
        } 
    }    
}

 

Also, if you're running a smallish network, like a home network, there's never a good reason to not run your DHCP server in authoritative mode; leaving it at the disabled default means that when a device that had an address on another network at some point connects to yours, it may well take until the DHCP timeout time for it to ever obtain an address on the local network.

 

Enabling authoritative mode lets the DHCP client know "No, you can't get that old IP address here, I'm the only DHCP server here and I don't handle DHCP for that address range."

 

You can verify settings are being propagated properly by checking /opt/vyatta/etc/dhcpd.conf to verify what /opt/vyatta/sbin/dhcpd-config.pl generates from your settings.

 

The error message "No subnet declaration for eth2 (10.1.0.1)" seems to imply an error either in your settings or in the dhcpd-config.pl script.

 

Emerging Member
Posts: 68
Registered: ‎08-08-2014
Kudos: 14
Solutions: 3

Re: EdgeMAX EdgeRouter software version v1.10.1 has been released!

I see the shared network for eth2 is disabled? If you remove that setting, does the dhcp log still say there's no subnet defined for 10.1.0.1/16?

Reply