Emerging Member
Posts: 63
Registered: ‎02-11-2018
Kudos: 1

Re: EdgeMAX EdgeRouter software version v2.0.0 has been released!

@UBNT-afomins, "There is another reason for "Flushing cache" message - when IPv4/IPv6 route is being added/deleted then offloading cache is flushed. ... especially with dynamic routing protocols this might cause throughput degradation because of frequent routing table updates that trigger offload cache flush." I'm sure this is the reason we have here, as you know we run ospf (btw, I don't see ospf fixes for my problems in 2.0.0, but this router has no tunnels, so I decided to not run quagga here, because this is new link and I can say this is sort of test channel ) , and this is enterprise network with several hundreds (well, at least, I think so, never calculated ) of routers. Is there any way to avoid whole cache invalidation here if offload is enabled? May be it is better to just disable offload and use cpu in my case? Thank you!
New Member
Posts: 7
Registered: ‎07-17-2018
Kudos: 3

Re: EdgeMAX EdgeRouter software version v2.0.0 has been released!

[ Edited ]

@Q-Singularity wrote:

 

In your previous post you said the MTU on your SFP was 1508. It has to be 1512.

 

The VLAN tag is not part of the payload and does not need to be compensated for at layer 3.  The PPPoE header does take up payload space which is why the extra 8 bytes is needed.  The VLAN tag is between the source address and the Ethertype value which are all at layer 2.

 

I've been using 1508 MTU on my SFP base interface on both FreeBSD and the ER Infinity without issues.  On my EdgeSwitch I do add the extra 4 for the VLAN tag (as well as the all the other Ethernet fields) as it uses the layer 2 MTU value.

New Member
Posts: 4
Registered: ‎09-03-2017

Re: EdgeMAX EdgeRouter software version v2.0.0 has been released!

[ Edited ]

@UBNT-afominse50 is missing the modules.order file causing theis warning when installing kernel modules:

depmod: WARNING: could not open /lib/modules/4.14.54-UBNT/modules.order: No such file or directory

 

New Member
Posts: 21
Registered: ‎12-21-2018

Re: EdgeMAX EdgeRouter software version v2.0.0 has been released!

thanks and is there a forecast of when the next stable version will arrive? I have a line at 1GB of download and I'm having problems of bandwidth down and up. what firmware version you recommend me to restore if the stable version takes more time
New Member
Posts: 8
Registered: ‎12-13-2018
Kudos: 1
Solutions: 1

Re: EdgeMAX EdgeRouter software version v2.0.0 has been released!


@16again wrote:

@kpratte 

 

Post your config, as previous QoS snippet lacked stuff.

What output does "sudo tc monitor" generate in ssh session1 , while disabling/enabling shaper in session2?  On v2.0 and previous.


So that didn't prove all that useful, but I was able to verify several things.. 

1) The tc monitor output is almost identical between the two version with the exception that in v2.0 you'll see: limit 1000p, while in 1.10.8 you'll see: limit 1p.

2) I couldn't for the life of me get VLAN matching to work.  So off to google and found this: https://community.ubnt.com/t5/EdgeRouter/Edge-Router-VLAN-traffic-shaping-RESOLVED/td-p/742890 which basically says that the VLAN tags were removed by the time you went to inspect the packet.  There was suggestions on how to work around it and on another post I saw mention of using "match <desc> interface eth2.5" which I tried in v1.10.8 and it works great.  It does NOT work in v2.0. 

3) The "Rate" column in the output of "show queueing ethernet" is always blank in v2.0, but always has something in v1.10.8.

 

So, in summary, if I match on the interface in v1.10.8 it works, on v2.0, it does not.   I'm attaching to my WAN port with: "set interfaces ethernet eth0 traffic-policy out upload"

 

Regular Member
Posts: 340
Registered: ‎04-22-2018
Kudos: 69
Solutions: 3

Re: EdgeMAX EdgeRouter software version v2.0.0 has been released!

[ Edited ]

@tsis wrote:
thanks and is there a forecast of when the next stable version will arrive? 

Hopefully very soon........... this 2.0 has been out for 11 days now, so plenty of time to see the reoccuring posts/bugs in here and fix them. So I would assume any day now .1 will appear...

 


@tsis wrote:
 I have a line at 1GB of download and I'm having problems of bandwidth down and up. what firmware version you recommend me to restore if the stable version takes more time

1.10.8


AP AC LITE
UAP nanoHD (x2)
Edgerouter 4
Ubiquiti Employee
Posts: 1,269
Registered: ‎07-20-2015
Kudos: 1590
Solutions: 82

Re: EdgeMAX EdgeRouter software version v2.0.0 has been released!

@3bs
> On edge routerpoe-5, pppoe don't estabilish connection on eth4 interface no errors in log
> Problem appeared in betta2, exist in betta3, in release still not fixed.
I deployed your configuration on my ER-PoE and finally was able to reproduce this issue - apparently PPPoE over eth4 does not work if switch0 has switch-ports configured.
Workaround is to delete all interfaces from switch-port and then PPPoE over eth4 will start functioning. I created bug ticket to fix this regresion in next release.

 

@pokwer
> the layer2 aspect of the er-x is working with the vlan config
> however I can't access its management IP anymore
This regression will be fixed in v2.0.1

 

@sle
> There is another reason for "Flushing cache" message - when IPv4/IPv6 route is being added/deleted then offloading cache is flushed
> Is there any way to avoid whole cache invalidation here if offload is enabled?
You can disable flow-flushing with following CLI command:

set system offload ipv4 disable-flow-flushing-upon-fib-change

@tbk0000
> e50 is missing the modules.order file causing warning when installing kernel modules:
> depmod: WARNING: could not open /lib/modules/4.14.54-UBNT/modules.order: No such file or directory
I acknowledge that "modules.order" is missingon e50 platform, however I see no warnings when loading modules, for instance with "sudo modprobe tunnel6"
How did you trigger this warning mesage? Did you install 3rd party modules?

 

@tsis
> is there a forecast of when the next stable version will arrive?
We need at least 2 more weeks to address all major issues found in v2.0.0

 

Emerging Member
Posts: 68
Registered: ‎10-10-2017
Kudos: 35

Re: EdgeMAX EdgeRouter software version v2.0.0 has been released!

@UBNT-afomins

Please take your time and don't release another half baked version.
Emerging Member
Posts: 82
Registered: ‎08-08-2017
Kudos: 12
Solutions: 1

Re: EdgeMAX EdgeRouter software version v2.0.0 has been released!

[ Edited ]

The issues with IPv6 RAs, and no IPv6 addresses on network devices, @UBNT-sandisn fixed the issue with radvd.  He provided a new version of radvd (https://community.ubnt.com/t5/EdgeRouter-Beta/EdgeMAX-EdgeRouter-firmware-version-v2-0-0-beta-2-has-...) that can used to replace the original radvd version (in usr/sbin).

 

I guess the fix will be incorporated in the next 2.0 release.

 

Thank you @UBNT-sandisn

Regular Member
Posts: 340
Registered: ‎04-22-2018
Kudos: 69
Solutions: 3

Re: EdgeMAX EdgeRouter software version v2.0.0 has been released!


@mxmartins wrote:

The issues with IPv6 RAs, and no IPv6 addresses on network devices, @UBNT-sandisn fixed the issue with radvd.  He provided a new version of radvd (https://community.ubnt.com/t5/EdgeRouter-Beta/EdgeMAX-EdgeRouter-firmware-version-v2-0-0-beta-2-has-...) that can used to replace the original radvd version (in usr/sbin).

 

I guess the fix will be incorporated in the next 2.0 release.

 

Thank you @UBNT-sandisn



@mxmartins wrote:

The issues with IPv6 RAs, and no IPv6 addresses on network devices, @UBNT-sandisn fixed the issue with radvd.  He provided a new version of radvd (https://community.ubnt.com/t5/EdgeRouter-Beta/EdgeMAX-EdgeRouter-firmware-version-v2-0-0-beta-2-has-...) that can used to replace the original radvd version (in usr/sbin).

 

I guess the fix will be incorporated in the next 2.0 release.

 

Thank you @UBNT-sandisn


I thought IPV6 was working on 2.0 (except for the ERX models)...?


AP AC LITE
UAP nanoHD (x2)
Edgerouter 4
Emerging Member
Posts: 74
Registered: ‎04-14-2017
Kudos: 35
Solutions: 1

Re: EdgeMAX EdgeRouter software version v2.0.0 has been released!

I guess it depends on what you needed IPv6 to do.

New Member
Posts: 20
Registered: ‎04-28-2018
Kudos: 2

Re: EdgeMAX EdgeRouter software version v2.0.0 has been released!

 

 


I thought IPV6 was working on 2.0 (except for the ERX models)...?


 

IPV6 is working as expected on my ERX.  Better than it did on 1.10.8

New Member
Posts: 20
Registered: ‎04-28-2018
Kudos: 2

Re: EdgeMAX EdgeRouter software version v2.0.0 has been released!

[ Edited ]

Ok following from my earlier post - my config.boot had a 'Saved Failed' again when making a change from the Web Gui, this time when deleting a VLAN. I'll be making my changes on using the CLI for the moment.

 

Edit: Just further to this.

 

The problem could be caused the WebGui not correctly loading the config.boot

 

For example compare the following configuration node in the Web Gui and CLI, the WebGui is missing the config-file node

 

Capture.PNG

ciedema@erx# show interfaces openvpn vtun0
 config-file /config/server.opvn
 description "Tunnel To Azure"
[edit]

 

Logging in and out of the ERX WebGui now shows the correct information.

 

Capture.PNG

 

The steps to get this result were:

 

Open the WebGui

ssh to the router

change the config with the CLI, commit and save.

Refreshing the WebGui as per the Configuration Changed Dialog.

Inspect the Changed node.

Emerging Member
Posts: 47
Registered: ‎10-16-2018
Kudos: 20
Solutions: 1

Re: EdgeMAX EdgeRouter software version v2.0.0 has been released!

Not sure if anything like this has happened. ERX-SFP with eth5 as WAN and all other eth ports under switch0. RaspberryPI attached to eth2 is assigned a static IP, no issues 1.10.8. Version 2.0.0 today refused to assign the RPi an IP address upon a reboot of the device. Deleting the static IP assignment also did not help. The device was refused an address even via DHCP. A roll back to 1.10.8 fixed the issue immediately.

New Member
Posts: 8
Registered: ‎08-06-2017
Kudos: 13

Re: EdgeMAX EdgeRouter software version v2.0.0 has been released!

Can you tell me why this firmware is not listed on the support download page? And additionally is there an ETA for 2.0.1? I suffer for broken hwnat on ER-X for a long time now, my devices are serving both l2tp/IPsec and s2s IPsec vpn

Regular Member
Posts: 340
Registered: ‎04-22-2018
Kudos: 69
Solutions: 3

Re: EdgeMAX EdgeRouter software version v2.0.0 has been released!

[ Edited ]

@bartaspoz wrote:

Can you tell me why this firmware is not listed on the support download page? And additionally is there an ETA for 2.0.1? I suffer for broken hwnat on ER-X for a long time now, my devices are serving both l2tp/IPsec and s2s IPsec vpn


 

I would strongly suggest you spend some time reading this entrie thread. These questions have been answered, only 1 page back. A lot of good info on the FW, and why not to upgrade to it right now.

 

Maybe start here?

 

https://community.ubnt.com/t5/EdgeRouter/EdgeMAX-EdgeRouter-software-version-v2-0-0-has-been-release...


AP AC LITE
UAP nanoHD (x2)
Edgerouter 4
New Member
Posts: 30
Registered: ‎08-01-2018
Kudos: 19

Re: EdgeMAX EdgeRouter software version v2.0.0 has been released!

What is the advantage of upgrading to 2.0 (from 1.10.7) for a home user like myself ( ER4, a few VLANS, basic Firewall protection)?
Security updates? Overall improvement in router performance? Better interface? Quicker WLAN speeds? Why is Debian distribution Stretch better than Wheezy?
New Member
Posts: 32
Registered: ‎03-29-2016
Kudos: 2

Re: EdgeMAX EdgeRouter software version v2.0.0 has been released!

[ Edited ]

@jbo55

Why is Debian distribution Stretch better than Wheezy?

 

Look here: https://wiki.debian.org/LTS

New Member
Posts: 4
Registered: ‎09-03-2017

Re: EdgeMAX EdgeRouter software version v2.0.0 has been released!

[ Edited ]

Generally because newer distro releases is = to newer software and that is especially true in Debians case.

Lots of software makers silently pushes fixes for security issues, that is why it is best practice to use the latest stable release of any software.

Highlighted
Deleted Account
Posts: 0

Re: EdgeMAX EdgeRouter software version v2.0.0 has been released!


@UBNT-afomins wrote:

 


@tbk0000
> e50 is missing the modules.order file causing warning when installing kernel modules:
> depmod: WARNING: could not open /lib/modules/4.14.54-UBNT/modules.order: No such file or directory
I acknowledge that "modules.order" is missingon e50 platform, however I see no warnings when loading modules, for instance with "sudo modprobe tunnel6"
How did you trigger this warning mesage? Did you install 3rd party modules?


It happens when installing Wireguard for Edgerouter X on firmware version 2.0.0.

 

https://github.com/Lochnair/vyatta-wireguard