Member
Posts: 249
Registered: ‎04-06-2014
Kudos: 198
Solutions: 24

EdgeMAX - TX errors on hurricane electric IPv6 tunnel

I keep getting TX errors on my IPv6 tunnel. But I don't have any errors on any of the other interfaces.

me@ubnt:~$ show interfaces tunnel tun0
tun0: <POINTOPOINT,NOARP,UP,LOWER_UP> mtu 1480 qdisc noqueue state UNKNOWN 
    link/sit 0.0.0.0 peer 216.x.x.x
    inet6 2001:x:7:x::2/64 scope global 
       valid_lft forever preferred_lft forever
    inet6 fe80::a00:201/64 scope link 
       valid_lft forever preferred_lft forever
    inet6 fe80::ad45:b83d/64 scope link 
       valid_lft forever preferred_lft forever
    inet6 fe80::a00:101/64 scope link 
       valid_lft forever preferred_lft forever
    Last clear: Mon Jun 16 21:00:02 EDT 2014
    Description: HE.NET IPv6 Tunnel

    RX:  bytes    packets     errors    dropped    overrun      mcast
     126423644     131702          0          0          0          0
    TX:  bytes    packets     errors    dropped    carrier collisions
      21187262     108569         15          0          0          0
me@ubnt:~$ 

 

Here are the relevant parts of my config:

 tunnel tun0 {
        address 2001:x:7:x::2/64
        description "HE.NET IPv6 Tunnel"
        encapsulation sit
        firewall {
            in {
                ipv6-name ipv6_wan_in
            }
            local {
                ipv6-name ipv6_wan_local
            }
        }
        local-ip 0.0.0.0
        mtu 1480
        multicast disable
        remote-ip 216.x.x.x
        ttl 255

 

interfaces {
    ethernet eth0 {
        address 192.168.1.1/24
        address 2001:x:8:x::1/64
        description Local
        duplex auto
        firewall {
            in {
            }
        }
        ipv6 {
            dup-addr-detect-transmits 1
            router-advert {
                cur-hop-limit 64
                link-mtu 0
                managed-flag false
                max-interval 600
                other-config-flag false
                prefix 2001:x:8:x::/64 {
                    autonomous-flag true
                    on-link-flag true
                    valid-lifetime 2592000
                }
                radvd-options "RDNSS 2001:x:8:x::1 { };"
                reachable-time 0
                retrans-timer 0
                send-advert true
            }
        }
        speed auto
    }

I've verified that both ends of the tunnel have an MTU of 1480. My LAN and WAN interfaces both have an MTU of 1500.

Could this be an MTU issue?

Previous Employee
Posts: 13,551
Registered: ‎06-10-2011
Kudos: 5480
Solutions: 1656
Contributions: 2

Re: EdgeMAX - TX errors on hurricane electric IPv6 tunnel

Do you see anything suspicious in the log?

Member
Posts: 249
Registered: ‎04-06-2014
Kudos: 198
Solutions: 24

Re: EdgeMAX - TX errors on hurricane electric IPv6 tunnel

[ Edited ]

@UBNT-ancheng wrote:

Do you see anything suspicious in the log?


no, not that I can see