Posts: 130
Registered: ‎03-19-2015
Kudos: 34
Solutions: 3

Re: EdgeMax rescue kit (now you can reinstall EdgeOS from scratch)


The configuration for the boot cmd is stored in another partition, it is not affected by the bootloader upgrade.

New Member
Posts: 3
Registered: ‎11-27-2015
Kudos: 1

Re: EdgeMax rescue kit (now you can reinstall EdgeOS from scratch)

@BranoB wrote:

For those who have problems with the EMRK script, here are ERLite-3 and ERPoe-5 dd images I've created from default un-modified firmware. Images are from 2GB USB stick, so you may want to re-size the 2nd partition for bigger sticks after the install.


md5sum 635838d09e78e13810bafc06f818d7d9 71MB

md5sum 44cc11a37d43354bfec9e8b519072ae9 79MB

md5sum 5081fbb391e5c3c77994ea3345184bf1 81MB

md5sum d57ad1fe4504002d831cf835318127ad 81MB


Hi - I just wanted to add my thanks here & confirm for other that these images work perfectly.


I used the 1.9.0 image and wrote it to a Lexar "LJDV10-8GB-000-110" 8GB flash drive (which I had to crack out of its plastic shell so it'd fit) and it boots great.


I'd previously tried another image (filename "EdgeOS 4GB") that I found on one of these forums and that didn't work at all.


My ERL lives again! Man Very Happy

Posts: 136
Registered: ‎02-11-2014
Kudos: 480
Solutions: 8

Re: EdgeMax rescue kit (now you can reinstall EdgeOS from scratch)

After reading reports that some people believe the AC adapter to be the cause of the ERLite faults, I decided to look closely at the USB flash drive in mine. I've detailed the investigation I did here. In my case I found that the flash drive passed all tests, so I've put it back into service with a new AC adapter. I'll be interested to see if it has further issues, but I have some small flash drives on order that I'll set aside as backups just in case.

New Member
Posts: 44
Registered: ‎02-23-2016
Kudos: 2

Re: EdgeMax rescue kit (now you can reinstall EdgeOS from scratch)

The details in the OP got me up and running again.

I have no idea what went wrong.

I'm on the original internal flash drive, i've not checked it's integrity, but will do if it happens again.


I run my unit on off grid directly on the 12v system, so it sees voltages from 11.1 to 13.8, this should be a non issue for a modern switch mode powersupply.


I fo have my unit grounded with the provided tag, i might ordinarily be too lazy to but it happens to be near my electronics work bench which has points for earthing.


Hopefully i won't have to do this again, but if i do at least i'm familiar with the process.


I'm no networking pro, just a keen prosumer, but if anyone in Australia has a similar issue and not the clues or equiptment to give this a go then message me, might be able to work something out.

New Member
Posts: 4
Registered: ‎05-21-2016

Re: EdgeMax rescue kit (now you can reinstall EdgeOS from scratch)

In my case I had router ssh and web interface unresponsive, though it was still keeping pppoe connection and routing,

after reboot it wasn't showing up, connected serial cable and this was the outputs:


Flashed router with OP's software and guide and router ended up throwing tons of read errors,

so changed USB drive  to Kingston Data Traveler, flashed again and it works again.


I myself had pwoer adapter changed, also I had UNMS set up and then remove the server, this migh have cause lots of logs written?


Anyway, thanks to OP!