Reply
New Member
Posts: 2
Registered: ‎12-30-2016
Accepted Solution

EdgeRouter X and IGMP not working.

I've been trying to get an ER-X working on IPTV and have the following issues:

 

1. show ip multicast mfc shows nothing

2. show ip multicast interfaces shows nothing

 

I've followed multiple configs and have checked that I can grep IGMP - all seems to be fine. 

 

My config is as follows -

 

firewall {
    all-ping enable
    broadcast-ping disable
    ipv6-receive-redirects disable
    ipv6-src-route disable
    ip-src-route disable
    log-martians enable
    name WAN_IN {
        default-action drop
        description "WAN to internal"
        rule 10 {
            action accept
            description "Allow Multicast (max)"
            destination {
                address 224.0.0.0/4
            }
            log disable
            protocol all
        }
        rule 20 {
            action accept
            description "Allow established/related"
            state {
                established enable
                related enable
            }
        }
        rule 30 {
            action accept
            description "Allow ICMP (max)"
            log disable
            protocol icmp
            state {
                established enable
                invalid disable
                new disable
                related enable
            }
        }
        rule 40 {
            action accept
            description "Allow IGMP (max)"
            log disable
            protocol igmp
        }
        rule 50 {
            action drop
            description "Drop invalid state"
            state {
                invalid enable
            }
        }
    }
    name WAN_LOCAL {
        default-action drop
        description "WAN to router"
        rule 10 {
            action accept
            description "Allow Multicast (max)"
            destination {
                address 224.0.0.0/4
            }
            log disable
            protocol all
        }
        rule 20 {
            action accept
            description "Allow established/related"
            state {
                established enable
                related enable
            }
        }
        rule 30 {
            action drop
            description "Drop Invalid State"
            state {
                invalid enable
            }
        }
    }
    options {
        mss-clamp {
            mss 1412
        }
    }
    receive-redirects disable
    send-redirects enable
    source-validation disable
    syn-cookies enable
}
interfaces {
    ethernet eth0 {
        description Local
        duplex auto
        speed auto
    }
    ethernet eth1 {
        description Local
        duplex auto
        speed auto
    }
    ethernet eth2 {
        description Local
        duplex auto
        speed auto
    }
    ethernet eth3 {
        description Local
        duplex auto
        speed auto
    }
    ethernet eth4 {
        description "Internet (PPPoE)"
        duplex auto
        poe {
            output off
        }
        pppoe 0 {
            default-route auto
            firewall {
                in {
                    name WAN_IN
                }
                local {
                    name WAN_LOCAL
                }
            }
            mtu 1492
            name-server auto
            password 
            user-id 
        }
        speed auto
    }
    loopback lo {
    }
    switch switch0 {
        address 192.168.1.1/24
        description Local
        mtu 1500
        switch-port {
            interface eth0 {
            }
            interface eth1 {
            }
            interface eth2 {
            }
            interface eth3 {
            }
            vlan-aware disable
        }
    }
}
port-forward {
    auto-firewall enable
    hairpin-nat enable
    lan-interface switch0
    rule 1 {
        description SMTP
        forward-to {
            address 192.168.1.198
            port 25
        }
        original-port 25
        protocol tcp_udp
    }
    wan-interface eth4
}
protocols {
    igmp-proxy {
        interface eth4 {
            alt-subnet 0.0.0.0/0
            role upstream
            threshold 1
        }
        interface switch0 {
            alt-subnet 0.0.0.0/0
            role downstream
            threshold 1
        }
    }
}
service {
    dhcp-server {
        disabled false
        hostfile-update disable
        shared-network-name LAN {
            authoritative disable
            subnet 192.168.1.0/24 {
                default-router 192.168.1.1
                dns-server 192.168.1.1
                lease 86400
                start 192.168.1.38 {
                    stop 192.168.1.243
                }
            }
        }
        use-dnsmasq disable
    }
    dns {
        forwarding {
            cache-size 150
            listen-on switch0
        }
    }
    gui {
        http-port 80
        https-port 443
        older-ciphers enable
    }
    nat {
        rule 5010 {
            description "masquerade for WAN"
            outbound-interface pppoe0
            type masquerade
        }
    }
    ssh {
        port 22
        protocol-version v2
    }
}
system {
    host-name ubnt
    login {
        user ubnt {
            authentication {
                encrypted-password
                plaintext-password ""
            }
            full-name ""
            level admin
        }
    }
    ntp {
        server 0.ubnt.pool.ntp.org {
        }
        server 1.ubnt.pool.ntp.org {
        }
        server 2.ubnt.pool.ntp.org {
        }
        server 3.ubnt.pool.ntp.org {
        }
    }
    syslog {
        global {
            facility all {
                level notice
            }
            facility protocols {
                level debug
            }
        }
    }
    time-zone UTC
}

I've tried to offload ipv4 forwarding which someone indicated might help but this is unavailable.

I've made sure I'm running the latest firmware (1.9.1) which says it supports IGMP Proxy but I don't seem to get anywhere.

 

Any help would be appreciated.


Accepted Solutions
Member
Posts: 231
Registered: ‎10-12-2016
Kudos: 55
Solutions: 17

Re: EdgeRouter X and IGMP not working.

Try adding an IP address to the eth4 interface e.g., set interfaces ethernet eth4 address 192.168.255.1/24. The address can be any valid IPv4 address that you're not using.

 

I found that the IGMP reports were being sent with a source address of 0.0.0.0 and observed the same behaviour as you're seeing. Once I added an IP address to the ethernet interface the IGMP reports were sent using that address and things burst into life.

 

Regards

View solution in original post


All Replies
Established Member
Posts: 1,063
Registered: ‎02-04-2015
Kudos: 611
Solutions: 49

Re: EdgeRouter X and IGMP not working.

You've got igmp-proxy in there so it should start up at least.  What happens if you try

 

restart igmp-proxy

 

Do you get this

$ restart igmp-proxy
Stopping IGMP proxy
Starting IGMP proxy

Or does it give you something about IGMP proxy not running?  I've had issues with it from time to time, you might just need to give it a kick to get it running

Member
Posts: 231
Registered: ‎10-12-2016
Kudos: 55
Solutions: 17

Re: EdgeRouter X and IGMP not working.

Try adding an IP address to the eth4 interface e.g., set interfaces ethernet eth4 address 192.168.255.1/24. The address can be any valid IPv4 address that you're not using.

 

I found that the IGMP reports were being sent with a source address of 0.0.0.0 and observed the same behaviour as you're seeing. Once I added an IP address to the ethernet interface the IGMP reports were sent using that address and things burst into life.

 

Regards

Member
Posts: 298
Registered: ‎12-18-2016
Kudos: 28
Solutions: 12

Re: EdgeRouter X and IGMP not working.

I get Internet (7) and IPTV (8) at different VLAN.

Look at the first four code blocks. "Entertain" means IPTV.

 

https://blog.tausys.de/2016/02/22/edgerouter-am-telekom-internetanschluss-mit-entertain-und-ipv6/

 

After block three I get an IP 10.27.xxx.xxx/19. Without this the igmp-proxy (block four) will not start.

 

New Member
Posts: 2
Registered: ‎12-30-2016

Re: EdgeRouter X and IGMP not working.

Thanks for the responses,

 

@poisonsnak Trying that showed that IGMP was NOT running and tried but failed to start which pointed me to 

 

@smf22 Setting the eth4 ip address allowed a binding point for the IGMP so now stays running.

 

For the sake of completeness, here is the working config for Plusnet ISP (UK) and TV Sport upgrade pack.

 

firewall {
    all-ping enable
    broadcast-ping disable
    ipv6-receive-redirects disable
    ipv6-src-route disable
    ip-src-route disable
    log-martians enable
    name WAN_IN {
        default-action drop
        description "WAN to internal"
        rule 10 {
            action accept
            description "Allow Multicast (max)"
            destination {
                address 224.0.0.0/4
            }
            log disable
            protocol all
        }
        rule 20 {
            action accept
            description "Allow established/related"
            state {
                established enable
                related enable
            }
        }
        rule 30 {
            action accept
            description "Allow ICMP (max)"
            log disable
            protocol icmp
            state {
                established enable
                invalid disable
                new disable
                related enable
            }
        }
        rule 40 {
            action accept
            description "Allow IGMP (max)"
            log disable
            protocol igmp
        }
        rule 50 {
            action drop
            description "Drop invalid state"
            state {
                invalid enable
            }
        }
    }
    name WAN_LOCAL {
        default-action drop
        description "WAN to router"
        rule 10 {
            action accept
            description "Allow Multicast (max)"
            destination {
                address 224.0.0.0/4
            }
            log disable
            protocol all
        }
        rule 20 {
            action accept
            description "Allow established/related"
            state {
                established enable
                related enable
            }
        }
        rule 30 {
            action drop
            description "Drop Invalid State"
            state {
                invalid enable
            }
        }
    }
    options {
        mss-clamp {
            mss 1412
        }
    }
    receive-redirects disable
    send-redirects enable
    source-validation disable
    syn-cookies enable
}
interfaces {
    ethernet eth0 {
        description Local
        duplex auto
        speed auto
    }
    ethernet eth1 {
        description Local
        duplex auto
        speed auto
    }
    ethernet eth2 {
        description Local
        duplex auto
        speed auto
    }
    ethernet eth3 {
        description Local
        duplex auto
        speed auto
    }
    ethernet eth4 {
	address 192.168.255.1/24
        description "Internet (PPPoE)"
        duplex auto
        poe {
            output off
        }
        pppoe 0 {
            default-route auto
            firewall {
                in {
                    name WAN_IN
                }
                local {
                    name WAN_LOCAL
                }
            }
            mtu 1492
            name-server auto
            password ********
            user-id ********
        }
        speed auto
    }
    loopback lo {
    }
    switch switch0 {
        address 192.168.1.1/24
        description Local
        mtu 1500
        switch-port {
            interface eth0 {
            }
            interface eth1 {
            }
            interface eth2 {
            }
            interface eth3 {
            }
            vlan-aware disable
        }
    }
}
port-forward {
    auto-firewall enable
    hairpin-nat enable
    lan-interface switch0
    rule 1 {
        description SMTP
        forward-to {
            address ********
            port 25
        }
        original-port 25
        protocol tcp_udp
    }
    wan-interface eth4
}
protocols {
    igmp-proxy {
        interface eth4 {
            alt-subnet 0.0.0.0/0
            role upstream
            threshold 1
        }
        interface switch0 {
            alt-subnet 0.0.0.0/0
            role downstream
            threshold 1
        }
    }
}
service {
    dhcp-server {
        disabled false
        hostfile-update disable
        shared-network-name LAN {
            authoritative disable
            subnet 192.168.1.0/24 {
                default-router 192.168.1.1
                dns-server 192.168.1.1
                lease 86400
                start 192.168.1.38 {
                    stop 192.168.1.243
                }
            }
        }
        use-dnsmasq disable
    }
    dns {
        forwarding {
            cache-size 150
            listen-on switch0
        }
    }
    gui {
        http-port 80
        https-port 443
        older-ciphers enable
    }
    nat {
        rule 5010 {
            description "masquerade for WAN"
            outbound-interface pppoe0
            type masquerade
        }
    }
    ssh {
        port 22
        protocol-version v2
    }
}
system {
    host-name ubnt
    login {
        user ubnt {
            authentication {
                encrypted-password 
                plaintext-password ""
            }
            full-name ""
            level admin
        }
    }
    ntp {
        server 0.ubnt.pool.ntp.org {
        }
        server 1.ubnt.pool.ntp.org {
        }
        server 2.ubnt.pool.ntp.org {
        }
        server 3.ubnt.pool.ntp.org {
        }
    }
    syslog {
        global {
            facility all {
                level notice
            }
            facility protocols {
                level debug
            }
        }
    }
    time-zone UTC
}

Luckily I didn't have the extra hassle of VLANs.

 

Thanks again......

Reply