Emerging Member
Posts: 47
Registered: ‎01-18-2015
Kudos: 1

Edgerouter to OpenVPN Access Server

I'm trying to setup a connection between an ER-3 and an OpenVPN access server I've setup. Based on the instructions I've read on this forum, it should be very easy. Download the config file from the access server, upload it to the router, enter this code

set interfaces openvpn vtun0 config-file /config/client.ovpn

commit
save

I've also gone into the config file and added:

auth-user-pass auth.txt

 

Then I created a file auth.txt with the first line being the username, and the second line being the password. I uploaded that to the edgerouter and it stopped giving me the Enter Auth Username:failed to start OpenVPN error, however the client still does not start. Im getting this error:

OpenVPN configuration error: Failed to start OpenVPN tunnel

Ive tested this configuration and it works in Windows to connect to the Access Server. I can't seem to find a log file or what exactly is missing to cause the client not to connect. And the original thread that had these instructions here is 4 years old with no further information.

Emerging Member
Posts: 47
Registered: ‎01-18-2015
Kudos: 1

Re: Edgerouter to OpenVPN Access Server

After further investigation ive found I needed to specify the folder in the config file of the auth.txt to /config/auth.txt.

 

I also managed to find the logs in /var/logs/messages.

 

The problem Im getting now is this:

TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
TLS Error: TLS handshake failed

Researching this it appears to be a firewall issue of some sort, but I have 1194 on my wan_local policy open. I'm kinda stuck again.

Emerging Member
Posts: 47
Registered: ‎01-18-2015
Kudos: 1

Re: Edgerouter to OpenVPN Access Server

Ok I solved the TLS issue from this thread. Now Im getting these errors.

 

TCPv4_CLIENT link local: [undef]
Feb 14 13:04:59 ubnt openvpn[10727]: TCPv4_CLIENT link remote: [AF_INET]XXX.XXX.XXX.XXX:443
Feb 14 13:04:59 ubnt openvpn[10727]: Connection reset, restarting [0]
Feb 14 13:04:59 ubnt openvpn[10727]: SIGUSR1[soft,connection-reset] received, process restarting
Feb 14 13:04:59 ubnt openvpn[10727]: Restart pause, 5 second(s)
Feb 14 13:05:04 ubnt openvpn[10727]: Socket Buffers: R=[294912->200000] S=[294912->200000]
Feb 14 13:05:04 ubnt openvpn[10727]: UDPv4 link local: [undef]
Feb 14 13:05:04 ubnt openvpn[10727]: UDPv4 link remote: [AF_INET]XXX.XXX.XXX.XXX:1194
Feb 14 13:05:09 ubnt openvpn[10727]: Server poll timeout, restarting