New Member
Posts: 15
Registered: ‎06-06-2014

GRE Tunnel with multicast - Just trying to understand one thing

[ Edited ]

Hello!

I've been searching into solutions at one point over the forum, some might have seen my other posts and somebody told me the best option I had to acheive my goals (mainly, one of the things I needed was that network autodiscovery for services (smb, bonjour, etc) worked on two different networks) was to setup a Layer 2 GRE tunnel between my two sites. So I did. And it worked!

Now, I'm just trying to figure out one of the mechanics of it. As far as I understood (I'm not networking genius), the GRE tunnel enabled multicast and it is what makes the services like bonjour able to get autodiscovered. Right now, it works, but my settings shows that multicast is disabled on boths my ERL. So like I said, I'm just trying to figure out why: is it that I misunderstood multicast? Or is it because service autodiscovery works in an another way that GRE enables?

EDIT: I've just realized that AFP/bonjour works very well, but my one (and only) SMB share on the network appears but disapears after I click on it, say 3-4 seconds after. Maybe I do need to enable multicast afterall?

Previous Employee
Posts: 13,551
Registered: ‎06-10-2011
Kudos: 5479
Solutions: 1656
Contributions: 2

Re: GRE Tunnel with multicast - Just trying to understand one thing

Actually when you set up the layer-2 GRE tunnel and bridge the interfaces (I assume that's what you did since you didn't show your config), the two sides become a single layer-2 network (i.e., as if they are connected to the same switch for example), so multicast/broadcast can work across the two sides (the SMB issue is probably something else).

New Member
Posts: 15
Registered: ‎06-06-2014

Re: GRE Tunnel with multicast - Just trying to understand one thing

Okay, it does all make better sense now.

Just out of curiosity, can you think of anything, ERL side, that could cause that problem with SMB? (Looking in the SMB machine side, I can't see anything, and it's only on the remote side of the tunnel that I get this problem...)

And for reference, here is one of my ERL config for interfaces. The other is pretty much the same (except for local/remote IP for tunnel, of course.)

interfaces {
    bridge br0 {
        address 10.1.0.1/24
        aging 300
        hello-time 2
        max-age 20
        priority 0
        promiscuous disable
        stp false
    }
    ethernet eth0 {
        bridge-group {
            bridge br0
        }
        description LAN
        duplex auto
        firewall {
            in {
            }
            local {
            }
            out {
            }
        }
        speed auto
    }
    ethernet eth1 {
        address dhcp
        description WAN
        duplex auto
        firewall {
            in {
            }
            local {
            }
            out {
            }
        }
        speed auto
    }
    ethernet eth2 {
        address 10.1.1.1/24
        description WLAN
        duplex auto
        firewall {
            in {
            }
            local {
            }
        }
        speed auto
    }
    loopback lo {
    }
    tunnel tun0 {
        bridge-group {
            bridge br0
        }
        encapsulation gre-bridge
        local-ip 132.203.X.X
        multicast disable
        remote-ip 132.203.X.X
        ttl 255
    }
}