Reply
SuperUser
Posts: 16,525
Registered: ‎06-23-2010
Kudos: 5198
Solutions: 78

IPv4: Neighbour table overflow

[ Edited ]

This evening my router stopped passing traffic for about 10 minutes.   During this time dmesg was flooded with:

 

IPv4: Neighbour table overflow
IPv4: Neighbour table overflow
IPv4: Neighbour table overflow
IPv4: Neighbour table overflow
IPv4: Neighbour table overflow
IPv4: Neighbour table overflow
IPv4: Neighbour table overflow
IPv4: Neighbour table overflow
IPv4: Neighbour table overflow
IPv4: Neighbour table overflow

 

Immediately after I got control back:

admin@uER:~$ ip neigh | wc -l
816

 

admin@uER-MNFDPA-HUT:~$ show arp | wc -l
821

 

Previous Employee
Posts: 13,551
Registered: ‎06-10-2011
Kudos: 5429
Solutions: 1656
Contributions: 2

Re: IPv4: Neighbour table overflow

Yeah probably the ARP table was full. You can increase the table size by, for example:

 

sudo /sbin/sysctl -q -w net.ipv4.neigh.default.gc_thresh1=1024
sudo /sbin/sysctl -q -w net.ipv4.neigh.default.gc_thresh2=4096
sudo /sbin/sysctl -q -w net.ipv4.neigh.default.gc_thresh3=8192

Also note that the above higher values are already the default in the new v1.7.0alpha1 release, so you could also give that a try.

Highlighted
Member
Posts: 157
Registered: ‎11-28-2013
Kudos: 121
Solutions: 7

Re: IPv4: Neighbour table overflow


UBNT-ancheng wrote:

Yeah probably the ARP table was full. You can increase the table size by, for example:

 

sudo /sbin/sysctl -q -w net.ipv4.neigh.default.gc_thresh1=1024
sudo /sbin/sysctl -q -w net.ipv4.neigh.default.gc_thresh2=4096
sudo /sbin/sysctl -q -w net.ipv4.neigh.default.gc_thresh3=8192

Also note that the above higher values are already the default in the new v1.7.0alpha1 release, so you could also give that a try.


Or, on 1.6, use:

set system ip arp table-size 8192

 to persist over restarts.

 

(Thanks, @UBNT-ancheng for fixing the defaults!  I haven't checked 1.7a1 yet - are the ipv6 defaults also fixed?)

 

Previous Employee
Posts: 13,551
Registered: ‎06-10-2011
Kudos: 5429
Solutions: 1656
Contributions: 2

Re: IPv4: Neighbour table overflow

Yeah IPv6 defaults are also increased. Good point about the system settings, I'll need to get those defaults changed too. Thanks for the reminder!

Reply