Scheduled maintenance: Community available only in read-only mode until 6:00 AM (PT)
New Member
Posts: 33
Registered: ‎10-26-2016
Kudos: 1
Solutions: 2
Accepted Solution

IPv6 autoconfig /SLAAC not working for my config

[ Edited ]

First, let's start with the fact that I'm new to the IPv6 world.

I've used my base config from the following site: https://kriegsman.io/

My provider is giving me an IPv6 /64 address (typo corrected) /48 subnet.

My WAN is on eth0 And internet is on VLAN 6 using PPPOE0,

My LAN is on eth1 on VLAN 10. I'm seeing the /64 address on the Routers LAN interface, so that;s ok,

If I manually assign an IP to my Windows 10 Client and put in the router as the gateway all is fine, i can browse the internet fine using IPv6.

My problem lies in getting some kind of auto-assignment. I know that has changed with IPv6.

I've posted the relevant part of my config below, it's basically the same as from the tutorial site (except from the LAN VLAN), but I can't get an auto IP on IPv6. 

Probably something is wrong but I can't find it.

 

The config below is cleaned to be relevant to this issue.

 

Spoiler
firewall {}
interfaces {
    ethernet eth0 {
        description "eth0 - FTTH"
        duplex auto
        mtu 1512
        speed auto
        vif 6 {
            description "eth0.6 - Internet"
            mtu 1508
            pppoe 0 {
                default-route auto
                dhcpv6-pd {
                    no-dns
                    pd 0 {
                        interface eth1.10 {
                            prefix-id :1
                            service slaac
                        }
                        prefix-length /48
                    }
                    rapid-commit disable
                }
                idle-timeout 180
                ipv6 {
                    address {
                        autoconf
                    }
                    dup-addr-detect-transmits 1
                    enable {
                    }
                }
                mtu 1500
                name-server auto
                password #########
                user-id #########
            }
        }
    }
    ethernet eth1 {
        description "eth1 - To Local Swithes"
        duplex auto
        mtu 1504
        speed auto
        vif 10 {
            address 192.168.0.254/24
            description "LAN (trusted)"
            ipv6 {
                dup-addr-detect-transmits 1
                router-advert {
                    cur-hop-limit 64
                    link-mtu 0
                    managed-flag false
                    max-interval 600
                    name-server 2001:4860:4860::8888
                    name-server 2001:4860:4860::8844
                    other-config-flag false
                    prefix ::/64 {
                        autonomous-flag true
                        on-link-flag true
                        valid-lifetime 2592000
                    }
                    radvd-options "RDNSS 2001:4860:4860::8888 2001:4860:4860::8844 {};"
                    reachable-time 0
                    retrans-timer 0
                    send-advert true
                }
            }
            mtu 1500
        }
    loopback lo {
    }
protocols {
}
service {
    dhcp-server {
        disabled false
        global-parameters "option vendor-class-identifier code 60 = string;"
        global-parameters "option broadcast-address code 28 = ip-address;"
        hostfile-update disable
        shared-network-name LAN {
            authoritative enable
            subnet 192.168.0.0/24 {
                default-router 192.168.0.254
                dns-server 192.168.0.254
                dns-server 8.8.4.4
                lease 86400
                start 192.168.0.50 {
                    stop 192.168.0.200
                }
            }
        }
        use-dnsmasq disable
    }
    ubnt-discover {
        disable
    }
}
system {
    host-name Router
    name-server 8.8.8.8
    name-server 8.8.4.4
    name-server 2001:4860:4860::8888
    name-server 2001:4860:4860::8844
    ntp {
        server 0.ubnt.pool.ntp.org {
        }
        server 1.ubnt.pool.ntp.org {
        }
        server 2.ubnt.pool.ntp.org {
        }
        server 3.ubnt.pool.ntp.org {
        }
    }
    offload {
        hwnat disable
        ipsec enable
        ipv4 {
            forwarding enable
            gre enable
            pppoe enable
            vlan enable
        }
        ipv6 {
            forwarding enable
            pppoe enable
            vlan disable
        }
    }
    package {
        repository wheezy {
            components "main contrib non-free"
            distribution wheezy
            password ""
            url http://mirror.leaseweb.com/debian
            username ""
        }
        repository wheezy-security {
            components main
            distribution wheezy/updates
            password ""
            url http://security.debian.org
            username ""
        }
    }
    static-host-mapping {
    }
    syslog {
        global {
            facility all {
                level notice
            }
            facility protocols {
                level debug
            }
        }
    }
    time-zone Europe/Amsterdam
    traffic-analysis {
        dpi disable
        export disable
    }
}

/* Warning: Do not remove the following line. */
/* === vyatta-config-version: "config-management@1:conntrack@1:cron@1:dhcp-relay@1:dhcp-server@4:firewall@5:ipsec@5:nat@3:qos@1:quagga@2:system@4:ubnt-pptp@1:ubnt-util@1:vrrp@1:webgui@1:webproxy@1:zone-policy@1" === */
/* Release version: v1.9.1.1.4977353.170426.0429 */

 


Accepted Solutions
New Member
Posts: 33
Registered: ‎10-26-2016
Kudos: 1
Solutions: 2

Re: IPv6 autoconfig /SLAAC not working for my config

Thanks for the reply.

My mistake in regards to the provider subnet. I get an /48 subnet.

In the end I couldn't get it to work with your requests either.

After debugging some more it appeared that i'm suffering from the bug mentioned here: 

https://community.ubnt.com/t5/EdgeMAX/radvd-dies-when-pppoe-drops/td-p/1653222

 

It's a combination of PPPoE and Router Advert.

My /etc/radvd.conf was empty.

Without changing anything, after a reboot the config file got created again and my ip's were handed out to the clients.

What I read from the other topic this is already solved in beta 1.9.7.

 

Thanks for the effort and tips. They were actually al good tips!

View solution in original post


All Replies
Ubiquiti Employee
Posts: 581
Registered: ‎01-06-2017
Kudos: 212
Solutions: 20

Re: IPv6 autoconfig /SLAAC not working for my config

My provider is giving me an IPv6 /64 address.

 

Looking at your configuration you are asking for prefix of length /48.

 

                dhcpv6-pd {
                    no-dns
                    pd 0 {
                        interface eth1.10 {
                            prefix-id :1
                            service slaac
                        }
                        prefix-length /48
                    }
                    rapid-commit disable
                }

If your provider really gives you a single /64 address then you can't do much without NAT (NAT66 is not currently implemented in EdgeOS).

 

If your provider gives you /64 prefix, then change prefix-length to /64, remove prefix-id and add host-address ::1 under pd 0. The idea is that your ISP gives you /64 network, but you can use the remaining 64 bits to address your hosts however you want.

New Member
Posts: 33
Registered: ‎10-26-2016
Kudos: 1
Solutions: 2

Re: IPv6 autoconfig /SLAAC not working for my config

Thanks for the reply.

My mistake in regards to the provider subnet. I get an /48 subnet.

In the end I couldn't get it to work with your requests either.

After debugging some more it appeared that i'm suffering from the bug mentioned here: 

https://community.ubnt.com/t5/EdgeMAX/radvd-dies-when-pppoe-drops/td-p/1653222

 

It's a combination of PPPoE and Router Advert.

My /etc/radvd.conf was empty.

Without changing anything, after a reboot the config file got created again and my ip's were handed out to the clients.

What I read from the other topic this is already solved in beta 1.9.7.

 

Thanks for the effort and tips. They were actually al good tips!