Member
Posts: 275
Registered: ‎08-23-2011
Kudos: 203
Solutions: 6
Accepted Solution

Internal VoIP calls No Audio on ER Load Balancing 3 WANs

I'm having a really weird issue. I'm load balancing 3 WAN connections using a EdgeRouter and I'm forcing all VoIP to go through one WAN connection to the 3CX PBX in the cloud. External calls work great (in and out), though when the employees try to call each other they get no audio. I would assume a NAT issue but since external calls are working just fine, not sure what it is.

Johnathan Penberthy
Director
Rural Data Centers

Accepted Solutions
Member
Posts: 275
Registered: ‎08-23-2011
Kudos: 203
Solutions: 6

Re: Internal VoIP calls No Audio on ER Load Balancing 3 WANs

3CX Session Border Controller fixed the issue

Johnathan Penberthy
Director
Rural Data Centers

View solution in original post


All Replies
Veteran Member
Posts: 6,104
Registered: ‎01-04-2017
Kudos: 886
Solutions: 314

Re: Internal VoIP calls No Audio on ER Load Balancing 3 WANs

How are internal calls routed? Do you have exclusions for RFC1918 address's in your load-balance config? if not that's probably your problem.
New Member
Posts: 30
Registered: ‎01-05-2017
Kudos: 1
Solutions: 1

Re: Internal VoIP calls No Audio on ER Load Balancing 3 WANs

i had a similar problem with a freepbx system.  I think the soln was opening the rtm 10000-20000.

Member
Posts: 275
Registered: ‎08-23-2011
Kudos: 203
Solutions: 6

Re: Internal VoIP calls No Audio on ER Load Balancing 3 WANs

3CX Session Border Controller fixed the issue

Johnathan Penberthy
Director
Rural Data Centers