Highlighted
New Member
Posts: 11
Registered: ‎06-17-2016
Kudos: 1
Accepted Solution

OSPFv3 and IPv6 feature gaps

[ Edited ]

I have found what I believe to be some significant gaps in the IPv6 feature set on EdgeOS, some may be known, some maybe not, I have not seen exact details of any of them, just folks asking questions and speculating. Some clear "yes" or "no" would be nice, as lacking these features essentially renders this platform undeployable in many dual stacked core environments. 

First (and I hope I am just missing simething simple), there doesn't seem to be a way to configure a static IP address on a port that I am able to find. 

 

[edit interfaces ethernet eth4]
buraglio@gw# set ipv6 address
autoconf eui64

 

The option for Static seems to be completely missing? I am really hoping that I am simply missing something easy here, but a search for static addressing just years a myriad of other stuff related to dhcpv6-pd. 

 

OSPFv3 is missing significant features needed to make this a viable routing platform - and I think this is an artifact of the underlying routing platforms, but I would like confirmation. Particularly, the link-type point-to-point is missing from OSPFv3 making this operate in an inconsistent manner when compared to it's v4 analog. Happy to be wrong about these things, looking for some insight from the maintainers. 

ForwardingPlane, LLC
https://www.forwardingplane.net/

Accepted Solutions
New Member
Posts: 38
Registered: ‎08-03-2017
Kudos: 11
Solutions: 2

Re: OSPFv3 and IPv6 feature gaps

Answered semi-privately already, but will add here for reference's sake.

 

IPv6 addresses aren't configured under the "[edit interfaces ethernet eth4 ipv6 address]" context. That's for addressing functions that are unique to IPv6. Addresses in general are configured under the "[edit interfaces ethernet eth4 address]" context regardless of whether they're IPv4 or IPv6.

 

Try something like this:

 

[edit interfaces ethernet eth4]
buraglio@gw# set address fd00::1/64

View solution in original post


All Replies
New Member
Posts: 11
Registered: ‎06-17-2016
Kudos: 1

Re: OSPFv3 and IPv6 feature gaps

So, I managed to make this work by using some acceptable, but what I would consider one-off workarounds. The static addressing question and lack of a few of the features are still open questions. Any insight appreciated.
ForwardingPlane, LLC
https://www.forwardingplane.net/
New Member
Posts: 11
Registered: ‎06-17-2016
Kudos: 1

Re: OSPFv3 and IPv6 feature gaps

For reference, OSPFv3 to a Mikrotik was accomplished with the following:

 

set interfaces ethernet eth4 ipv6 ospfv3 cost 1
set interfaces ethernet eth4 ipv6 ospfv3 dead-interval 40
set interfaces ethernet eth4 ipv6 ospfv3 hello-interval 10
set interfaces ethernet eth4 ipv6 ospfv3 instance-id 0
set interfaces ethernet eth4 ipv6 ospfv3 priority 1
set interfaces ethernet eth4 ipv6 ospfv3 retransmit-interval 5
set interfaces ethernet eth4 ipv6 ospfv3 transmit-delay 1
set protocols ospfv3 area 0.0.0.0 area-type normal
set protocols ospfv3 area 0.0.0.0 interface eth4
set protocols ospfv3 parameters abr-type cisco
set protocols ospfv3 parameters router-id 0.0.0.1
set protocols ospfv3 passive-interface default
set protocols ospfv3 passive-interface-exclude eth4
set protocols ospfv3 redistribute connected
set protocols ospfv3 redistribute static

 

set interfaces ethernet eth4 ipv6 dup-addr-detect-transmits 1
set interfaces ethernet eth4 ipv6 ospfv3 cost 1
set interfaces ethernet eth4 ipv6 ospfv3 dead-interval 40
set interfaces ethernet eth4 ipv6 ospfv3 hello-interval 10
set interfaces ethernet eth4 ipv6 ospfv3 instance-id 0
set interfaces ethernet eth4 ipv6 ospfv3 priority 1
set interfaces ethernet eth4 ipv6 ospfv3 retransmit-interval 5
set interfaces ethernet eth4 ipv6 ospfv3 transmit-delay 1

 

Mikrotik

 

/routing ospf-v3 instance
set [ find default=yes ] metric-bgp=100 metric-other-ospf=100 redistribute-connected=as-type-1 redistribute-static=as-type-1 router-id=\
1.0.0.0
/routing ospf-v3 interface
add area=backbone interface=ether9

 

 

ForwardingPlane, LLC
https://www.forwardingplane.net/
New Member
Posts: 38
Registered: ‎08-03-2017
Kudos: 11
Solutions: 2

Re: OSPFv3 and IPv6 feature gaps

Answered semi-privately already, but will add here for reference's sake.

 

IPv6 addresses aren't configured under the "[edit interfaces ethernet eth4 ipv6 address]" context. That's for addressing functions that are unique to IPv6. Addresses in general are configured under the "[edit interfaces ethernet eth4 address]" context regardless of whether they're IPv4 or IPv6.

 

Try something like this:

 

[edit interfaces ethernet eth4]
buraglio@gw# set address fd00::1/64
New Member
Posts: 11
Registered: ‎06-17-2016
Kudos: 1

Re: OSPFv3 and IPv6 feature gaps

Great info, thanks!

ForwardingPlane, LLC
https://www.forwardingplane.net/