Reply
Member
Posts: 159
Registered: ‎08-09-2010
Kudos: 4
Solutions: 3
Accepted Solution

OpenVPN configuration error: Must specify "local-address"

Dear, 

 

I'm working with 1.4.1 version and I'm having the following problem on openvpn settings.

After I have set up successfull set up the VPN I want to cancel the local-address and remote address because I want to make a bridge vpn but when I try I get always the following message:

 

CE@ubnt# delete interfaces openvpn vtun0 local-address 1.1.1.2

[edit]

CE@ubnt# commit

[ interfaces openvpn vtun0 ]

OpenVPN configuration error: Must specify "local-address".

 

Commit failed

 

Anyone has a solution on that?

 

thanks


Accepted Solutions
Highlighted
Member
Posts: 159
Registered: ‎08-09-2010
Kudos: 4
Solutions: 3

Re: OpenVPN configuration error: Must specify "local-address"

Hi Guys,

 

I have understood where was my mistake: if I try to commit before completing the configuration , I mean if I don't add the following setting

 

ubnt@R1# set interfaces openvpn vtun0 bridge-group bridge br0

 before committing I get the error.

 

Thanks anyway.

View solution in original post


All Replies
SuperUser
Posts: 7,480
Registered: ‎01-05-2012
Kudos: 1973
Solutions: 979

Re: OpenVPN configuration error: Must specify "local-address"

And

delete interfaces openvpn vtun0 local-address

?

Member
Posts: 159
Registered: ‎08-09-2010
Kudos: 4
Solutions: 3

Re: OpenVPN configuration error: Must specify "local-address"

same!!!

Member
Posts: 159
Registered: ‎08-09-2010
Kudos: 4
Solutions: 3

Re: OpenVPN configuration error: Must specify "local-address"

at the end I have deleted the interface vtun0, but now I'm trying to configure the interface from the beginning and because I want to use the vtun0 in a bridge  I don't want to configure local-address and remote-address, but when I try to commit again I see this error. I think v 1.4.1 is definitely bugged. Can someone confirm or give me an hand to understand this phenomena?

 

 

 

PE@ubnt# commit

[ interfaces openvpn vtun0 ]

OpenVPN configuration error: Must specify "local-address".

 

Commit failed

[edit]

 

Thank you

Highlighted
Member
Posts: 159
Registered: ‎08-09-2010
Kudos: 4
Solutions: 3

Re: OpenVPN configuration error: Must specify "local-address"

Hi Guys,

 

I have understood where was my mistake: if I try to commit before completing the configuration , I mean if I don't add the following setting

 

ubnt@R1# set interfaces openvpn vtun0 bridge-group bridge br0

 before committing I get the error.

 

Thanks anyway.

Reply