Reply
Highlighted
New Member
Posts: 6
Registered: ‎09-03-2017

PVID blank vs PVID 1 if VLAN aware set.

[ Edited ]

I've been playing around with VLANs on an ER-X router, and while I've got things working to my satisfaction right now, one question remains outstand on how this works.  After lots of reading I understand the concept of tagged versus untagged frames, and that if VLAN aware is not set, the router will forward all frames explicitly tagged by a downstream device (e.g. a UBNT AP with VLAN set) and will forward untagged frames as untagged.  But what happens if I set VLAN aware and leave PVID blank?  Will all untagged frames now be marked as tagged and forwarded as VLAN 1, just as if I set PVID equal to 1, or will they be forwarded as untagged, just as if VLAN aware was not set?

 

All the documentation I've encountered on the internet is very confusing on this point because it's not precise.  In some cases they say that VLAN 1 is equivelent to not setting a VLAN, and in others they seem to indicate that setting VLAN equal to 1, forces a frame to be forwarded with a VLAN tag of 1 versus untagged.  

 

Also, the documentation is very unclear about the interaction between setting PVID and VID on the same port, and for the record what I believe it means is that in practical terms you cannot set PVID with a value that's equal to one of the entries you've set on VID, because the switch would have problems figuring out, on a return packet, whether it's supposed to forward the frame back on the port with a VLAN tag equal to that value, per the VID setting, or strip the VLAN tag completely and make it untagged, per the PID setting.

 

If someone who really knows how all this works can comment on what the real deal here is I'd appreciate it.  Like I said, for now I've got it working, but I want to make sure I know why it's working.  

Ubiquiti Employee
Posts: 2,296
Registered: ‎05-08-2017
Kudos: 416
Solutions: 343

Re: PVID blank vs PVID 1 if VLAN aware set.

[ Edited ]

Hi @srwsol,

 

The 'VLAN aware' feature will allow the switch0 interface to utilize the PVID and VID settings. If you leave the PVID blank on a switch-port, the port will remain associated with the primary switch0 interface without any VLAN association. Simply adding vlan-aware to the configuration will not instantly drop all traffic from the switch-ports (without vid or pvid tags) to the switch0 interface.

 

The switch0 interface is not associated with any VLANs (including VLAN1). The switch0 VLAN interface for VLAN1 is switch0 vif 1 (switch0.1). Because switch0 is not associated with any VLAN tag, there will also be no inter-VLAN routing between a switch0.x VLAN network and the primary switch0 network.

 

Hope that helps!

 

-Ben


Ben Pin - EdgeMAX Support

Veteran Member
Posts: 7,221
Registered: ‎03-24-2016
Kudos: 1859
Solutions: 821

Re: PVID blank vs PVID 1 if VLAN aware set.

@UBNT-benpinwrote:

Because switch0 is not associated with any VLAN tag, there will also be no inter-VLAN routing between 
a switch0.x VLAN interface and the primary switch0.

 

Indeed true routing doesn't work  ,  but this really doesn't explain why it doesn't

If  interfaces have a working layer3 address on the router, routing between those interfaces should work

Reply