Reply
New Member
Posts: 5
Registered: ‎07-02-2016
Solutions: 1
Accepted Solution

Port forwarding for Amcrest camera

I have several Amcrest cameras on my network, and need to open up a port so one of them can be accessed over the internet. 

 

I want to have outside port 48107 forward to this particular camera at 172.16.0.31:80.

 

I've set up a rule in the firewall to allow 48107 to local, and added a source/destination NAT as well. The Destination NAT rule is as follows:

 

Screen Shot 2018-01-20 at 1.47.16 PM.png

 

After testing externally, I can see the packet count increase on the Destination NAT rule, but no count in crease on the Source NAT rule and the video obviously fails to load. 

 

What am I missing?

 

Screen Shot 2018-01-20 at 1.54.18 PM.pngScreen Shot 2018-01-20 at 1.54.59 PM.png


Accepted Solutions
Highlighted
New Member
Posts: 5
Registered: ‎07-02-2016
Solutions: 1

Re: Port forwarding for Amcrest camera

I appreciate everyone's help. After setting up the inbound firewall rule and NAT destination rule, I read the camera manual which stated that RTSP (554) also needed to be forwarded. After adding both ports, it works great. 

View solution in original post


All Replies
SuperUser
Posts: 7,072
Registered: ‎01-05-2012
Kudos: 1862
Solutions: 925

Re: Port forwarding for Amcrest camera

The masquerade rule 2, should have dest. port 80, the rule 3 in the WAN_IN must have dest. port 80 as well (note that the masquerade rule 2 matters only if you try to connect from inside, to your public.ip/fqdn:48107).

Cheers,

jonatha

New Member
Posts: 5
Registered: ‎07-02-2016
Solutions: 1

Re: Port forwarding for Amcrest camera

Thank you for the quick reply. I've attempted your suggestions and don't even see the count increase any longer for Destination NAT.
Ubiquiti Employee
Posts: 1,799
Registered: ‎05-08-2017
Kudos: 349
Solutions: 287

Re: Port forwarding for Amcrest camera

[ Edited ]

You do not need a source NAT rule if you are only forwarding ports. The firewall rule needs to be added in the inbound direction (WAN_IN) and needs to allow the port that you translating to, which is 80 in this case. This is because the NAT translation happens before the traffic hits the firewall.

 

Ben


Ben Pin - EdgeMAX Support

SuperUser
Posts: 7,072
Registered: ‎01-05-2012
Kudos: 1862
Solutions: 925

Re: Port forwarding for Amcrest camera

If you need hairpin nat, the masquerade rule 2 should be set on your lan interface, not the wan.

Cheers,

jonatha

Highlighted
New Member
Posts: 5
Registered: ‎07-02-2016
Solutions: 1

Re: Port forwarding for Amcrest camera

I appreciate everyone's help. After setting up the inbound firewall rule and NAT destination rule, I read the camera manual which stated that RTSP (554) also needed to be forwarded. After adding both ports, it works great. 

Reply