Emerging Member
Posts: 44
Registered: ‎06-19-2014
Kudos: 10

Possible bug: GUI PPPoE username

I had set up an EdgeRouter lite with dual WAN (one PPPoE on eth2, one DHCP on eth1, LAN on eth0), and it was working. However, I then decided to change the PPPoE username in the GUI. But once I did so, the EdgeRouter decided to just stop functioning, and wouldn't respond to ping at all on the LAN.

I did also try to set the interfaces up with IP addresses to access the modems in front of the router; I have no idea if that's relevant. Though the router itself could ping them, PC's behind the router could not, but that's another issue.

I'm still waiting on a compatible console cable, so I can't see the current configuration right now, but this is the most recent:

firewall {
    all-ping enable
    broadcast-ping disable
    ipv6-receive-redirects disable
    ipv6-src-route disable
    ip-src-route disable
    log-martians enable
    modify balance {
        rule 1 {
            action modify
            destination {
                port 80,443
            }
            modify {
                lb-group cable
            }
            protocol tcp
        }
        rule 2 {
            action modify
            modify {
                lb-group wan
            }
        }
    }
    name wan_in {
        default-action drop
        description "WAN to LAN"
        rule 1 {
            action accept
            state {
                established enable
                related enable
            }
        }
    }
    name wan_local {
        default-action drop
        description "WAN to router"
        rule 1 {
            action accept
            state {
                established enable
                related enable
            }
        }
        rule 2 {
            action accept
            destination {
                port 1194
            }
            protocol udp
        }
    }
    options {
        mss-clamp {
            mss 1412
        }
    }
    receive-redirects disable
    send-redirects enable
    source-validation disable
    syn-cookies enable
}
interfaces {
    ethernet eth0 {
        address 10.0.0.1/24
        description LAN
        duplex auto
        firewall {
            in {
                modify balance
            }
        }
        speed auto
    }
    ethernet eth1 {
        address dhcp
        duplex auto
        firewall {
            in {
                name wan_in
            }
            local {
                name wan_local
            }
        }
        speed auto
    }
    ethernet eth2 {
        address 10.66.66.2/24
        duplex auto
        pppoe 0 {
            default-route auto
            firewall {
                in {
                    name wan_in
                }
                local {
                    name wan_local
                }
            }
            mtu 1454
            name-server auto
            password [password]
            user-id [username]
        }
        speed auto
    }
    loopback lo {
    }
    openvpn vtun0 {
        encryption aes128
        local-address 10.255.255.10 {
        }
        mode site-to-site
        openvpn-option --comp-lzo
        protocol udp
        remote-address 10.255.255.11
        tls {
            ca-cert-file /config/auth/openvpn/ca.crt
            cert-file /config/auth/openvpn/server.crt
            dh-file /config/auth/openvpn/dh1024.pem
            key-file /config/auth/openvpn/server.key
            role passive
        }
    }
    pseudo-ethernet peth0 {
        address 192.168.100.2/24
        link eth1
    }
}
load-balance {
    group cable {
        interface eth1 {
        }
        interface pppoe0 {
            failover-only
        }
    }
    group wan {
        interface eth1 {
        }
        interface pppoe0 {
        }
    }
}
port-forward {
    auto-firewall enable
    hairpin-nat enable
    lan-interface eth0
    wan-interface eth1
}
protocols {
    static {
    }
}
service {
    dhcp-server {
        disabled false
        hostfile-update disable
        shared-network-name LAN {
            authoritative disable
            subnet 10.0.0.0/24 {
                default-router 10.0.0.1
                dns-server 10.0.0.6
                lease 86400
                start 10.0.0.10 {
                    stop 10.0.0.254
                }
                static-mapping Duck {
                    ip-address 10.0.0.100
                    mac-address 1C:6F:65:CD:89:B9
                }
                static-mapping EA-N66 {
                    ip-address 10.0.0.4
                    mac-address 10:BF:48:FC:19:44
                }
                static-mapping HL-3040CN {
                    ip-address 10.0.0.8
                    mac-address 00:1B:A9:83:6B:CC
                }
                static-mapping Horize {
                    ip-address 10.0.0.200
                    mac-address 00:90:F5:EE:2F:1F
                }
                static-mapping MP560 {
                    ip-address 10.0.0.9
                    mac-address 00:1E:8F:3B:32:AC
                }
            }
        }
    }
    dns {
        forwarding {
            cache-size 150
            listen-on eth0
        }
    }
    gui {
        https-port 443
    }
    nat {
        rule 5000 {
            outbound-interface eth1
            protocol all
            type masquerade
        }
        rule 5001 {
            outbound-interface eth2
            protocol all
            type masquerade
        }
        rule 5002 {
            outbound-interface pppoe0
            protocol all
            type masquerade
        }
        rule 5003 {
            outbound-interface peth0
            type masquerade
        }
    }
    ssh {
        port 22
        protocol-version v2
    }
    upnp {
        listen-on eth0 {
            outbound-interface eth1
        }
    }
}
system {
    host-name EdgeRouter
    login {
        user ubnt {
            authentication {
                encrypted-password $1$zKNoUbAo$gomzUbYvgyUMcD436Wo66.
            }
            level admin
        }
    }
    ntp {
        server time.iinet.net.au {
        }
    }
    offload {
        ipsec enable
        ipv4 {
            forwarding enable
        }
        ipv6 {
            forwarding disable
        }
    }
    syslog {
        global {
            facility all {
                level notice
            }
            facility protocols {
                level debug
            }
        }
    }
    time-zone Australia/Melbourne
}


/* Warning: Do not remove the following line. */
/* === vyatta-config-version: "config-management@1:conntrack@1:cron@1:dhcp-relay@1:dhcp-server@4:firewall@5:ipsec@3:nat@3:qos@1:quagga@2:system@4:ubnt-pptp@1:ubnt-util@1:vrrp@1:webgui@1:webproxy@1:zone-policy@1" === */
/* Release version: v1.5.0.4677648.140620.1301 */

 

Previous Employee
Posts: 13,551
Registered: ‎06-10-2011
Kudos: 5474
Solutions: 1656
Contributions: 2

Re: Possible bug: GUI PPPoE username

Can't really see anything from the config that could've caused the router to stop responding on the LAN after chaning only the PPPoE username on the WAN. Seeing the current config on the console should provide more information of course.