Reply
Highlighted
Regular Member
Posts: 454
Registered: ‎12-17-2015
Kudos: 161
Solutions: 8
Accepted Solution

SOLVED: Cloudflare DDNS 1.9.0

[ Edited ]

 All,

 

I'm attemping to configure Cloudflare DDNS on 1.9.0, and I guess I'm missing how you do this. Any hints? 

USG, UniFi AP AC Pro, 2x UniFi US-8-150W, Unifi US-8, UCK-G2-Plus, UVC-G3, UVC-G3-Flex

Accepted Solutions
Regular Member
Posts: 454
Registered: ‎12-17-2015
Kudos: 161
Solutions: 8

Re: Cloudflare DDNS 1.9.0

Got it thanks to some help from the beta forum.

 

You have to do:

 

set service dns dynamic interface eth5 service custom-cloudflare host-name www.yoursite.com
set service dns dynamic interface eth5 service custom-cloudflare login your_cloudflare_email
set service dns dynamic interface eth5 service custom-cloudflare password your_cloudflare_global_API_key
set service dns dynamic interface eth5 service custom-cloudflare protocol cloudflare
set service dns dynamic interface eth5 service custom-cloudflare server www.cloudflare.com
set service dns dynamic interface eth5 service custom-cloudflare options "zone=yoursite.com"

That got it all working. Took a little bit for it to update, but it finally, and I see:

 

admin@ubnt:/var/cache/ddclient$ show dns dynamic status

interface    : eth5

ip address   : xxx.xxx.xxx.xxx

host-name    : home.domain.com

last update  : Mon Aug  8 22:10:23 2016

update-status: good

 

Really need to add the "cloudflare" protocol option to the GUI, as well as the "options" or "zone" if that is selected! =)

 

Thanks! 

USG, UniFi AP AC Pro, 2x UniFi US-8-150W, Unifi US-8, UCK-G2-Plus, UVC-G3, UVC-G3-Flex

View solution in original post


All Replies
Regular Member
Posts: 454
Registered: ‎12-17-2015
Kudos: 161
Solutions: 8

Re: Cloudflare DDNS 1.9.0

Guessing this (blank IP address) is part of the issue:

 

admin@ubnt:/var/cache/ddclient$ show dns dynamic status

interface    : eth5

ip address   :

host-name    : home.domain.tld

last update  : Wed Dec 31 16:00:00 1969

update-status: noconnect

USG, UniFi AP AC Pro, 2x UniFi US-8-150W, Unifi US-8, UCK-G2-Plus, UVC-G3, UVC-G3-Flex
Regular Member
Posts: 454
Registered: ‎12-17-2015
Kudos: 161
Solutions: 8

Re: Cloudflare DDNS 1.9.0

Got it thanks to some help from the beta forum.

 

You have to do:

 

set service dns dynamic interface eth5 service custom-cloudflare host-name www.yoursite.com
set service dns dynamic interface eth5 service custom-cloudflare login your_cloudflare_email
set service dns dynamic interface eth5 service custom-cloudflare password your_cloudflare_global_API_key
set service dns dynamic interface eth5 service custom-cloudflare protocol cloudflare
set service dns dynamic interface eth5 service custom-cloudflare server www.cloudflare.com
set service dns dynamic interface eth5 service custom-cloudflare options "zone=yoursite.com"

That got it all working. Took a little bit for it to update, but it finally, and I see:

 

admin@ubnt:/var/cache/ddclient$ show dns dynamic status

interface    : eth5

ip address   : xxx.xxx.xxx.xxx

host-name    : home.domain.com

last update  : Mon Aug  8 22:10:23 2016

update-status: good

 

Really need to add the "cloudflare" protocol option to the GUI, as well as the "options" or "zone" if that is selected! =)

 

Thanks! 

USG, UniFi AP AC Pro, 2x UniFi US-8-150W, Unifi US-8, UCK-G2-Plus, UVC-G3, UVC-G3-Flex
Member
Posts: 182
Registered: ‎09-18-2012
Kudos: 87
Solutions: 3

Re: SOLVED: Cloudflare DDNS 1.9.0

[ Edited ]

 

I had some issues as well, but figured out that we cannot use api.cloudflare.com as well as... for some reason I needed to regenerate my global API key before this would work.

Regular Member
Posts: 454
Registered: ‎12-17-2015
Kudos: 161
Solutions: 8

Re: SOLVED: Cloudflare DDNS 1.9.0

Hi storrgie,

 

Is eth0 the proper interface? the fact it says "noconnect" seems odd... 

USG, UniFi AP AC Pro, 2x UniFi US-8-150W, Unifi US-8, UCK-G2-Plus, UVC-G3, UVC-G3-Flex
New Member
Posts: 12
Registered: ‎08-07-2018
Kudos: 2
Solutions: 1

Re: Cloudflare DDNS 1.9.0

There is now an updated source:

https://help.ubnt.com/hc/en-us/articles/204976324-EdgeMAX-Custom-Dynamic-DNS-with-Cloudflare

 

For anyone like me who kept getting noconnect errors by following staze's instructions on 1.10.5 or later, I got it to work by deleting the server field.

New Member
Posts: 26
Registered: ‎09-07-2015
Solutions: 1

Re: Cloudflare DDNS 1.9.0

I am getting noconnect with the following:

 interface eth3 {
     service custom-cloudflare {
         host-name mctest.xxxxxxxxxxxxx
         login adrian@xxxxxxxxxxxxx
         options zone=xxxxx.com
         password xxxxxxxxxx
         protocol cloudflare
     }

status:

interface    : eth3
ip address   :
host-name    : mctest.xxxxxxxxxxx
last update  : Thu Jan  1 00:00:00 1970
update-status: noconnect

I dont have the sever field

Reply