New Member
Posts: 6
Registered: ‎05-05-2017
Accepted Solution

Setting up wake-on-lan on a simple home network?

My goal is to wake up a PC with the Plex server by use of any Plex client (local).

 

But being completely new to EdgeOS (Edgemax X) and CLI based router setup I'm not able to get any of the tips I find to work.

 

The server pc has a static IP (with plex port forwarding) and all clients are on the same network. I'm also able to wake up the pc with the command etherwake (router) and mc-wol (pc), but not from the Plex clients. Do I need a script running? Somebody able to give a noob description of what's needed?


Accepted Solutions
Emerging Member
Posts: 53
Registered: ‎11-06-2017
Kudos: 6
Solutions: 3

Re: Setting up wake-on-lan on a simple home network?

You shouldn't need to do anything special on the router since your pcs are local. I am going to assume you are using windows, here are some tips for WOL:

1. Make sure WOL is enabled in your bios settings

 

2. In windows on your NIC settings: Turn off any "Energy efficient ethernet"( wording could be different on yours. Eneble any settings for WOL. Under Power management, enable all WOL settings, even the one you mentioned was unchecked.

 

3. In windows control panel>Hardware and Sound>Power Options>Change Plan Settings>Change Advanced Power Settings: Find PCI Settings>Link State Power Management---->Turn that off

 

4. IN control panel find "Change what the power buttons do, uncheck "Turn on fast startup"

 

5. Restart computer

 

These should get WOL working in windows. Now when you turn off your pc, the light on your NIC will continue to blink. Hope this helps

View solution in original post


All Replies
New Member
Posts: 6
Registered: ‎05-05-2017

Re: Setting up wake-on-lan on a simple home network?

 

It works (I'm able to wake the PC) if I unchecked "Only allow magic packet to wake computer". So maybe I just have to hope that Plex implements magic packets.

Emerging Member
Posts: 53
Registered: ‎11-06-2017
Kudos: 6
Solutions: 3

Re: Setting up wake-on-lan on a simple home network?

You shouldn't need to do anything special on the router since your pcs are local. I am going to assume you are using windows, here are some tips for WOL:

1. Make sure WOL is enabled in your bios settings

 

2. In windows on your NIC settings: Turn off any "Energy efficient ethernet"( wording could be different on yours. Eneble any settings for WOL. Under Power management, enable all WOL settings, even the one you mentioned was unchecked.

 

3. In windows control panel>Hardware and Sound>Power Options>Change Plan Settings>Change Advanced Power Settings: Find PCI Settings>Link State Power Management---->Turn that off

 

4. IN control panel find "Change what the power buttons do, uncheck "Turn on fast startup"

 

5. Restart computer

 

These should get WOL working in windows. Now when you turn off your pc, the light on your NIC will continue to blink. Hope this helps

Established Member
Posts: 1,917
Registered: ‎03-02-2016
Kudos: 472
Solutions: 150

Re: Setting up wake-on-lan on a simple home network?

You also often need to turn on WOL in the BIOS.
New Member
Posts: 6
Registered: ‎05-05-2017

Re: Setting up wake-on-lan on a simple home network?

 

Thanks for the help!

 

I'm able to get it to wake up as long as I don’t check "Only allow a magic packet to wake the computer" in the Power management on the Network card. But with that unchecked I'm told to believe that "any chatter" on the network will wake it up hence it will almost never get any sleep.

 

Emerging Member
Posts: 54
Registered: ‎02-02-2018
Kudos: 15
Solutions: 2

Re: Setting up wake-on-lan on a simple home network?

What NIC is it? Some NICs behave differently, so providing the model might help...

New Member
Posts: 6
Registered: ‎05-05-2017

Re: Setting up wake-on-lan on a simple home network?

 

It is an integrated controller on a Asus Z87M-plus motherboard. Windows names it is Realtek PCIe GBE controller.

Established Member
Posts: 1,917
Registered: ‎03-02-2016
Kudos: 472
Solutions: 150

Re: Setting up wake-on-lan on a simple home network?

I'm not really sure how you're trying to wake the PC, but once you enable WoL in the BIOS and make the changes mentioned upthread, you should be able to log in to the router and do

sudo etherwake <PC MAC address>
New Member
Posts: 6
Registered: ‎05-05-2017

Re: Setting up wake-on-lan on a simple home network?

I'm trying to get Plex clients to wake it up. It works with "Only allow a magic packet to wake the computer" unchecked, but I afraid that also means that it wakes up of other random networks chatter.

 

sudo etherwake <mac> from the router works fine, but don’t want to log into the router from the couch ready to watch TV.

Established Member
Posts: 1,917
Registered: ‎03-02-2016
Kudos: 472
Solutions: 150

Re: Setting up wake-on-lan on a simple home network?

OK, I'm confused. Have you asked on the Plex forum? What does this all have to do with the EdgeRouter platform?

Emerging Member
Posts: 53
Registered: ‎11-06-2017
Kudos: 6
Solutions: 3

Re: Setting up wake-on-lan on a simple home network?

I’m not exactly sure what you want to do now either. I thought we were talking about WOL. Seems to me you want to turn on the plex client, which in turn automatically sends out a magic packet to the server to wake it up? Yeah this has nothing to do with the edgerouter as I said earlier. Get a wol app on your phone or try a plex forum. I was just trying to help you with settings so it could wake up, sorry I can’t help further.

Highlighted
New Member
Posts: 6
Registered: ‎05-05-2017

Re: Setting up wake-on-lan on a simple home network?

Thanks for the help!

 

Your right it is more a Plex problem. Hopefully they implement "magic package" as Kodi has to wake up the media server. I searched the Plex forum and found a script for dd-wrt that I believe listen to the Plex post specifically and then sent a "magic package" to the server (from the router). Hence filtering out some traffic that could unnecessary  wake up the server.  

 

The reason I posted here and not in the Plex forum was due to knowledge about the EdgeOS and scripting. I hoped that someone had a similar ore better fix for this small problem. Sorry for not being clear.

 

Again, thanks for the effort