Reply
Highlighted
New Member
Posts: 4
Registered: ‎05-21-2013
Kudos: 2

disable-link-detect does not work properly

The ethernet link detection works even if disable-link-detection option has been enabled

adik@rt-msk20:~$ show version
Version:      v1.5.0
Build ID:     4677648
Build on:     06/20/14 13:01
Copyright:    2012-2014 Ubiquiti Networks, Inc.
HW model:     EdgeRouter Lite 3-Port
HW S/N:       XXXXXXXXXX
Uptime:       10:05:56 up 6 min,  1 user,  load average: 0.18, 0.38, 0.22

adik@rt-msk20:~$ sudo vtysh -c 'show running-config' |grep -A3 eth0
interface eth0
 ipv6 nd suppress-ra
 link-detect
!

adik@rt-msk20:~$ configure

adik@rt-msk20# set interfaces ethernet eth0 disable-link-detect

adik@rt-msk20# commit

adik@rt-msk20# sudo vtysh -c 'show running-config' |grep -A3 eth0
interface eth0
 ipv6 nd suppress-ra
 link-detect
!

adik@rt-msk20# delete interfaces ethernet eth0 disable-link-detect

adik@rt-msk20# commit

adik@rt-msk20# sudo vtysh -c 'show running-config' |grep -A3 eth0
interface eth0
 ipv6 nd suppress-ra
!

 

The problem was solved when I replaced update and delete actions

--- /opt/vyatta/share/vyatta-cfg/templates/interfaces/ethernet/node.tag/disable-link-detect/node.def~
+++ /opt/vyatta/share/vyatta-cfg/templates/interfaces/ethernet/node.tag/disable-link-detect/node.def
@@ -1,3 +1,3 @@
 help: Ignore link state changes
-update:/opt/vyatta/sbin/vyatta-link-detect $VAR(../@) on
-delete:/opt/vyatta/sbin/vyatta-link-detect $VAR(../@) off
+update:/opt/vyatta/sbin/vyatta-link-detect $VAR(../@) off
+delete:/opt/vyatta/sbin/vyatta-link-detect $VAR(../@) on
Previous Employee
Posts: 13,551
Registered: ‎06-10-2011
Kudos: 5465
Solutions: 1656
Contributions: 2

Re: disable-link-detect does not work properly

Good catch, that looks like an "inherited" bug that's been there for years! Thanks for your contributions!

Reply