Reply
New Member
Posts: 27
Registered: ‎06-05-2016
Kudos: 4
Solutions: 1
Accepted Solution

set system conntrack modules rtsp disable not working

Dear,

 

I get the following error:

 

set system conntrack modules rtsp disable
The specified configuration node is not valid
Set failed

I could disable the other conntrack modules except for this one. Please advise.


Accepted Solutions
New Member
Posts: 27
Registered: ‎06-05-2016
Kudos: 4
Solutions: 1

Re: set system conntrack modules rtsp disable not working

Nothing to delete (the specified node does not exist)
[edit]

After testing out some more it appears the rtsp conntrack module isnt loaded by the kernel by default unlike the other conntrack modules. So my goal is accomplished by just "delete system conntrack modules rtsp".

However the command "set system conntrack modules rtsp disable" giving an error should be flagged as a bug

View solution in original post


All Replies
SuperUser
Posts: 8,233
Registered: ‎01-05-2012
Kudos: 2182
Solutions: 1088

Re: set system conntrack modules rtsp disable not working

Try

delete system conntrack modules rtsp enable

Cheers,

jonatha

New Member
Posts: 27
Registered: ‎06-05-2016
Kudos: 4
Solutions: 1

Re: set system conntrack modules rtsp disable not working

Nothing to delete (the specified node does not exist)
[edit]

After testing out some more it appears the rtsp conntrack module isnt loaded by the kernel by default unlike the other conntrack modules. So my goal is accomplished by just "delete system conntrack modules rtsp".

However the command "set system conntrack modules rtsp disable" giving an error should be flagged as a bug
SuperUser
Posts: 8,233
Registered: ‎01-05-2012
Kudos: 2182
Solutions: 1088

Re: set system conntrack modules rtsp disable not working

By default is disabled, what error do you see ?

ubnt@ubnt# sudo lsmod
Module                  Size  Used by
xt_TCPMSS               3295  0
xt_set                  5378  5
ipt_MASQUERADE          1378  3

 

ubnt@ubnt# set system conntrack modules rtsp enable
[edit]
ubnt@ubnt# commit
[edit]
ubnt@ubnt# lsmod
Module                  Size  Used by
nf_nat_rtsp             4818  0
nf_conntrack_rtsp       5417  1 nf_nat_rtsp
xt_TCPMSS               3295  0
xt_set                  5378  5
ipt_MASQUERADE          1378  3
ubnt@ubnt# delete system conntrack modules rtsp enable
[edit]
ubnt@ubnt# commit
[edit]
ubnt@ubnt# lsmod
Module Size Used by
xt_TCPMSS 3295 0
xt_set 5378 5
ipt_MASQUERADE 1378 3

Cheers,

jonatha

Veteran Member
Posts: 7,642
Registered: ‎03-24-2016
Kudos: 1985
Solutions: 876

Re: set system conntrack modules rtsp disable not working

Use these commands to enable/disable rtsp conntrack module:

set system conntrack modules rtsp enable
delete system conntrack modules rtsp

Indeed counter-intuitive

 

New Member
Posts: 27
Registered: ‎06-05-2016
Kudos: 4
Solutions: 1

Re: set system conntrack modules rtsp disable not working

[ Edited ]

@redfive wrote:

By default is disabled, what error do you see ?

ubnt@ubnt# sudo lsmod
Module                  Size  Used by
xt_TCPMSS               3295  0
xt_set                  5378  5
ipt_MASQUERADE          1378  3

 

ubnt@ubnt# set system conntrack modules rtsp enable
[edit]
ubnt@ubnt# commit
[edit]
ubnt@ubnt# lsmod
Module                  Size  Used by
nf_nat_rtsp             4818  0
nf_conntrack_rtsp       5417  1 nf_nat_rtsp
xt_TCPMSS               3295  0
xt_set                  5378  5
ipt_MASQUERADE          1378  3
ubnt@ubnt# delete system conntrack modules rtsp enable
[edit]
ubnt@ubnt# commit
[edit]
ubnt@ubnt# lsmod
Module Size Used by
xt_TCPMSS 3295 0
xt_set 5378 5
ipt_MASQUERADE 1378 3

Cheers,

jonatha



Please try running set system conntrack modules rtsp disable. This gives an error while it should just set the rtsp module to disable or at least give a proper output

Reply