Reply
Ubiquiti Employee
Posts: 2,654
Registered: ‎12-10-2015
Kudos: 956
Solutions: 223

New UCRM version 2.10.0-beta1 released!

[ Edited ]

Great news! UCRM version 2.10.0-beta1 with many new features and extensions is ready for you.

 

The most interesting extensions for many users could be Plugins and Webhooks. This allows you to extend UCRM features and more importantly to contribute to the plugins which are commonly used. Soon, we will give you more guides and examples. Follow the UCRM forum.

 

Use the in-app upgrade tool to switch to the new version and try out many new features like Data usage report, ACH payments, new Ticketing, improved suspension feature with redirection to the payment page and much more.

 

Feature requests

please add new one or upvote an existing one in  UCRM Feature Requests

 

Changelog 2.10.0-beta1 (2018-02-14)

Added

  • Plugins - plugins are open source modules which can be uploaded into UCRM. Check out the Plugins repository.
  • Webhooks - configurable URL endpoints which will be automatically triggered in case of actions related to invoicing (such as a new invoice or new payment created). Additionally, you can set any plugin (its public URL) as the webhook endpoint.
  • Canned responses for Ticketing.
  • Automatic remote backups for UCRM backup files (sync with Dropbox).
  • New improved wizard and users onboarding for the first run.
  • UX Improvements (SSL certificate near expiration date notification, creating a service plan while adding a client's service, etc.)
  • New option for FCC reporting: use the GPS coordinates of the client's service as the primary source for FCC Census geocoder (instead of the address). Additionally, you can check, set or change the FCC Block ID manually for each client's service.
  • More placeholders are now available in customizable notifications and bulk email tool.
  • API enhancements: invoice email can be sent via API and the invoice emailSentDate attribute can be set or changed.
  • Improved notifications in case of FCC Geocoder service outage.

Changed

  • After tickets or ticket comments are imported to UCRM, they are automatically marked as read in the source IMAP inbox.
  • Improved outgoing email format, the plain text version is attached to the email to prevent it from being marked as spam.

 

Try it out and let us know what you think. Your opinion is important to us!

New Member
Posts: 21
Registered: ‎11-20-2014
Kudos: 2

Re: New UCRM version 2.10.0-beta1 released!

- error on upgrade

 

CONTAINER ID IMAGE COMMAND CREATED STATUS PORTS NAMES
59226477c64b ubnt/ucrm-billing:2.10.0-beta1 "make crm_netflow" 58 seconds ago Restarting (2) 2 seconds ago ucrm_web_app_1
3463243db55a postgres:9.5 "docker-entrypoint..." About a minute ago Up 58 seconds 5432/tcp ucrm_postgresql_1
3ee64e8e9cd6 rabbitmq:3 "docker-entrypoint..." About a minute ago Up 58 seconds 4369/tcp, 5671-5672/tcp, 25672/tcp ucrm_rabbitmq_1
62d437ab86aa elasticsearch:2 "/docker-entrypoin..." About a minute ago Up 58 seconds 9200/tcp, 9300/tcp ucrm_elastic_1

 

==========

 

root@ucrm:/home/ucrm# docker logs 59226477c64b
make: *** No rule to make target 'crm_netflow'. Stop.
make: *** No rule to make target 'crm_netflow'. Stop.
make: *** No rule to make target 'crm_netflow'. Stop.
make: *** No rule to make target 'crm_netflow'. Stop.

Emerging Member
Posts: 60
Registered: ‎09-27-2013
Kudos: 51
Solutions: 3

Re: New UCRM version 2.10.0-beta1 released!

upgrade went well - with the usual adrenaline kick ...

Ubiquiti Employee
Posts: 877
Registered: ‎03-21-2016
Kudos: 143
Solutions: 111

Re: New UCRM version 2.10.0-beta1 released!

Hello @sell, it seems you have out of date docker-compose.yml. Could you please post the contents of it? You can find it in /home/ucrm.

Also how did you update your UCRM? Did you use in-app update or manual update script?

New Member
Posts: 21
Registered: ‎11-20-2014
Kudos: 2

Re: New UCRM version 2.10.0-beta1 released!

- i did upgrade from 2.10.0-dev ...

- i got error, i reinstall and now when i try to put the backup : backup_database.1518609610.2.10.0-dev.tar, is saying is wrong version ... to install the same or older version ... 

- how can i reinstall my backup ? probably is because at last update was that error between 2.10.0-dev and 2.9.0-beta3

New Member
Posts: 21
Registered: ‎11-20-2014
Kudos: 2

Re: New UCRM version 2.10.0-beta1 released!

- i did upgrade from web, but i got error and i deleted and did clean reinstall

- now i just try to put backup back

 

root@ucrm:/home/ucrm# cat docker-compose.yml
version: '2'

services:
postgresql:
image: postgres:9.5
restart: always
env_file: docker-compose.env
volumes:
- ./data/postgres:/var/lib/postgresql/data
logging:
driver: "json-file"
options:
max-size: "10m"
max-file: "3"

web_app:
image: ubnt/ucrm-billing:2.9.0-beta3
restart: always
env_file: docker-compose.env
links:
- postgresqlMan Tongueostgresql
- elastic:elastic
- rabbitmq:rabbitmq
volumes:
- ./data/ucrm:/data
ports:
- 8080:80
- 8081:81
- 8443:443
- 2055:2055/udp
command: "server"
logging:
driver: "json-file"
options:
max-size: "10m"
max-file: "3"

elastic:
image: elasticsearch:2
restart: always
volumes:
- ./data/elasticsearch:/usr/share/elasticsearch/data
logging:
driver: "json-file"
options:
max-size: "10m"
max-file: "3"

rabbitmq:
image: rabbitmq:3
restart: always
volumes:
- ./data/rabbitmq:/var/lib/rabbitmq
logging:
driver: "json-file"
options:
max-size: "10m"
max-file: "3"
root@ucrm:/home/ucrm#

Ubiquiti Employee
Posts: 877
Registered: ‎03-21-2016
Kudos: 143
Solutions: 111

Re: New UCRM version 2.10.0-beta1 released!

@sell The errors is there because your instance is trying to run "crm_netflow" container which does not exist since UCRM 2.8.0. That means, that your docker-compose.yml file did not get updated as it should have.

Please try running the update manually using this guide https://help.ubnt.com/hc/en-us/articles/115002834888-UCRM-Beta-Update-Guide

 

Basically run the following command:

 

cd /home/ucrm
curl -fsSL https://raw.githubusercontent.com/Ubiquiti-App/UCRM/master/update.sh | sudo bash -s -- 2.10.0-beta1 | sudo tee update.log

You should see the message "Your docker-compose contains obsolete section crm_netflow_app. Trying to remove." during the update process. If you don't, please send the contents of your docker-compose.yml file here and we'll take a look into fixing this.

 

Ad the backup, you cannot restore this without manual change in the contents of the archive. Basically you need to rename the backup file, so that it has "2.9.0-beta3" in the name instead of "2.10.0-dev" and you need to change the contents of "version" text file within the backup archive to contain the same (2.9.0-beta3). Basically extract the archive, change the version file, archive again and rename. If you send me the backup I can do this for you and send it back.

 

Ubiquiti Employee
Posts: 877
Registered: ‎03-21-2016
Kudos: 143
Solutions: 111

Re: New UCRM version 2.10.0-beta1 released!

@sell Sorry, did not see the second post. In this case, you will have to change the backup archive as I said.

Member
Posts: 176
Registered: ‎04-26-2013
Kudos: 67
Solutions: 3

Re: New UCRM version 2.10.0-beta1 released!

Update using Web interface - ALL good

/Simon
New Member
Posts: 21
Registered: ‎11-20-2014
Kudos: 2

Re: New UCRM version 2.10.0-beta1 released!

- i did archive modification, i did upload, is making i think install, and when finish is sending me back to wizard instalation .. like is clean install

 

CONTAINER ID IMAGE COMMAND CREATED STATUS PORTS NAMES
bf28468e3498 ubnt/ucrm-billing:2.10.0-beta1 "make server" 29 minutes ago Up 29 minutes 0.0.0.0:2055->2055/udp, 9000/tcp, 0.0.0.0:8080->80/tcp, 0.0.0.0:8081->81/tcp, 0.0.0.0:8443->443/tcp ucrm_web_app_1
5cefa2ffa7f4 elasticsearch:2 "/docker-entrypoin..." 29 minutes ago Up 29 minutes 9200/tcp, 9300/tcp ucrm_elastic_1
afdb12f808ca rabbitmq:3 "docker-entrypoint..." 29 minutes ago Up 29 minutes 4369/tcp, 5671-5672/tcp, 25672/tcp ucrm_rabbitmq_1
6b205c0cca1b postgres:9.5 "docker-entrypoint..." 30 minutes ago Up 30 minutes 5432/tcp ucrm_postgresql_1

 

Getting started with UCRM
  • 1 Account
  •  
  • 2 Organization
  •  
     
  • 3 Mailer
  •  
  • 4 Finishing
I have backup
Browse
Restore
 
Create Account
Username
 
Password
show
Email
 
Full name
Established Member
Posts: 992
Registered: ‎04-30-2009
Kudos: 166
Solutions: 4

Re: New UCRM version 2.10.0-beta1 released!

How long before the quickbooks plugin is available?

New Member
Posts: 21
Registered: ‎11-20-2014
Kudos: 2

Re: New UCRM version 2.10.0-beta1 released!

Solved my problem, thx Ondra, best support.

New Member
Posts: 4
Registered: ‎03-15-2014
Kudos: 1

Re: New UCRM version 2.10.0-beta1 released!

Upgraded from web interface and is working fine, just one problem; The logo do not show in login pages and in the invoice pdf, there is some issue about this?

Ubiquiti Employee
Posts: 2,654
Registered: ‎12-10-2015
Kudos: 956
Solutions: 223

Re: New UCRM version 2.10.0-beta1 released!

@popcorrin - You can try out the QB plugin: https://github.com/Ubiquiti-App/UCRM-plugins

@SkyAccess - We will check this issue. What was your previous version?
New Member
Posts: 16
Registered: ‎09-03-2011

Re: New UCRM version 2.10.0-beta1 released!

Hi,

update not working:

Setting UPDATE_TO_VERSION=2.10.0-beta1
Setting CRON=true
Skipping auto-update permissions setup.
Backing up docker compose files.
Pulling rabbitmq (rabbitmq:3)...
3: Pulling from library/rabbitmq
error pulling image configuration: Get https://dseasb33srnrn.cloudfront.net/registry-v2/docker/registry/v2/blobs/sha256/02/02c3edbcf3d1d965...: dial tcp: lookup dseasb33srnrn.cloudfront.net on XXX.XXX.XXX.XXX:53: read udp XXX.XXX.XXX.XX:35558->XXX.XXX.XXX.XXX:53: i/o timeout
Image for version "2.10.0-beta1" not found.
Reverting docker compose files.
Sun Feb 18 20:04:19 EET 2018 --- Update failed.

Ubiquiti Employee
Posts: 2,654
Registered: ‎12-10-2015
Kudos: 956
Solutions: 223

Re: New UCRM version 2.10.0-beta1 released!

@aronokia this looks like a temporary outage of the Docker hub. Try the update again.
Regular Member
Posts: 648
Registered: ‎03-08-2014
Kudos: 201
Solutions: 22

Re: New UCRM version 2.10.0-beta1 released!

[ Edited ]

When we try to add a canned response we get an internal server error. The response is plain text with one URL in it. Could it be that there is no URL allowed?

Internal server error.

New Member
Posts: 16
Registered: ‎09-03-2011

Re: New UCRM version 2.10.0-beta1 released!

Today same error

Regular Member
Posts: 648
Registered: ‎03-08-2014
Kudos: 201
Solutions: 22

Re: New UCRM version 2.10.0-beta1 released!

@UBNT-Petr I have just noticed that it is a character count error. When the canned response is longer, I receive an error. A short canned response works always. The number of characters really needs to be higher.

Senior Member
Posts: 2,946
Registered: ‎07-28-2009
Kudos: 803
Solutions: 40

Re: New UCRM version 2.10.0-beta1 released!

[ Edited ]

@UBNT-Petr I too get the same error on setting up a canned response.  The response I was adding is below and I do not think it is too long that is should not be allowed.

 

The below gave server error when trying to add:

 

Thank you for your interest.  Since our service is line-of-sight based, I have put you on our site-survey calendar. Sometime this week or next week we expect to come out to your property and complete a survey. Weather conditions will also play a factor on how quickly we can get it completed. We will then give you a call or email to let you know what we find. No one needs to be home to complete the survey.

 

The system excepted this one where I removed the last 2 sentences.

 

Thank you for your interest.  Since our service is line-of-sight based, I have put you on our site-survey calendar. Sometime this week or next week we expect to come out to your property and complete a survey. 

 

Not very useful to have to limit canned responsed to so few characters.

Reply