Reply
Member
Posts: 155
Registered: ‎09-19-2009
Kudos: 34
Solutions: 3

Subscription didn't work

[ Edited ]

I have a customer who is set up with a subscription to pay her bill on the 1st of each month. She just emailed me because she didn't see the money come out of her account like it usually does. 

 

I checked and the subscription is still set up. The error in the log doesn't tell me much. There's an error like the one attached each day and the failure number increments each time.

 

Anyone know what's going on? I'm not sure if it even attempted to charge the card.

 

Edit: This subscription has been set up and worked fine for 3 months previous to it failing on Dec 1st.

Ubiquiti Employee
Posts: 3,511
Registered: ‎12-10-2015
Kudos: 1248
Solutions: 271

Re: Subscription didn't work

Please send us the log message to us. Is that UCRM log or the payment gateway log? (Please check whether you see some error in the gateway)
Which gateway do you use?
Did it happen for one client or all the clients?
Member
Posts: 155
Registered: ‎09-19-2009
Kudos: 34
Solutions: 3

Re: Subscription didn't work

 
Screen Shot 2018-12-06 at 11.02.31 AM.png
Member
Posts: 155
Registered: ‎09-19-2009
Kudos: 34
Solutions: 3

Re: Subscription didn't work

 
Screen Shot 2018-12-06 at 11.11.54 AM.png
Member
Posts: 155
Registered: ‎09-19-2009
Kudos: 34
Solutions: 3

Re: Subscription didn't work

The Gateway is IPPay. AFAIK it only effects this client. Haven't come across any others that failed. I don't know how to find the transaction in the gateway because I don't know where to find the token or any reference numbers in UCRM to be able to identify it in the gateway.

Member
Posts: 155
Registered: ‎09-19-2009
Kudos: 34
Solutions: 3

Re: Subscription didn't work

Apparently this turned out to be an expired credit card. It would be nice if it gave an error so I could see what the problem is, or even automatically email the customer and notify them that their card has expired and could not be charged.

 

Thanks,

Roger

Ubiquiti Employee
Posts: 3,511
Registered: ‎12-10-2015
Kudos: 1248
Solutions: 271

Re: Subscription didn't work

Thanks for info, we will consider possible improvements.
Reply