Senior Member
Posts: 3,356
Registered: ‎07-28-2009
Kudos: 1005
Solutions: 44

Tickets not importing from IMAP after upgrade to beta 4

@UBNT-Petr I think I am having a problem with tickets importing via IMAP with the latest beta.

 

I believe the issue could be do to the following change.

  • Notifications sent by UCRM are no longer detected as a new ticket in any case now.

I have 2 IMAP email boxes setup

  • signup@domain.com
  • support@domain.com

If I send an email to signup CRM detects and creates the ticket and marks the message as read in the signup email inbox.  However if I send an email to support the message never gets imported.

 

I have my Mailer settings to as follows and have had them setup this way for several version with no issue.

  • Sender Address - crm@domain.com
  • Support Email Address - support@domain.com

Do you have any suggestions on what is going on?

 

Senior Member
Posts: 3,356
Registered: ‎07-28-2009
Kudos: 1005
Solutions: 44

Re: Tickets not importing from IMAP after upgrade to beta 4

Also when a client sends an email to signup@domain.com they get the autogenerated ticket creation email from support@domain.com (that is my default IMAP ticketing box).  However when they respond to the email (support@domain.com) the CRM system never picks up their reply.

Senior Member
Posts: 3,356
Registered: ‎07-28-2009
Kudos: 1005
Solutions: 44

Re: Tickets not importing from IMAP after upgrade to beta 4

Now I am thinking my issue might be similar to this.

https://community.ubnt.com/t5/UCRM/uCRM-tickets-not-importing/m-p/2291877#M8057

 

As a test I sent 2 emails from my personal email address.  One email to signup@domain.com and the other to support@domain.com.  This time uCRM only created a ticket and picked up the one sent to support and not the one sent to signup.

 

I have logged into both email boxes and they both have the email message in their inbox.

 

This needs fixed ASAP as I now cannot count on CRM to handle tickets until this is resolved.

Senior Member
Posts: 3,356
Registered: ‎07-28-2009
Kudos: 1005
Solutions: 44

Re: Tickets not importing from IMAP after upgrade to beta 4

Restarted my email server and CRM server and have been doing more tests.

 

I sent an email at 1:15pm to support@domain.com.  CRM picked up the ticket at 1:20pm. #514

 

I sent an email at 1:14pm to signup@domain.com.  CRM picked up the ticket at 1:30pm.  #518 #Why the exra delay?

 

I replied to #514 at 1:24pm and CRM picked up the response at 1:25.

 

I replied to #518 at 1:30pm and CRM has still not picked up the response yet.  It is now 1:38pm.

Senior Member
Posts: 3,356
Registered: ‎07-28-2009
Kudos: 1005
Solutions: 44

Re: Tickets not importing from IMAP after upgrade to beta 4

[ Edited ]

Ok here is some more information.

 

I sent new tickets.  One to support and one to signup.  Both were sent from the same email address sbyrd@anotherdomain.com at the same time of 1:51pm.

 

CRM picked up the message to support at 1:55pm and created ticket #519

CRM picked up the message to signup at 2:00pm and created ticket #521.

 

What is odd is first there is no ticket #520?  No other tickets came in but CRM jumped from 519 to 521.  Why?

Also why the extra 5 minute delay in picking up the message sent to signup?

 

In fact since the upgrade it looks like CRM is incrementing ticket numbers by 2 instead of by 1. 

Senior Member
Posts: 3,356
Registered: ‎07-28-2009
Kudos: 1005
Solutions: 44

Re: Tickets not importing from IMAP after upgrade to beta 4

When customers get a ticket notification is has the Reply-To set to support.

 

I then replied to both tickets 519 and 521 via email to support at 2:06pm and CRM picked up both responses at 2:10pm.

 

So right now it looks like CRM is having issues with skipping ticket numbers and delays when you have more than one IMAP box setup for ticketing?

Highlighted
New Member
Posts: 2
Registered: ‎06-17-2016

Re: Tickets not importing from IMAP after upgrade to beta 4

Hello,

 

I am having same issue on V 2.15.0 some mails open ticket others simple don't do nothing and ticket numbers increments without ticket. I use gmail server. I can receive the clients email and have to open ticket manually.

 

I have this issue a long time, If i delete imap and create again few minutes later I have new tickets from past mails, but the imports stop some how.

 

I tried everything and still not working and ticket # increment fast as the number of mails increases.

 

Best regards,

Ubiquiti Employee
Posts: 3,923
Registered: ‎12-10-2015
Kudos: 1380
Solutions: 299

Re: Tickets not importing from IMAP after upgrade to beta 4

@jorgemarques
we will try to reproduce this, however, this info could be helpful for us:
are the emails which failed to be converted into new tickets marked as read?
New Member
Posts: 2
Registered: ‎06-17-2016

Re: Tickets not importing from IMAP after upgrade to beta 4

@UBNT-Petr 

 

Thks for the reply, no, this mailbox is only for tickets. We receive alarms on that mailbox and customers support requests. Sometimes we are 2 or 3 days without receiving any tickets by mail, but when I force it sometimes will import them correctly.