Reply
New Member
Posts: 38
Registered: ‎08-30-2014
Kudos: 13
Solutions: 1

UCRM Subscription Payment Not Showing

Hi!

 

-Bob's New invoice was generated with a maturity of 7 days.

-Bob logged in, created a subscription in the client portal

-I logged in to Stripe, confirmed a subscription did exist, and a payment has already been processed is on it's way to my bank

 

 

But, this payment does not show in UCRM and the invoice is still outstanding.

 

How do I reconcile? I can manually do this, but I don't want to do this, any thoughts?

 

 

Ubiquiti Employee
Posts: 1,325
Registered: ‎03-21-2016
Kudos: 214
Solutions: 150

Re: UCRM Subscription Payment Not Showing

Hello @mercman87 , please go through the Setting up Stripe guide step by step and check you've done everything mentioned - https://ucrm-demo.ubnt.com/help/setting-up-stripe. This sounds like you do not have the webhook URL generated by UCRM configured in your Stripe settings.

 

New Member
Posts: 38
Registered: ‎08-30-2014
Kudos: 13
Solutions: 1

Re: UCRM Subscription Payment Not Showing

Thanks, I've had stripe integration setup for quite some time, and it works flawlessly, asides from this particular issue, I've not had any clients enable a subsription, it's usually 1 month at a time.

 

-All payments show up in stripe

-Whenever a client creates a subscription in UCRM, it get's created in Stripe

-If the cancel a subscription, it get's cancelled in Stripe as well

 

My only issue is that, I don't see the payment from a subscription that get's charged in stripe reflect in UCRM, I don't see any error logs, I've followed the guides and nothing errors out in stripe either.

 

-Matt

Ubiquiti Employee
Posts: 1,325
Registered: ‎03-21-2016
Kudos: 214
Solutions: 150

Re: UCRM Subscription Payment Not Showing

Hello @mercman87 , like I said, the Stripe subscriptions require additional configuration, namely adding a webhook URL in the Stripe dashboard, so that Stripe can contact UCRM when the suscription payment is made. It's all in the guide I linked above, please go through all the steps and make sure you have everything configured correctly.

New Member
Posts: 38
Registered: ‎08-30-2014
Kudos: 13
Solutions: 1

Re: UCRM Subscription Payment Not Showing

I can confirm the webhook is indeed in Stripe and configured properly on my UCRM instance which is publically facing/accessbile, I am also not seing any webhook failure notices from Stripe.

Ubiquiti Employee
Posts: 1,325
Registered: ‎03-21-2016
Kudos: 214
Solutions: 150

Re: UCRM Subscription Payment Not Showing

@mercman87  can you check if you see webhook event about new payment in Stripe dashboard and if so, can you open it and check UCRM response?

New Member
Posts: 38
Registered: ‎08-30-2014
Kudos: 13
Solutions: 1

Re: UCRM Subscription Payment Not Showing

Charge Succeeded.pngWebhooks.png

 

 

Ubiquiti Employee
Posts: 1,325
Registered: ‎03-21-2016
Kudos: 214
Solutions: 150

Re: UCRM Subscription Payment Not Showing

Hello @mercman87 , I've sent you a PM, please take a look.

Highlighted
New Member
Posts: 1
Registered: 2 weeks ago

Re: UCRM Subscription Payment Not Showing

Hi @mercman87 & @UBNT-Ondra  - we are having the same issue with our clients using the subscription feature. The payments are showing up in stripe and we see where stripe talked back to UCRM but it is not taking that payment and applying it to their invoice. Were you able to find a solution and what was that solution? Thanks!

Ubiquiti Employee
Posts: 1,325
Registered: ‎03-21-2016
Kudos: 214
Solutions: 150

Re: UCRM Subscription Payment Not Showing

Hello @sjhanson1102  and @mercman87, we were not able to reproduce this issue. The first subscription payments are always showing up in UCRM for us.

Can you please try to find the missing payment in UCRM with instruction I posted to this topic and let us know about the results? https://community.ubnt.com/t5/UCRM/uCRM-2-14-7-Not-Recording-First-Subscription-Payment/m-p/2684697#...

 

Reply