New Member
Posts: 5
Registered: ‎09-21-2016
Kudos: 1
Solutions: 1
Accepted Solution

UCRM and UNMS not starting after hardware reboot

I just installed Debian on my cpu and then installed UCRM and it was working fine until I lost power and my cpu restarted, but UCRM didn`t.

 

I managed to make it work again and after that I installed UNMS. Both services are working well but if I reboot the system they don`t come back.

 

I can start this services with this, but I have to do this everytime I turn off my device

 

cd /home/ucrm
sudo docker-compose kill
sudo docker-compose rm --all
sudo docker-compose up -d


cd /home/unms/app
docker-compose -p unms down
docker-compose -p unms up -d

 

What can I do to avoid starting manually this servies?

 

This is my docker version:

 

docker version
Client:
Version: 18.09.4
API version: 1.39
Go version: go1.10.8
Git commit: d14af54
Built: Wed Mar 27 18:36:06 2019
OS/Arch: linux/amd64
Experimental: false

Server: Docker Engine - Community
Engine:
Version: 18.09.4
API version: 1.39 (minimum version 1.12)
Go version: go1.10.8
Git commit: d14af54
Built: Wed Mar 27 18:01:48 2019
OS/Arch: linux/amd64
Experimental: false

Accepted Solutions
New Member
Posts: 5
Registered: ‎09-21-2016
Kudos: 1
Solutions: 1

Re: UCRM and UNMS not starting after hardware reboot

I found a solution, finally. The problem is caused when you don't install "standard system utilities" when installing DEBIAN, I came across with this page with instructions to install those packages https://lists.debian.org/debian-user/2015/04/msg01549.html

 

Maybe some of those are needed to restart the services correctly.

 

This is what I did:

tasksel -t --new-install

selected *only* "standard" and left everything else unchecked, then:

aptitude -q -y install ~pstandard ~prequired ~pimportant

After that everything started to work as it should

 

I hope this solution is helpful for anyone with the same problem, and also I would like to sugest to ubiquiti staff to add some warning in the tutorials for UNMS and UCRM installation page.

View solution in original post


All Replies
Highlighted
Regular Member
Posts: 338
Registered: ‎11-18-2009
Kudos: 97
Solutions: 10

Re: UCRM and UNMS not starting after hardware reboot

@israman,

 

Is "restart: always" missing from the services in docker-compose.yml, per chance?

 

 

New Member
Posts: 5
Registered: ‎09-21-2016
Kudos: 1
Solutions: 1

Re: UCRM and UNMS not starting after hardware reboot

restart: always is in every paragraph as it should be
Regular Member
Posts: 338
Registered: ‎11-18-2009
Kudos: 97
Solutions: 10

Re: UCRM and UNMS not starting after hardware reboot

And no errors when you start it manually?

New Member
Posts: 5
Registered: ‎09-21-2016
Kudos: 1
Solutions: 1

Re: UCRM and UNMS not starting after hardware reboot

No, only says "done"
Ubiquiti Employee
Posts: 4,163
Registered: ‎12-10-2015
Kudos: 1472
Solutions: 315

Re: UCRM and UNMS not starting after hardware reboot

I am afraid we can't help with this. Some issues like this occurred in the past with old docker or kernel version. You might check if you are using the latest version available. Additionally, note that the containers are not starting automatically if you have stopped them manually.
New Member
Posts: 5
Registered: ‎09-21-2016
Kudos: 1
Solutions: 1

Re: UCRM and UNMS not starting after hardware reboot

Would you recomend to install everything from scratch, including OS?

New Member
Posts: 5
Registered: ‎09-21-2016
Kudos: 1
Solutions: 1

Re: UCRM and UNMS not starting after hardware reboot

I found a solution, finally. The problem is caused when you don't install "standard system utilities" when installing DEBIAN, I came across with this page with instructions to install those packages https://lists.debian.org/debian-user/2015/04/msg01549.html

 

Maybe some of those are needed to restart the services correctly.

 

This is what I did:

tasksel -t --new-install

selected *only* "standard" and left everything else unchecked, then:

aptitude -q -y install ~pstandard ~prequired ~pimportant

After that everything started to work as it should

 

I hope this solution is helpful for anyone with the same problem, and also I would like to sugest to ubiquiti staff to add some warning in the tutorials for UNMS and UCRM installation page.

Ubiquiti Employee
Posts: 4,163
Registered: ‎12-10-2015
Kudos: 1472
Solutions: 315

Re: UCRM and UNMS not starting after hardware reboot

Thanks for sharing this info @israman
We will include this in our guides to help others.