Reply
Veteran Member
Posts: 4,387
Registered: ‎05-19-2009
Kudos: 661
Solutions: 19

missing the required redirect URI (Google Calendar sync error)

 

 

I set up  0Auth in line by line from the domain.com/help/google-oauth

 

 

I uploaded the 0Auth Json file and UCRM said success 

 

 

then I go to domain.com/user/settings/account

 

click "Connect with Google calendar" 

 

then UCRM Displays red pop up error "missing the required redirect URI"

 

Should it not say URL, not URI???

 

 

anyway 

 

I go back to domain.com/system/settings/oauth

 

Google redirect  URL is set to  https://domain.com/oauth/google/callback

 

 

@UBNT-Petr

 

Any idea what is going on? is there a URI I need to set somewhere or is that a typo and the I should be an L?

 

 

 

Veteran Member
Posts: 4,387
Registered: ‎05-19-2009
Kudos: 661
Solutions: 19

Re: missing the required redirect URI (Google Calendar sync error)

also, the how-to at domain.com/help/google-oauth

 

steps 10 - 13 are missing a space after the . making it hard to read as set 10 looks like it says 10jIF do to the dot making an I look like a J from not having a space

Ubiquiti Employee
Posts: 1,157
Registered: ‎03-21-2016
Kudos: 188
Solutions: 134

Re: missing the required redirect URI (Google Calendar sync error)

[ Edited ]

@900mhzdude Just to make sure, the redirect URL in /system/settings/oauth is auto-generated by UCRM and you're supposed to copy it and put in into configuration in Google API Console, did you do that?

 

Also thanks for the guide report, we'll look into it.

Highlighted
Veteran Member
Posts: 4,387
Registered: ‎05-19-2009
Kudos: 661
Solutions: 19

Re: missing the required redirect URI (Google Calendar sync error)

Yes, I did do that, 

 

 

maybe I will redo it is the 3rd time is the charm saying is true..  we will see.. :/

Ubiquiti Employee
Posts: 1,157
Registered: ‎03-21-2016
Kudos: 188
Solutions: 134

Re: missing the required redirect URI (Google Calendar sync error)

Hello @900mhzdude, I just went through the guide and actually got the same error you've reported. After some digging I found it was actually because of misconfiguration in Google API Console like I first thought.

The problem is, that you have to actually press "enter" key after pasting the redirect URL, otherwise Google will not save it.

 

To illustrate, this is in "OAuth consent screen" section where you have to fill in authorised domain. If you don't press enter it will look like this and Google will not save it:


oauth_authorized.png

If you press enter, it will to change to this and then it will be saved:

oauth_authorized_2.png

 

The same applies for authorised redirect URIs when creating the "OAuth client ID" in Credentials section:

oauth_client.pngoauth_client_2.png

 

When this is saved, the JSON file you download later in the guide will have the redirect URI correctly in the data and everything will start to work.

We will update the guide accordingly, thanks for reporting the issue.

Reply