New Member
Posts: 3
Registered: ‎04-16-2018
Kudos: 1
Solutions: 1
Accepted Solution

Let's Encrypt error: An unexpected error occurred version 0.13.3

Timestamp: Today at 12:14
Error: An unexpected error occurred:
ConnectTimeout: HTTPSConnectionPool(host='acme-v01.api.letsencrypt.org', port=443): Max retries exceeded with url: /directory (Caused by ConnectTimeoutError(<urllib3.connection.VerifiedHTTPSConnection object at 0x7f4e75e81710>, 'Connection to acme-v01.api.letsencrypt.org timed out. (connect timeout=45)'))
Please see the logfiles in /tmp for more details.
Failed to generate or update Let's Encrypt certificate.
Keeping existing certificate for 'unms.1120tech.com'.

 

I have both port 80 and 443 open, however if you go to the url on port 80 it automatically redirects to 443, not sure if that's a problem or not.  This is a new install that was completed yesterday.  Any suggestions on how to get let's encrypt to work?

 

Thanks,

Andy


Accepted Solutions
Ubiquiti Employee
Posts: 3,280
Registered: ‎09-08-2017
Kudos: 1244
Solutions: 245

Re: Let's Encrypt error: An unexpected error occurred version 0.13.3

@andygee1  Hello Andy. From the log you posted, it seems that your UNMS cannot connect to the LE server. Can you please double check that you have LE enabled in Settings->UNMS->Use Let's Encrypt? What happens when you try to click Refresh certificate? If you are constantly getting the same error it would mean there is something on the way to LE validation server, possibly a firewall. 

UBNT_Alternate_Logo.png
UNMS Support - If you want to report an issue please use this guide.

Check out our ever-evolving Help Center for answers to many common questions!

View solution in original post

New Member
Posts: 3
Registered: ‎04-16-2018
Kudos: 1
Solutions: 1

Re: Let's Encrypt error: An unexpected error occurred version 0.13.3

Turns out it was a NAT issue on our side, thanks for the help.  I had checked basic connectivity from the box and could ping out and connect to the box from outside, ended up doing a wget to a webpage and found that it wouldn't bring it in.  

 

Andy

View solution in original post


All Replies
New Member
Posts: 27
Registered: ‎06-02-2016
Kudos: 4

Re: Let's Encrypt error: An unexpected error occurred version 0.13.3

My guess from that output is that letsencrypt was having api issues.  You can try again in the settings.

 

New Member
Posts: 3
Registered: ‎04-16-2018
Kudos: 1
Solutions: 1

Re: Let's Encrypt error: An unexpected error occurred version 0.13.3

It's possible but if they are it's been going on for 2 days now.  :-(  

 

Andy

Ubiquiti Employee
Posts: 3,280
Registered: ‎09-08-2017
Kudos: 1244
Solutions: 245

Re: Let's Encrypt error: An unexpected error occurred version 0.13.3

@andygee1  Hello Andy. From the log you posted, it seems that your UNMS cannot connect to the LE server. Can you please double check that you have LE enabled in Settings->UNMS->Use Let's Encrypt? What happens when you try to click Refresh certificate? If you are constantly getting the same error it would mean there is something on the way to LE validation server, possibly a firewall. 

UBNT_Alternate_Logo.png
UNMS Support - If you want to report an issue please use this guide.

Check out our ever-evolving Help Center for answers to many common questions!

New Member
Posts: 3
Registered: ‎04-16-2018
Kudos: 1
Solutions: 1

Re: Let's Encrypt error: An unexpected error occurred version 0.13.3

Turns out it was a NAT issue on our side, thanks for the help.  I had checked basic connectivity from the box and could ping out and connect to the box from outside, ended up doing a wget to a webpage and found that it wouldn't bring it in.  

 

Andy