Reply
Ubiquiti Employee
Posts: 5,088
Registered: ‎08-08-2016
Kudos: 5510
Solutions: 353

Re: Adoption Failed: It’s impossible to adopt USG


@mcheavens wrote:

I have fought this recently and after a major re-subnetting and a failure to adopt I did a factory reset (5 seconds) and still no joy. I found the lack of adoption was related to the need to UNCHECK "check ssh key" when trying to manually re-adopt a KNOWN device. 

 


Thanks for noting that. I'm investigating a semi-related adoption issue (unrelated key problem in an unusual edge case) and will check that out while I'm at it. 

New Member
Posts: 20
Registered: ‎11-30-2009
Kudos: 3

Re: Adoption Failed: It’s impossible to adopt USG

This sounds very relevant to a problem I am having. Is ther any additonal information to help troubleshoot?

New Member
Posts: 4
Registered: ‎11-24-2016

Re: Adoption Failed: It’s impossible to adopt USG

OMG This technique just worked for me. Spammin the set-inform command. Thanks for the tip.
New Member
Posts: 6
Registered: ‎01-30-2018
Kudos: 11

Re: Adoption Failed: It’s impossible to adopt USG

UPDATE - 11JUL2018

 

I have now installed about 100 of the USGs and WAPs.

 

I have narrowed down the steps as follows:

 

1). Use Chrome App to find Ubiquiti devices on network.

2). Get IP of the device from the Chrome App and use Putty to log in using default user/pw combo.

3). Use set-inform command on device to get it to touch your Dashboard.

4). Click ADOPT while under the proper profile for the client/location.

5). Use the set-inform command again after you click ADOPT in the dashboard.

6). The device provisions itself.

 

All of this happens within 120 seconds from start to finish.   This has now worked for me almost 100 times.

 

Just as an FYI ... I have had successful installs where I did not follow the steps (I tested different things for my home units).  However, it could take anywhere from 5 minutes to 20 minutes before the devices would finish the adoption process.   I don't think it is broken - I just think the work around allows you to immediately get the results desired rather than waiting for them.

Emerging Member
Posts: 73
Registered: ‎06-29-2017
Kudos: 10

Re: Adoption Failed: It’s impossible to adopt USG

[ Edited ]

Just to add my experience into the mix.

 

I had an existing UniFi network (switch, cloud key, access points) being run by an EdgeRouter Lite on the 192.168.10.0/24 subnet.

 

As per the instruction document I went into the controller and set the LAN details to match my current subnet (x.x.10.1) so when the USG was adopted, it wouldn't change my LAN to x.x.1.1.

 

Looks like newer firmware in the USG allows you to browse to it and change the LAN address, however mine was older so I had so SSH into it and change it manually. As my network was in use, I chose to do this on the bench and it worked ok, I issued the Commit command and lost access to the USG as expected, however, I needed to power down the USG to move it to my equipment rack.

 

It seems that when powering the USG down it returns to the 192.168.1.1 address, so I left it insitu and changed the IP details again.

 

I then had the "adoption failed" loop issue in the controller. I tried set inform many, many times, I'd approximate that I tried to adopt it 60-70 times when all of a sudden ti just worked.

 

For a system that seems to work so well, the difficulty in bringing a USG into the system is quite appaling.

New Member
Posts: 2
Registered: ‎12-28-2016
Kudos: 1

Re: Adoption Failed: It’s impossible to adopt USG

Mark, 

You are an absolute star. 

That is exactly the issue. The controller seems to ignore it if "Check SSH key" is checked.

Once unchecked it responds with "Only adopt if you are confident... "etc. and immediately provisions.

I must have tried 50-60 times before I found your solution. Thank you for saving me another couple of hours!

James.  Hurray

Established Member
Posts: 1,811
Registered: ‎02-01-2014
Kudos: 462
Solutions: 65

Re: Adoption Failed: It’s impossible to adopt USG

@Greenz. I HATE that little checkbox. It got me about 2 weeks ago.
New Member
Posts: 1
Registered: ‎11-14-2016

Re: Adoption Failed: It’s impossible to adopt USG

It solved my problem, thanks.

New Member
Posts: 15
Registered: ‎04-02-2014
Kudos: 13

Re: Adoption Failed: It’s impossible to adopt USG

FYI, I had this issue. I connected my USG WAN port to the Internet, LAN port directly to a PC. I logged in to the setup.ubnt.com interface and manually set the WAN IP which was a real static IP from our ISP. I set the inform address via the same web interface and it kept saying that it could not contact the controller, and indeed the USG would not show up in the controller. 

 

So I sshed into the unit and manually ran set-inform. Nothing. Checked /var/log/messages and found that it was simply going to http://unifi:8080 COMPLETELY ignoring the Set-Inform and web interface settings! In fact, the logs don't show ANY ATTEMPT AT ALL to use the controller address I was manually specifying. 

 

I resolved the issue in my case by MANUALLY editing /etc/hosts on the USG and putting in a line for unifi to point to my controller's IP. THAT worked.

 

Clearly the firmware is bugged here, the set-inform command is just plain broken - at least in the factory default firmware of 4.3.33.4936086

 

 

 

New Member
Posts: 2
Registered: ‎02-25-2017

Re: Adoption Failed: It’s impossible to adopt USG

This worked great, thanks.
Emerging Member
Posts: 73
Registered: ‎06-29-2017
Kudos: 10

Re: Adoption Failed: It’s impossible to adopt USG


@Greenz wrote:

That is exactly the issue. The controller seems to ignore it if "Check SSH key" is checked.


Where exactly does one find this checkbox in UniFi Controller?

Highlighted
New Member
Posts: 3
Registered: ‎11-03-2017

Re: Adoption Failed: It’s impossible to adopt USG

HI WAP ADMIN,

 

i have the same problem, i already follow your step but


@WAP-ADMIN-20 wrote:
Hi Everyone this works great if you keep you LAN 1 interface on the same network segment.
I am using the Cloud Key and changed the LAN1 192.168.1.1/24 segment to 10.1.250.0/24 and ran into issues once the USG was adopted and provisioned the new network segments and VLANs.

Here's what I found to work for me giving my requirements:

Log into Cloud Unifi Console and click on the clients icon via the left side menu, once you see UniFi-CloudKey double click.
The properties menu will open, click on the configuration tab, and then the network section in the menu.
Check use fixed IP address. This apply what ever IP you want the Cloud Key controller to have once you start the adoption process/provision the USG device with you defined networks.

The second important piece here is to use the set-inform http://10.1.250.2:8080/inform command on your USG device. Note: the IP address would be specific to your network!

From what I can see is this address must be set statically and cannot change once the device is adopted, if you have it set to 192.168.1.X for example it will fail once the IP's are provisioned to your desired IP scheme.


I can not find the  the network section in the menu. whare have to find this menu ? 

menu.JPG
menu.JPG
Reply