Reply
Emerging Member
Posts: 93
Registered: ‎11-06-2016
Kudos: 8
Accepted Solution

Adoption Failed: It’s impossible to adopt USG

[ Edited ]

Hi,

 

I am using a 10.0.1.x network. Yesterday I got my new UniFi Security Gateway, but it is not possible to adopt it to the controller. Now I do not ave more ideas how to connect it to my controller. I am very frustrated!

 

What I am doing:

  1. After resetting the USG to factory defaults I wait for stop flashing.
  2. Then I put a cable between my iMac and thd USG LAN port. Network setting on the Mac is DHCP.
  3. I open Safari and call the URL: https://setup.ubnt.com
  4. Then I put a cable from USG WAN port to my network. The USG gets the address 10.0.1.3 and an internet connection.
  5. I open my controller and try to adopt the USG. But what I do, it doesn't work. :-( I alsways get „Adopting Failed“.

I guess I am doing something wrong. But I do not know what. Please, can I get some help?

 

Best regards

Gerhard

Adoption_Failed.jpg
Adoption_Failed2.jpg

Accepted Solutions
Regular Member
Posts: 461
Registered: ‎07-22-2016
Kudos: 195
Solutions: 28

Re: Adoption Failed: It’s impossible to adopt USG

You can't do it that way. You need to set the subnet before trying to adpot it. Follow the directions from this link under the section "Change the USG LAN IP Before Adoption"

 

https://help.ubnt.com/hc/en-us/articles/236281367-UniFi-Adopting-a-USG-into-an-Existing-Network

View solution in original post


All Replies
Regular Member
Posts: 461
Registered: ‎07-22-2016
Kudos: 195
Solutions: 28

Re: Adoption Failed: It’s impossible to adopt USG

You can't do it that way. You need to set the subnet before trying to adpot it. Follow the directions from this link under the section "Change the USG LAN IP Before Adoption"

 

https://help.ubnt.com/hc/en-us/articles/236281367-UniFi-Adopting-a-USG-into-an-Existing-Network

New Member
Posts: 33
Registered: ‎12-14-2015
Kudos: 15
Solutions: 4

Re: Adoption Failed: It’s impossible to adopt USG

If you are planning to replace your existing router/firewall, you should conenct the USG LAN port to your network instead and perform the adoption following the link in the post above.

 

If your intentionally trying to adopt the USG thru the WAN interface, I would say you should try and perform it as a Layer 3 WAN adoption.

 

See the link below.

https://help.ubnt.com/hc/en-us/articles/204909754-UniFi-Layer-3-methods-for-UAP-adoption-and-managem...

The link above is for AP adoption, but the part about the WAN adoption also applies to the USG

 

If you can SSH into the USG WAN IP, it's possible to do L3-adoption via CLI command:

# 3. ssh into the device (on IP 10.0.1.3) and type
mca-cli
# the CLI interface:
set-inform http://ip-of-controller:8080/inform
# 4. after issuing the set-inform, the UniFi device will show up for adoption. Once you click adopt the device will appear to go offline.
# 5. once the device goes offline, issue the set-inform command again. This will permanently save the inform address, and you'll see the device will start provisioning.

resend the set-inform command again once/twice more after hitting the adopt button on the controller.
Dont forget to check that port 8080 is open in your firwall on your controller if your not running it on a CloudKey.

 

Emerging Member
Posts: 93
Registered: ‎11-06-2016
Kudos: 8

Re: Adoption Failed: It’s impossible to adopt USG

[ Edited ]

The hint to set the port IP to 10.0.1.x was right. This works. Thank You. :-)

 

The USG is shown in the controller, so Ubiquiti should make it posibility to set the address via the contoller interface instead of ssh.

New Member
Posts: 2
Registered: ‎08-09-2017
Kudos: 1

Re: Adoption Failed: It’s impossible to adopt USG


@SAMTECHM wrote:

If you are planning to replace your existing router/firewall, you should conenct the USG LAN port to your network instead and perform the adoption following the link in the post above.

 

If your intentionally trying to adopt the USG thru the WAN interface, I would say you should try and perform it as a Layer 3 WAN adoption.

 

See the link below.

https://help.ubnt.com/hc/en-us/articles/204909754-UniFi-Layer-3-methods-for-UAP-adoption-and-managem...

The link above is for AP adoption, but the part about the WAN adoption also applies to the USG

 

If you can SSH into the USG WAN IP, it's possible to do L3-adoption via CLI command:

# 3. ssh into the device (on IP 10.0.1.3) and type
mca-cli
# the CLI interface:
set-inform http://ip-of-controller:8080/inform
# 4. after issuing the set-inform, the UniFi device will show up for adoption. Once you click adopt the device will appear to go offline.
# 5. once the device goes offline, issue the set-inform command again. This will permanently save the inform address, and you'll see the device will start provisioning.

resend the set-inform command again once/twice more after hitting the adopt button on the controller.
Dont forget to check that port 8080 is open in your firwall on your controller if your not running it on a CloudKey.

 


This is what solved the adopt issue for me.  Thank you!

New Member
Posts: 1
Registered: ‎06-09-2017

Re: Adoption Failed: It’s impossible to adopt USG

One thing that i would like to bring to this topic is the experience that i had today.

I ordered a new security gateway.  installed it with the same difficulties listed above.

 

I was able to finally get it configred to local network and get the DHCP scope working.

 

I moved the device from my test vlan to production and I started having all sorts of adoption issues.

 

I have 2 APs 1 Mesh and then I added the USG.  Prior to this i had no issues at all with the APs or Mesh or the controller.

 

They all went into an adoption loop.

From the machine where my controller was installed i could SSh to the WAPs and the USG.

I could not get it to adopt the devices.

 

I worked on it for about 2 hours.  Using the CLI to force the SET-INFORM 

Restarts the works nothing would stop this adoption loop.

 

I then tried to telnet from my  AP to my workstation that has the controller on it, and there is when i realized

 

The firewall on the PC had been blocking all the inform requests for adoption.

 

 

So make sure that you can ping and telnet port 8080 from the APs/USG to your machine running your controller.

 

 

The curiousity of it all was that the controller has been running as a service for about 9 months from this workstation with no issue.

 

Only when i installed the USG did the firewall on the workstation become a problem.

 

 

Hope this saves someone some time.

 

Chris.

 

Showing the adoption loop after the USG install

Secure Gateway was automatically readoptedToday2:21 pm
 Secure Gateway was automatically readoptedToday2:21 pm
 Secure Gateway was automatically readoptedToday2:20 pm
 Outside Remote was automatically readoptedToday2:20 pm
 Secure Gateway was automatically readoptedToday2:19 pm
 Outside Remote was automatically readoptedToday2:19 pm
 Outside Remote was automatically readoptedToday2:18 pm
 Secure Gateway was automatically readoptedToday2:18 pm
 Outside Remote was automatically readoptedToday2:17 pm
 Secure Gateway was automatically readoptedToday2:17 pm
 Secure Gateway was automatically readoptedToday2:16 pm
 Outside Remote was automatically readoptedToday2:16 pm
 Secure Gateway was automatically readoptedToday2:15 pm
 Outside Remote was automatically readoptedToday2:15 pm
 Outside Remote was automatically readoptedToday2:14 pm
 Secure Gateway was automatically readoptedToday2:14 pm
 Secure Gateway was automatically readoptedToday2:13 pm
 Outside Remote was automatically readoptedToday2:12 pm
 Secure Gateway was automatically readoptedToday2:12 pm
Emerging Member
Posts: 59
Registered: ‎11-01-2016
Kudos: 15
Solutions: 1

Re: Adoption Failed: It’s impossible to adopt USG

Even after setting the subnet to my LAN network via the console and setting the inform URL I was stuck in the adoption failed loop as well. What ended up working was, via the console, continually running the set-inform command every 2 seconds while at the same time clicking "Adopt" in the controller. After about 10 set-informs the controller finally adopted the USG without issue. Just posting this in case it may help someone out in the future.

Ubiquiti Employee
Posts: 5,066
Registered: ‎08-08-2016
Kudos: 5501
Solutions: 351

Re: Adoption Failed: It’s impossible to adopt USG


@cbwilliam4446 wrote:

One thing that i would like to bring to this topic is the experience that i had today.

I ordered a new security gateway.  installed it with the same difficulties listed above.

 

I was able to finally get it configred to local network and get the DHCP scope working.

 

I moved the device from my test vlan to production and I started having all sorts of adoption issues.

 

I have 2 APs 1 Mesh and then I added the USG.  Prior to this i had no issues at all with the APs or Mesh or the controller.

 

They all went into an adoption loop.

From the machine where my controller was installed i could SSh to the WAPs and the USG.

I could not get it to adopt the devices.

 

I worked on it for about 2 hours.  Using the CLI to force the SET-INFORM 

Restarts the works nothing would stop this adoption loop.

 

I then tried to telnet from my  AP to my workstation that has the controller on it, and there is when i realized

 

The firewall on the PC had been blocking all the inform requests for adoption.

 

 

So make sure that you can ping and telnet port 8080 from the APs/USG to your machine running your controller.

 

 

The curiousity of it all was that the controller has been running as a service for about 9 months from this workstation with no issue.

 

Only when i installed the USG did the firewall on the workstation become a problem.

 


Sounds like it's on a Windows system. When the MAC address of your gateway IP changes, Windows detects it as a new network. It'll then prompt for which type it is (trusted or public). I'm guessing you had the firewall disabled, or 8080 open, in Windows firewall for trusted networks only, and then chose public for the new prompt. Or something similar along those lines. 

New Member
Posts: 2
Registered: ‎10-11-2017

Re: Adoption Failed: It’s impossible to adopt USG

Hello, I have been having the same issue, in the cloud portal. I have a USG with a cloud key, I can fing it but it does not adopt by any means... I t says pending adoption and it just does not work. Could you please help me out?


Thanks.

 

 

Emerging Member
Posts: 59
Registered: ‎11-01-2016
Kudos: 15
Solutions: 1

Re: Adoption Failed: It’s impossible to adopt USG


@lifeemotions wrote:

Hello, I have been having the same issue, in the cloud portal. I have a USG with a cloud key, I can fing it but it does not adopt by any means... I t says pending adoption and it just does not work. Could you please help me out?


Thanks.

 

 


Are you getting an adoption failed message? or continual pending adoption? When I had the issue it would try to adopt and then fail over and over. I used a console cable to get into the USG and continually set the inform URL (which was pointing to the cloud key). Like issue the set inform command, hit enter, hit up arrow, issue the command again, hit up arrow, issue again etc. While at the same time clicking Adopt in the controller. This did in fact work and I have had no issues since.

New Member
Posts: 6
Registered: ‎01-30-2018
Kudos: 11

Re: Adoption Failed: It’s impossible to adopt USG

I hate to say this .. but I struggled for 2 hours trying to get my USG to adopt as well.  I stumbled across this post (and many others).

 

To get my USG to finally get into provisioning phase and get adopted, I had to do the following:

 

1). Reset USG to factory using the chrome browser tool.

2). Use Putty to SSH into my defaulted USG device (192.168.1.1 - ubnt/ubnt)

3). Issue the command mca-cli

4). Issue the command set-inform http://YOURUNFICONTROLLERIP:8080/inform

          *yourunificontroillerip = the IP address or the domain name of your unfi controller

5). As soon as it showed on the dashboard of my unifi controller, I hit ADOPT.

6). Every 2 seconds, I then reissued the same set-inform command in step 4.

 

No science to this .. I just kept doing it until it said PROVISIONING and my Putty connection quit.  The putty quit because once it was provisioned, it changed the default ubnt/ubnt login to my login name/password specified in the unifi controller.

 

All I can say is ... UGGHHH ... I bought this to test at home (USG, Switch, AP-Pro) before doing customer deployments.  This almost killed my desire to deploy on customer sites.  Nothing should be like this ... 

New Member
Posts: 6
Registered: ‎01-30-2018
Kudos: 11

Re: Adoption Failed: It’s impossible to adopt USG

Just FYI - once I got the USG up and running, it took 10 total minutes (including building my wifi networks) to get the 8 port switch and the AC Pro operational. Hard to fathom how easy it is once the USG was running...
Ubiquiti Employee
Posts: 5,066
Registered: ‎08-08-2016
Kudos: 5501
Solutions: 351

Re: Adoption Failed: It’s impossible to adopt USG


wrote:

I hate to say this .. but I struggled for 2 hours trying to get my USG to adopt as well.  I stumbled across this post (and many others).

 

To get my USG to finally get into provisioning phase and get adopted, I had to do the following:

 

1). Reset USG to factory using the chrome browser tool.

2). Use Putty to SSH into my defaulted USG device (192.168.1.1 - ubnt/ubnt)

3). Issue the command mca-cli

4). Issue the command set-inform http://YOURUNFICONTROLLERIP:8080/inform

          *yourunificontroillerip = the IP address or the domain name of your unfi controller

5). As soon as it showed on the dashboard of my unifi controller, I hit ADOPT.

6). Every 2 seconds, I then reissued the same set-inform command in step 4.

 

No science to this .. I just kept doing it until it said PROVISIONING and my Putty connection quit.  The putty quit because once it was provisioned, it changed the default ubnt/ubnt login to my login name/password specified in the unifi controller.

 


Running mca-cli is unnecessary, set-inform works outside of that. After hitting adopt in the controller you only have to run set-inform once so it reaches out again and gets adopted and provisioned. It takes some time (~2-3 minutes maybe) to complete the initial adoption and provisioning, which seems to be why people get the idea they have to keep running set-inform a bunch of times. No, once suffices, then just wait for it to provision. No need to run set-inform at all if the controller is directly-connected to USG's LAN. 

Emerging Member
Posts: 76
Registered: ‎07-03-2017
Kudos: 34

Re: Adoption Failed: It’s impossible to adopt USG

[ Edited ]

Hey guys,

I'm out of ideas with this freakin' USG hardware :-(

I simply can't get it to be adopted.

 

It toggles between adopting and adoption failed.

 

  • restart didn't help
  • sensing the set-inform command using CLI after hitting the adopt button didn't help.
  • even the update didn't work - which I managed to du manually using CLI

 

Currently it looks like this.
My actual Linux firewall router uses 192.168.1.1 on the LAN side and a 10.0.0.x adress on it's input side.

The 10.0.0.x address is coming from the modem.

The linux machine does DNS, DHCP etc. for my internal network. And this should stay this way for the time being.

That's why I want to use the USG in a bridge mode as describes here by @wnoisephx

But I don't even manage to adopt the **** thing.

 

The USG on the WAN side currently also has a 10.0.0.x adress and on the LAN side I configured it to 192.168.1.222.

It shows up in the controller - but I can't manage to adopt it.
It always goes in a loop between "adopting" and "adoption failed"

 

Screen Shot 2018-02-18 at 19.03.10.pngAdopting

 

Screen Shot 2018-02-18 at 19.03.23.pngAdoption failed

 

Screen Shot 2018-02-18 at 19.04.17.pngsometimes it even shows a wrong IP in the controller although I changed it to .222

 

The controller is running in a docker container on a Synology NAS.
Controller Version 5.6.30

 

 

Would be great if you could help me.
I'm literally out of ideas with this d*** thing :-(

 

 

Thanks a million guys

Greets
Michael 

 

 

 

 

New Member
Posts: 1
Registered: ‎10-24-2017

Re: Adoption Failed: It’s impossible to adopt USG

OMG Thank you sooooo much!  I have been struggling with this for 2 hours at a new location when my other location only took minutes.  I tried that and it worked perfect!!! THANKS

New Member
Posts: 6
Registered: ‎01-30-2018
Kudos: 11

Re: Adoption Failed: It’s impossible to adopt USG

Here is an update.   I have done about 10 test runs.   And I have now done 11 installations.  

 

To get my USG to finally get into provisioning phase and get adopted, I had to do the following:

1). Reset USG to factory using the chrome browser tool.
2). Use Putty to SSH into my defaulted USG device (192.168.1.1 - ubnt/ubnt)
3). Issue the command set-inform http://YOURUNFICONTROLLERIP:8080/inform
*yourunificontroillerip = the IP address or the domain name of your unfi controller
4). As soon as it showed on the dashboard of my unifi controller, I hit ADOPT.
5). About 10 seconds after I hit adopt, I then reissued the same set-inform command in step 4.

 

This has worked 100% of the time every time in the adoption happens within 20 to 40 seconds

New Member
Posts: 1
Registered: ‎03-09-2018

Re: Adoption Failed: It’s impossible to adopt USG

Hi Everyone this works great if you keep you LAN 1 interface on the same network segment.
I am using the Cloud Key and changed the LAN1 192.168.1.1/24 segment to 10.1.250.0/24 and ran into issues once the USG was adopted and provisioned the new network segments and VLANs.

Here's what I found to work for me giving my requirements:

Log into Cloud Unifi Console and click on the clients icon via the left side menu, once you see UniFi-CloudKey double click.
The properties menu will open, click on the configuration tab, and then the network section in the menu.
Check use fixed IP address. This apply what ever IP you want the Cloud Key controller to have once you start the adoption process/provision the USG device with you defined networks.

The second important piece here is to use the set-inform http://10.1.250.2:8080/inform command on your USG device. Note: the IP address would be specific to your network!

From what I can see is this address must be set statically and cannot change once the device is adopted, if you have it set to 192.168.1.X for example it will fail once the IP's are provisioned to your desired IP scheme.
New Member
Posts: 8
Registered: ‎04-15-2018

Re: Adoption Failed: It’s impossible to adopt USG

I am equally frustrated -  I can set the device IP (to 192.168.1.2) , and can browse to it on my mac when its connected only to the USG - connect the USG to my windows network and I cant even browse to the USG so of course I can't adopt it, even though it shows up as a disovered device waiting to be adopted... Using putty on the windows network I cant even logon to the USG. password fails every time. I cant reset it on the windows network because 192.168.1.1. is the comcast gateway. 

Perhaps my Comcast modem is getting in the way ? Otherwise what the F am I doing wrong? I have reset and reconfigured the IP of this USG many times. 

Established Member
Posts: 1,061
Registered: ‎02-18-2017
Kudos: 356
Solutions: 33

Re: Adoption Failed: It’s impossible to adopt USG


@wififorall wrote:

I am equally frustrated -  I can set the device IP (to 192.168.1.2) , and can browse to it on my mac when its connected only to the USG - connect the USG to my windows network and I cant even browse to the USG so of course I can't adopt it, even though it shows up as a disovered device waiting to be adopted... Using putty on the windows network I cant even logon to the USG. password fails every time. I cant reset it on the windows network because 192.168.1.1. is the comcast gateway. 

Perhaps my Comcast modem is getting in the way ? Otherwise what the F am I doing wrong? I have reset and reconfigured the IP of this USG many times. 


What you are doing wrong is that the modem and USG are both on the 192.168.1.x subnet.

 

The USG exists to take what is in the Modem side of the router and route that to your private IP range on your network.

 

The Quick Start guide (that no-one ever reads) points this out very clearly. 

 

The fastest way way to get up and running is to change the IP address of the Comcast Modem to 192.168.0.1 and set the USG to DHCP. 

 

If the IP address of the Comcast Modem is not changeable then you need to change the DHCP range of the USG to be something other than 192.168.1.x - so 192.168.0.1 for the USG and then all your internal networking devices will be on the 192.168.0.x subnet. 

 

Whatever that 3rd number in the IP address is for the Modem, the USG must be something different. Once you have that sorted out, it’s all gravy. 

Member
Posts: 230
Registered: ‎08-14-2015
Kudos: 76
Solutions: 6

Re: Adoption Failed: It’s impossible to adopt USG

I have fought this recently and after a major re-subnetting and a failure to adopt I did a factory reset (5 seconds) and still no joy. I found the lack of adoption was related to the need to UNCHECK "check ssh key" when trying to manually re-adopt a KNOWN device.

 

Mark

Reply