Reply
Highlighted
New Member
Posts: 25
Registered: ‎08-10-2017
Accepted Solution

Changing the Inform URL of the same Controller

Hi I have almost 12 site and all are working fine on a DDNS inform URL now I have the static IP on the Controller and I put that IP in the GoDaddy Subdomain.

 

Old: abc.dyndns.org

New: unifi.abc.com

 

Now, how can I change all the devices to do the inform to the new URL.


Accepted Solutions
Regular Member
Posts: 377
Registered: ‎11-11-2015
Kudos: 140
Solutions: 38

Re: Changing the Inform URL of the same Controller

The quickest way to mass-update inform URLs to all devices:

  1. Verify unifi.abc.com resolves correctly in DNS first.
  2. Enter unifi.abc.com into the Settings > Controller > Controller Settings > Controller Hostname/IP field
  3. Enable Override inform host with controller hostname/IP
  4. Click Apply Changes.

From now on, regardless of the URL used to initially connect to the controller, the controller will force http://unifi.abc.com:8080/inform as the provisioned Inform URL.

View solution in original post


All Replies
New Member
Posts: 26
Registered: ‎05-01-2018
Kudos: 4
Solutions: 2

Re: Changing the Inform URL of the same Controller

Last time I had to do this I VPNed into my clients and changed the devices via SSH. There may be an easier way that I am not aware of though?

Established Member
Posts: 1,815
Registered: ‎02-01-2014
Kudos: 462
Solutions: 65

Re: Changing the Inform URL of the same Controller

[ Edited ]

Hi there,

If you go to Settings-> Controller-> Controller Settings, you could setup the Controller Hostname/IP and check "Override inform host with controller hostname/IP". This I believe, will set the APs to the correct destination. BUT I am afraid to try it myself as i don't want my external sites to stop responding.

I saw your post and am interested in the answer. I am sorry if this doesn't help. I didn't mean to post and get in the way.

 

Edit- Yes you can always SSH into each device and change the inform URL to the new one. That would take a while most likely and most of the time people don't have SSH access setup for each site.

New Member
Posts: 25
Registered: ‎08-10-2017

Re: Changing the Inform URL of the same Controller

This I already tested and this appear in the email when the controller send the device status etc.

{8F79E90D-52BC-408D-A608-76490BCEF9B3}.png.jpg{E9225213-B92A-44A9-9C8B-502801B86282}.png.jpg

Established Member
Posts: 1,815
Registered: ‎02-01-2014
Kudos: 462
Solutions: 65

Re: Changing the Inform URL of the same Controller

Thats strange. Are you sure you put the correct inform URL in? The inform URL is supposed to look like this: http://ip-of-controller:8080/inform. The port 8443 is to login to the controller GUI.
Regular Member
Posts: 377
Registered: ‎11-11-2015
Kudos: 140
Solutions: 38

Re: Changing the Inform URL of the same Controller

The quickest way to mass-update inform URLs to all devices:

  1. Verify unifi.abc.com resolves correctly in DNS first.
  2. Enter unifi.abc.com into the Settings > Controller > Controller Settings > Controller Hostname/IP field
  3. Enable Override inform host with controller hostname/IP
  4. Click Apply Changes.

From now on, regardless of the URL used to initially connect to the controller, the controller will force http://unifi.abc.com:8080/inform as the provisioned Inform URL.

New Member
Posts: 25
Registered: ‎08-10-2017

Re: Changing the Inform URL of the same Controller

[ Edited ]

So I follow the steps you mentioned. But the local devices are informing to the IP address and the remote devices are still on the DDNS I used before.{18E0EB24-70BC-461C-A352-5B45EC03A43E}.png.jpg

New Member
Posts: 25
Registered: ‎08-10-2017

Re: Changing the Inform URL of the same Controller

[ Edited ]

It Took few time and now all the sites are informing on the new URL I mentioned in the Settings > Controller > Controller Settings > Controller Hostname/IP field

Reply