Emerging Member
Posts: 47
Registered: ‎02-09-2018
Kudos: 1

Edgerouter with UniFi Switches - gotchas?

Hello all,

 

I plan to set-up a small office building with UniFi APs and switches (for the backbone), however, I'd like to install an Edgerouter ER-4 instead of a USG for a couple reasons:

 

  • the client is asking me to save money wherever possible, and the ER-4 should give us a lot of power/bandwidth, at a very low price
  • I'm simply more familiar with the ER (firewall set-up, VLANs, etc)

I know this is doable, but other than sacrificing the "fully integrated" look-and-feel and the nice throughput stats with using a USG, is there anything else functionality-wise I'd be giving up?  It appears I can still leverage UniFi's switch port profiles as long as I create the individual VLAN-Only networks in UniFi that match the VLANs on the ER?

 

Thank you!!

 

Regular Member
Posts: 468
Registered: ‎08-07-2016
Kudos: 279
Solutions: 40

Re: Edgerouter with UniFi Switches - gotchas?

It will work. Just as you said, it will make a bit more work keeping configs synchronized.

Be careful that Unifi reserves VLAN1 for that default “LAN” network. No way to change it. So either embrace it by having it be your management VLAN or totally abandon it.
Emerging Member
Posts: 47
Registered: ‎02-09-2018
Kudos: 1

Re: Edgerouter with UniFi Switches - gotchas?

I'm totally fine with using that for admin as long as the default LAN can be changed to say, a 10.x.x.x network instead of 192.168.x.x, just in case for some reason the WAN side needs to use 192.168.  It would appear I can change it.  And I presume I can safely ignore that it says it's using this USG interface?

 

 

Screen Shot 2018-11-04 at 9.18.16 PM.png

 

 Thanks for your help!

 

Member
Posts: 482
Registered: ‎09-23-2018
Kudos: 56
Solutions: 25

Re: Edgerouter with UniFi Switches - gotchas?

If your EdgeRouter is configured properly, then you should be safe to create your interfaces within UniFi and it should route properly.

 

The UniFi controller is letting you know "if you want to use this feature, use our USG. If you don't, it may not work as intended and you'll need to do other configuration outside of just clicking these buttons."

 

If you have the EdgeRouter configured properly, you should be fine