Reply
New Member
Posts: 1
Registered: ‎09-24-2018

Experiencing high UDP packet loss on US-16-XG

Hi everyone,

I'm having 4 of US-16-XG as core switch and experiencing high UDP packet loss rate.
Here is my test setup:
2 servers are at the same spec:
CPU : 2xE5-2620 V4
RAM: DDR4 64GB ECC
NIC: Mellanox ConnectX-3 EN 10gbps SFP+
SFP+ :  UF-MM-10G (at US-16-XG also)


US-16-XG version 3.9.42.9152
Unifi cloud keyV1 version 5.9.29-11384-1

 

UDP test

server A :  iperf3 -s -V
server B :  iperf3 -c <serverA IP address> -u -b 10G -P 8  

 

Test Complete. Summary Results:
[ ID] Interval Transfer Bandwidth Jitter Lost/Total Datagrams
[ 5] 0.00-10.03 sec 1.18 GBytes 1.01 Gbits/sec 0.099 ms 19898/155039 (13%)
[ 6] 0.00-10.03 sec 1.15 GBytes 986 Mbits/sec 0.100 ms 19193/150893 (13%)
[ 8] 0.00-10.03 sec 1.18 GBytes 1.01 Gbits/sec 0.070 ms 20766/155082 (13%)
[ 10] 0.00-10.03 sec 1.15 GBytes 984 Mbits/sec 0.067 ms 19397/150567 (13%)
[ 12] 0.00-10.03 sec 1.25 GBytes 1.07 Gbits/sec 0.075 ms 22480/163790 (14%)
[ 14] 0.00-10.03 sec 1.18 GBytes 1.01 Gbits/sec 0.091 ms 19195/154579 (12%)
[ 16] 0.00-10.03 sec 1.18 GBytes 1.01 Gbits/sec 0.100 ms 20242/154618 (13%)
[ 18] 0.00-10.03 sec 1.15 GBytes 982 Mbits/sec 0.097 ms 19288/150361 (13%)
[SUM] 0.00-10.03 sec 9.42 GBytes 8.07 Gbits/sec 0.087 ms 160459/1234929 (13%)   <--- LOSS 13%
CPU Utilization: local/receiver 10.1% (0.7%u/9.4%s), remote/sender 99.6% (3.7%u/95.9%s)
iperf 3.0.11

 


TCP test 

server A : iperf3 -s -V

server B :  iperf3 -c <serverA IP address>


Connecting to host hydra8, port 5201
[ 4] local <client IP address> port 47972 connected to <server IP address> port 5201
[ ID] Interval Transfer Bandwidth Retr Cwnd
[ 4] 0.00-1.00 sec 1.04 GBytes 8.91 Gbits/sec 11 779 KBytes
[ 4] 1.00-2.00 sec 1.05 GBytes 9.06 Gbits/sec 330 625 KBytes
[ 4] 2.00-3.00 sec 1.05 GBytes 9.02 Gbits/sec 0 728 KBytes
[ 4] 3.00-4.00 sec 1.06 GBytes 9.09 Gbits/sec 0 872 KBytes
[ 4] 4.00-5.00 sec 1.05 GBytes 9.01 Gbits/sec 0 1.05 MBytes
[ 4] 5.00-6.00 sec 1.05 GBytes 9.01 Gbits/sec 0 1.17 MBytes
[ 4] 6.00-7.00 sec 1.06 GBytes 9.10 Gbits/sec 0 1.26 MBytes
[ 4] 7.00-8.00 sec 1.06 GBytes 9.09 Gbits/sec 379 796 KBytes
[ 4] 8.00-9.00 sec 1.05 GBytes 8.99 Gbits/sec 0 1008 KBytes
[ 4] 9.00-10.00 sec 1.06 GBytes 9.07 Gbits/sec 0 1.13 MBytes
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval Transfer Bandwidth Retr
[ 4] 0.00-10.00 sec 10.5 GBytes 9.04 Gbits/sec 720 sender   <---  HAVE SOME RETRIED
[ 4] 0.00-10.00 sec 10.5 GBytes 9.03 Gbits/sec receiver

 

So I move these two server to Cisco SG350XG-24F  Firmware 2.4.0.94 
(move SFP+ module from US-16-XG to plug into Cisco)
No UDP packet loss or TCP retried at all.

 

Switch iperf3 server to serverB and client to serverA also result about the same.


What should I look into unifi controller to inprove its performance, reduce packet loss?

Reply