Reply
New Member
Posts: 13
Registered: ‎01-18-2015
Kudos: 1

Re: Having serious issues with UniFi Security Gateway 3P - Freezes everyday!

[ Edited ]

im on 4.4.29.5124210 and am having issues as well.

 

the gateway disappears from the ui, things are infact running just very badly, cant get dhcp leases half the time.  reboot seems to have it recover.

 

Edit:

   ssh server isnot responding on the device but it is flipping packets.

New Member
Posts: 2
Registered: ‎07-23-2017
Kudos: 2

Re: Having serious issues with UniFi Security Gateway 3P - Freezes everyday!

I have two sites with 4.4.29 running and both have exhibited the same weird freezing behavior. 

 

Tried to downgrade to 4.4.22 and it threw a config error so now I’m back on 4.4.29. Hopefully this bug gets ID’d and patched soon. 

New Member
Posts: 2
Registered: ‎01-09-2018

Re: Having serious issues with UniFi Security Gateway 3P - Freezes everyday!

Same issue with freezing here on 4.4.29. Definitely started after the upgrade. 100% stable pre 4.4.28. If is firmware all the way. Question is, will when Ubiquity have new stable release? I agree there needs to be less focus on new features and more on new firmware updates that don't compromise the product stability. Ubiquity, what can us users do to provide you enough data to catch and clean this bug?
New Member
Posts: 3
Registered: ‎10-18-2018
Kudos: 1

Re: Having serious issues with UniFi Security Gateway 3P - Freezes everyday!

I have a brand new Security Gatewy 3P and it has proven to be quite unreliable too. @ 1 month old.

The device requires a reboot @ once a week.

When the gateway freezes, the APs drop off the network. Wired devices still have internet access.

 

My set up includes:

1 AP AC Pro, 1 Security Gateway, 1 Switch 8 150, 1 AP in wall.

All the devices have the latest firmware.

I have a total of 6 devices connected to the network. 

I do have DPI and intrusion prevention turned on.

 

Does anyone have any useful insite to this issue? I am curious if it is heat related as the unit seems to always feel hot.

 

 

 

New Member
Posts: 4
Registered: ‎04-21-2018

Re: Having serious issues with UniFi Security Gateway 3P - Freezes everyday!

At jojogte's suggestion I downgraded my USG 3P from 4.4.29 to 4.4.22, and it has been stable ever since.  Now I face the question of when it is safe to upgrade again and to what?

New Member
Posts: 3
Registered: ‎10-18-2018
Kudos: 1

Re: Having serious issues with UniFi Security Gateway 3P - Freezes everyday!

Thank you milleri (and jojogte), I will try the downgrade.
New Member
Posts: 2
Registered: ‎10-25-2018

Re: Having serious issues with UniFi Security Gateway 3P - Freezes everyday!

Having the same issue here. USG 3P freezes almost daily. Wife is loosing faith in Ubiquiti...Apple router (almost) never froze.

 

Reapplied 4.4.29 and downloaded 4.4.22 as a backup.

Screen Shot 2018-11-10 at 8.05.34 AM.png
New Member
Posts: 4
Registered: ‎01-14-2018
Kudos: 1

Re: Having serious issues with UniFi Security Gateway 3P - Freezes everyday!

what firmware are you running?  I had similar problems with 4.4.29, rolled back to 4.4.22 and has been stable for several weeks now.

New Member
Posts: 4
Registered: ‎01-14-2018
Kudos: 1

Re: Having serious issues with UniFi Security Gateway 3P - Freezes everyday!

roll back to 4.4.22 firmware

New Member
Posts: 4
Registered: ‎01-14-2018
Kudos: 1

Re: Having serious issues with UniFi Security Gateway 3P - Freezes everyday!

I had same issue.  This is how I fixed:

turn off auto firmware upgrade then go back down to 4.4.22. 

after downgrade, shut down everything,

then start with modem on, then router, then switches.  should fix the config errors. 

make sure you leave auto upgrade off or you will be right back to 4.4.29 and have same problems. 

New Member
Posts: 2
Registered: ‎06-12-2017

Re: Having serious issues with UniFi Security Gateway 3P - Freezes everyday!

Same problem here. With v4.4.29 the USG freezes after a few days. The firmware seems to be really unstable. I watch it for a few more days and then I downgrade it.

Unifi please report!

New Member
Posts: 3
Registered: ‎10-02-2016

Re: Having serious issues with UniFi Security Gateway 3P - Freezes everyday!

This could be the same issue I ran into here: https://community.ubnt.com/t5/UniFi-Routing-Switching/USG-Repeated-Partial-Lock-Up-amp-Disconnecting...

 

In my case, disabling martian packet logging seems to have stabilized things. I normally have a reasonably low volume of martian packets logged but that volume increased last night for some reason I don't understand. Last night all of the sudden I couldn't get the USG to stay up for more than 10 minutes and then it would lock up requiring a physical power cycle of the device. 

 

I had to follow the steps here: https://community.ubnt.com/t5/EdgeRouter/Martians-won-t-stop/td-p/1238666 to disable martian packet logging. There's a step later on down in the thread that says to change:

 

# Log packets with impossible addresses to kernel log

net.ipv4.conf.all.log_martians=1

 

to 0 in /etc/sysctl.d/30-vyatta-router.conf but that did not fix it. I still had to do the steps in the beginning to disable it. Without doing both, it didn't seem to change permanently.

 

Here's another post that seems to indicate the same. https://www.reddit.com/r/Ubiquiti/comments/9f09le/martian_packets_crash_edgerouterx/

 

The system has been stable now for about 10 hours. It's incredibly frustrating and I was ready to punt my USG across the street last night. I'm running on 4.4.29 at two sites.

New Member
Posts: 3
Registered: ‎10-18-2018
Kudos: 1

Re: Having serious issues with UniFi Security Gateway 3P - Freezes everyday!

It is not clear if anyone from Ubnt reads these postings. I have contacted support on this issue and they have not responded with any urgency or insight to the issue.

Established Member
Posts: 1,556
Registered: ‎01-29-2015
Kudos: 210
Solutions: 58

Re: Having serious issues with UniFi Security Gateway 3P - Freezes everyday!

[ Edited ]

4.4.22 had memory leak issues for me, and many others. I went all the way back to 4.4.18 and all is well.

New Member
Posts: 3
Registered: ‎10-02-2016

Re: Having serious issues with UniFi Security Gateway 3P - Freezes everyday!

I tried to post this earlier but I'm not sure where it went. Anyway I started having this issue last night on 4.4.29 as well. My USG wouldn't stay up for more then 5-10min at a time and it looks like it was due to the USG crashing when receiving a large amount of martian packets. The USG is set to log them as is the ER-X. I followed the instructions here and it seems to have resolved it.

 

https://community.ubnt.com/t5/EdgeRouter/Martians-won-t-stop/td-p/1238666

 

I had to follow both solutions, first one is changing the settings during run time and the second was to change net.ipv4.conf.all.log_martians=1 to net.ipv4.conf.all.log_martians=0 in /etc/sysctl.d/30-vyatta-router.conf on the USG. Here's a similar thread: https://community.ubnt.com/t5/UniFi-Routing-Switching/USG-Repeated-Partial-Lock-Up-amp-Disconnecting... and then there's a post on reddit too about martian packet logging and usg lockups.

New Member
Posts: 1
Registered: ‎11-30-2018
Kudos: 1

Re: Having serious issues with UniFi Security Gateway 3P - Freezes everyday!

Hi there,

 

I have a similar issue. With 4.4.29 and IPS detection activated the gateway survives more or less a week. After that it freezes to a point that current wired connections keep mostly working and the wireless connection is gone. The strange thin also is that you don’t see any information in the logs of the gateway. At some point the logging stops and you can’t really use it to find out what’s going wrong.

 

If I disable the IPS detection, then it seems that the gateway is working fine.

 

So in my humble opinion the Beta of IPS is generating the problems.

 

Hope this helps.

 

New Member
Posts: 4
Registered: ‎04-21-2018

Re: Having serious issues with UniFi Security Gateway 3P - Freezes everyday!

I've been rock solid stable on 4.4.22 for months now.  I also agree with those who suggest that the issue seems to be related to IDS/IPS.  Has anyone upgraded to 4.4.36?  And if so, is it stable?  Thanks in advance.

New Member
Posts: 2
Registered: ‎10-25-2018

Re: Having serious issues with UniFi Security Gateway 3P - Freezes everyday!

I have upgraded a single nano to 4.4.36 and the AP has disconnected for hours at a time 2 - 3 times since the update. I have IPS on.

New Member
Posts: 5
Registered: ‎11-02-2018

Re: Having serious issues with UniFi Security Gateway 3P - Freezes everyday!

Same here. Purchased a 3 and a 4 (Pro). On 4.4.36.5146617 and it dropped its WAN connection every 3-4 hours. Will be returning both devices given trend seen here.

 

In contrast, my pfSense boxes have been on for months, connected (house, cabin), with streaming video from security cams passing thru.

House: 1x USG4, 1x sw-48x500w, 1x sw-8x60w, 3x sw-8, 2x ap-NanoHD, 1x ap-LR, 1x Cloudkey2
Cabin:1x USG3, 1x sw-8x60w, 3x sw-8, 1x ap-NanoHD, 1x Win10-Cloudkey
Member
Posts: 174
Registered: ‎01-20-2018
Kudos: 28
Solutions: 3

Re: Having serious issues with UniFi Security Gateway 3P - Freezes everyday!

I’m grabbing a netgate router with pfsense as a backup to give it a shot. Ran untangle for a while which worked great until my appliance broke. Giving UniFi a try to see how it goes. I kinda miss all the features that untangle had.
Reply