New Member
Posts: 2
Registered: ‎11-12-2018

MikroTik managed switch not working with Unifi VLANs

Hi all,

need some advice pertaining to VLAN configuration on MikroTik switches. I've configured the following VLANs on my Unifi switch, using port profiles:

  1. Corporate LAN (untagged, subnet 192.168.1.x)

  2. IOT network (VLAN 20, subnet 192.168.3.x)

  3. Fibre TV (VLAN only, ID 1091)

I need to pull a trunk (piping all 3 VLAN traffic) into the living room, plugging into a MikroTik RB250GS switch. While the MikroTik switch works for untagged traffic, I can't get the VLAN configuration to work. For instance, plugging into the IOT port doesn't grab an IP at all, where I'm supposed to connect to 2).


The trunk port's profile is configured to "All". If I set the trunk's port profile to either 1, 2, 3 - this will work but I will lose the flexibility on the MikroTik switch. Have tried 802.1x control on the US-8 switch, but to no avail. Also tried applying a "trunk" port profile (tagging all 3 networks), but no dice too.


Have attached my Microtik configuration below. Appreciate some advice!


This is my last ditch attempt before getting another Unifi switch...